Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1435840 - [LLNL 7.5 FEAT] rebase conman to 0.2.8
[LLNL 7.5 FEAT] rebase conman to 0.2.8
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: conman (Show other bugs)
7.4
Unspecified Unspecified
medium Severity medium
: rc
: 7.5
Assigned To: Ondrej Vasik
Jan Houska
Lenka Špačková
: FutureFeature, Rebase
Depends On:
Blocks: 1461180 1522983 1400611 1465906 1465925
  Show dependency treegraph
 
Reported: 2017-03-24 20:03 EDT by Ben Woodard
Modified: 2018-04-10 05:55 EDT (History)
11 users (show)

See Also:
Fixed In Version: conman-0.2.8-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_conman_ rebased to version 0.2.8 The _conman_ packages have been upgraded to upstream version 0.2.8, which provides a number of bug fixes and enhancements over the previous version. Notable changes include: * Scalability has been improved. * *Coverity Scan* and *Clang* warnings have been fixed to improve stability. * Arbitrary limit on the number of Intelligent Platform Management Interface (IPMI) Serial Over LAN (SOL) consoles has been fixed. * The default value of the `loopback` setting has been changed to `ON` in the `conman.conf` file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 05:55:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0683 None None None 2018-04-10 05:55 EDT

  None (edit)
Description Ben Woodard 2017-03-24 20:03:05 EDT
Description of problem:
LLNL which is also the upstream requests that we rebase conman to 0.2.8 to pick up some performance improvements and fixes needed for their site.


Version-Release number of selected component (if applicable):
0.2.7
Comment 3 Ben Woodard 2017-03-25 00:56:07 EDT
From: Chris Dunlap <cdunlap@llnl.gov>
Subject: Re: [Bug 1022502] Spec file URLs should point to new home page
Date: March 24, 2017 at 5:36:11 PM PDT
To: Ben Woodard <woodard@redhat.com>

Thanks!

You should be able to drop all 4 patches from conman-0.2.7-15.
In fact, conman-0.2.7-hack-around-overflow-issue.patch is wrong and
should be dropped regardless.  I noted that with the patch's author
last year but didn't realized he added it to Red Hat's rpm until now.
I was finally able to see the Coverity Scan results back in Nov when
I found out their scan results are free for open-source projects.

 https://github.com/dun/conman/pull/24

-Chris
Comment 4 Ondrej Vasik 2017-03-27 03:02:24 EDT
Is this really request for rebase of conman in RHEL 7? Is there some good reason behind it? Usually we don't rebase components in released major version of RHEL unless there is some good reason for it.

As for Fedora, I see Dan Horak already built 0.2.8 in Rawhide - https://koji.fedoraproject.org/koji/buildinfo?buildID=866738 , adding him to CC of this bugzilla. Dan, can you please make sure if Chris's comments are addressed by your rebase in Rawhide? Thanks!
Comment 5 Dan Horák 2017-03-27 04:04:30 EDT
My initial intention on the Fedora side was cleaning up the spec file (mainly for bug #1244218), but because there was a new release available with a number of fixes mentioned in conman's release notes I've rebased it as well. The Fedora version is now clean upstream version, so except some packaging differences it's what Ben/Chris ask for. Although freeipmi is still 1.5.4 in Fedora while 1.5.5 is available, it might be what Chris means in comment #2.
Comment 7 Ben Woodard 2017-03-27 12:10:59 EDT
The reasons for the rebase are:
1) one of the patches currently being applied introduces a bug
2) the other patches are part of the the 0.2.8 release. LLNL which is upstream made sure that our fixes were incorporated -- except when they were wrong and introduced additional bugs.
3) There are other performance issues that have shown up in the 0.2.7 release which were addressed in the 0.2.8 release.
Comment 19 errata-xmlrpc 2018-04-10 05:55:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0683

Note You need to log in before you can comment on or make changes to this bug.