Bug 143637 - Firefox crashes when opening link
Firefox crashes when opening link
Status: CLOSED DUPLICATE of bug 155582
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
Depends On:
  Show dependency treegraph
Reported: 2004-12-22 23:55 EST by Carl Gherardi
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-06-01 00:35:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Carl Gherardi 2004-12-22 23:55:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041216 Firefox/1.0 Fedora/1.0-6

Description of problem:
Was looking at some snooker stuff and went to look at a results page


Firefox crashed - then did it again when I attempted to open the page again after reloading firefox.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Open link shown above.
2. Crash  

Additional info:
Comment 1 Brian Vuyk 2004-12-23 01:33:19 EST
Link worked OK for me with firefox-1.0-6...
Comment 2 Carl Gherardi 2004-12-23 02:44:42 EST
It may be of signficance - i'm blocking any cookies prompted, and have
the cookie settings as:

Allow sites to set cookies, for the originating site only, and ask
every time.

I block everything except sites I must access that require it.

The only messages i'm getting hen run from the console are.

[carlos@coeus ~] firefox --gtk-debug
INTERNAL ERROR on Browser End: Could not read ack from child process
System error?:: Resource temporarily unavailable

There isn't a firefox-debug package, so i'm lost on how to get more

This happens _every_ time I try to access the page.
Comment 3 Warren Togami 2004-12-23 14:41:04 EST
What java plugin and version do you have installed?  I don't have a java plugin,
and it doesn't crash for me.
Comment 4 Carl Gherardi 2004-12-23 21:17:22 EST
Comment 5 Jean-David Beyer 2005-03-29 07:56:46 EST
Summary: Me too.

I am running

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
 Gecko/20050317 Firefox/1.0.2

on a Red Hat Enterprise Linux 3 system and Firefox crashes way to much for me too.

$ uname -a
Linux trillian.localdomain 2.4.21-27.0.2.ELsmp #1 SMP
 Wed Jan 12 23:35:44 EST 2005 i686 i686 i386 GNU/Linux

The plugin directory I have looks like this:

[/usr/local/mozilla/firefox-installer/plugins]$ ls -l
total 780
drwxr-xr-x    2 root     root         4096 Mar 29 07:35 HIDE
-rw-r--r--    1 root     root         2363 Mar 25 00:51 ShockwaveFlash.class
-rwxr-xr-x    1 root     root       765852 Mar 25 00:51 libflashplayer.so
lrwxrwxrwx    1 root     root           58 Mar 25 00:43 libjavaplugin_oji.so ->
-rwxr-xr-x    1 root     root        18840 Mar 17 07:29 libnullplugin.so
lrwxrwxrwx    1 root     root           40 Mar 24 18:08 nphelix.so ->
lrwxrwxrwx    1 root     root           41 Mar 24 18:08 nphelix.xpt ->

When I click on the link (shown earlier)


it crashes everytime for me as well (but lots of links crash like that).
Konqueror does not crash on this link.
Comment 6 Luya Tshimbalanga 2005-04-28 13:45:58 EDT
Firefox is crashing with Flash plugin installed. I used Wtogami flash build to
get that result. 
Even with rebuilt version, I got the crashing result while I didn't have that
problem with FC3.(In reply to comment #3)
Comment 7 Shane Nuessler 2005-05-31 22:17:51 EDT
Please add the following line to the firefox executable script uner /usr/bin

(I found a report on the web, and someone had tracked the problem back to the
fact that firefox was running on xorg 6.8.1 with, I believe but please check,
composite extension enabled.)

Comment 8 Warren Togami 2005-06-01 00:35:10 EDT

*** This bug has been marked as a duplicate of 155582 ***

Note You need to log in before you can comment on or make changes to this bug.