Bug 155582 - flash crashes with X COMPOSITE
flash crashes with X COMPOSITE
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: flash-plugin (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
: 143637 189847 192355 202068 202299 204273 (view as bug list)
Depends On:
Blocks: flash_el4
  Show dependency treegraph
 
Reported: 2005-04-21 12:10 EDT by Brian Millett
Modified: 2009-10-18 19:21 EDT (History)
17 users (show)

See Also:
Fixed In Version: flash-plugin-9.0.31.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-17 13:31:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of xdpyinfo (6.10 KB, text/plain)
2006-08-24 00:27 EDT, Thomas Cameron
no flags Details
gdb output - not much help (452 bytes, text/plain)
2006-08-24 08:18 EDT, Daniel Walsh
no flags Details
strace output (2.88 MB, text/plain)
2006-08-24 08:21 EDT, Daniel Walsh
no flags Details

  None (edit)
Description Brian Millett 2005-04-21 12:10:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
With flash plugin installed, firefox & mozilla cores when visiting a page with the flash plugin needed (www.motorola.com).  The only debug info I can get is:

The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 117 error_code 8 request_code 146 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. go to a site that requires flash
2.install
3.whatch it die
  

Actual Results:  firefox dies when visiting a flash enabled url

Expected Results:  not that.  I should still have a browser.

Additional info:
Comment 1 Warren Togami 2005-04-21 16:27:19 EDT
This seems to be a FC4 problem, FC3 firefox-1.0.3-1.3.1 is fine.

It dies on ANY site with Flash?
Comment 2 Brian Millett 2005-04-21 17:21:36 EDT
Yes it does.  I am sorry that I can not
be more specific, but it used to work.  Its been +- 2 weeks since it
started doing this.
Comment 3 Warren Togami 2005-04-29 01:47:35 EDT
Did you happen to turn on X's COMPOSITE extension?
Are you running with selinux enabled?
Comment 4 Brian Millett 2005-04-29 07:25:57 EDT
Thanks Warren.
  
I did not turn on X's COMPOSITE extension, but that does not mean that it was
not turned on by accedent.  How do I check for it?

SELinux = disabled.
Comment 5 Brian Millett 2005-04-29 07:38:10 EDT
Warren you're a genius!

I did a quick google and saw where it is enabled in the xorg.conf.  I did
a quick check (I did not set it).
[bpm]$ ls -l xorg*
-rw-r--r--  1 root root 2881 Apr 29 06:28 xorg.conf
-rw-r--r--  1 root root 2880 Apr 11 08:41 xorg.conf.backup
-rw-r--r--  1 root root 2811 Sep 29  2004 xorg.conf.hold
-rw-r--r--  1 root root 2816 Aug  1  2004 xorg.conf.O18180
-rw-r--r--  1 root root 2816 Jul 31  2004 xorg.conf.Vg4791
[bpm]$ grep -i composite xorg*
xorg.conf:     Option      "Composite" "Enable"
xorg.conf.backup:       Option      "Composite" "Enable"

Gee about the time I got a "new" xorg.conf.backup is when flash started dieing.
I commented it out, restarted X11, reloaded flash, FIXED!!.

So it looks like a configuration problem from one of the updates.  Nice thing 
to remember when flash just dies unexpectantly.

Thanks.  I love rawhide, I learn soo much from it.
Comment 6 Warren Togami 2005-06-01 00:35:30 EDT
*** Bug 143637 has been marked as a duplicate of this bug. ***
Comment 9 Warren Togami 2005-11-15 11:57:11 EST
It looks like FC5+ will have X composite enabled by default in order to support
advanced hardware accelerated desktop rendering, so it is now urgent to get this
fixed.  By all indications it should be simple to fix once the problem is
understood.  I am in communication with Macromedia about this issue.  Further
known details to be posted here soon.
Comment 10 Warren Togami 2005-11-15 12:41:12 EST
http://lists.freedesktop.org/pipermail/release-wranglers/2004-August/000852.html
Technical analysis by X.org developer Keith Packard
Comment 11 Kristian Høgsberg 2005-11-15 12:58:38 EST
Additionally, to understand the difference between an X server with COMPOSITE
enabled and one without it, the xdpyinfo command can be used to inspect the list
of visuals offered by the server.  With composite enabled, the X server provides
two different visuals:

  number of visuals:    2
  default visual id:  0x21
  visual:
    visual id:    0x21
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff0000, 0xff00, 0xff
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x36
    class:    TrueColor
    depth:    32 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff0000, 0xff00, 0xff
    significant bits in color specification:    8 bits

The 0x21 visual is a regular 24 bit RGB visual, but the 0x36 visual is a 32 bit
RGBA visual, i.e. the visual provides an extra channel for per pixel alpha
information.

Without COMPOSITE enabled, xdpyinfo only lists one visual, the regular 24 bit
RGB visual:

  number of visuals:    1
  default visual id:  0x21
  visual:
    visual id:    0x21
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff0000, 0xff00, 0xff
    significant bits in color specification:    8 bits
Comment 13 Warren Togami 2006-06-17 14:32:36 EDT
*** Bug 189847 has been marked as a duplicate of this bug. ***
Comment 14 Warren Togami 2006-07-19 15:58:00 EDT
*** Bug 192355 has been marked as a duplicate of this bug. ***
Comment 15 Andre Robatino 2006-07-26 15:04:37 EDT
  After reading

http://www.redhat.com/archives/fedora-list/2006-July/msg03579.html

I found that visiting the site http://www.dluxproductions.com/webcandy/ reliably
causes my browser to immediately crash (I have the flash-plugin-7.0.63-1 RPM
installed).  Uninstalling flash-plugin allows me to view the page.  My browser
does NOT usually crash on other websites that use Flash, though it happens
non-reproducibly on occasion.  I'm running FC5, and the xdpyinfo command says
that my number of visuals is 16, but there is no "Composite" line in xorg.conf.
 Is this the same bug?
Comment 16 Andre Robatino 2006-07-26 15:12:59 EDT
  I just found that I can view the page without crashing by clicking on an email
link (I tried it when I got the email for the preceding comment).  However, it
crashes reliably if I visit via a bookmark, or via copy-and-paste.  Viewing this
page and clicking on the link in the above comment also seems to cause a
reliable crash.
  If this bug exists in FC5, it should be bumped up to FC5.
Comment 17 Warren Togami 2006-08-10 15:59:01 EDT
*** Bug 202068 has been marked as a duplicate of this bug. ***
Comment 18 Thomas Cameron 2006-08-24 00:27:54 EDT
Created attachment 134773 [details]
Output of xdpyinfo

I am seeing the same issue on RHEL5-Server-20060823.1 as well.
Comment 19 Daniel Walsh 2006-08-24 07:31:17 EDT
I am having this problem in FC6 Test2 all over the place.  I use SELinux to turn
off firefox ability to read libflashplayer by changing the file context and the
pages work.  When I correct the libraries file context seamonkey and firefox crash.
Comment 20 Daniel Walsh 2006-08-24 08:18:36 EDT
Created attachment 134802 [details]
gdb output - not much help
Comment 21 Daniel Walsh 2006-08-24 08:21:56 EDT
Created attachment 134803 [details]
strace output 

I can get this to happen by going to www.ford.com
Comment 22 Warren Togami 2006-08-24 11:20:24 EDT
export XLIB_SKIP_ARGB_VISUALS=1 should work as a workaround until Adobe fixes
this in their next release.
Comment 23 Warren Togami 2006-08-28 09:06:11 EDT
*** Bug 204273 has been marked as a duplicate of this bug. ***
Comment 24 Rickey Moore 2006-09-13 14:07:58 EDT
(In reply to comment #22)
> export XLIB_SKIP_ARGB_VISUALS=1 should work as a workaround until Adobe fixes
> this in their next release.
How do I implement this? And where? 

Comment 25 Warren Togami 2006-09-13 15:49:12 EDT
Edit /usr/bin/firefox and add "export XLIB_SKIP_ARGB_VISUALS=1" near the top,
close firefox completely, then run it again.

Be warned that upgrading firefox to new versions via RPM later (for security
reasons or anything) will blow away your change to that script.
Comment 26 Otha Stubblefield 2006-09-21 12:52:30 EDT
I have an AMD 3800+ running FC5.  Firefox version firefox-1.5.0.7-1.fc5.  While
trying to download and execute Flash 9 content, firefox doesn't just crash, but
takes the whole system down with it!  The entire screen will turn white or white
with pinstripes.
Comment 27 Warren Togami 2006-09-21 17:04:30 EDT
Otha, if a user-level application is causing your entire system to crash, it is
a problem at either the X, kernel, or hardware level.  You are not describing a
Flash bug.
Comment 28 Otha Stubblefield 2006-09-21 17:37:57 EDT
Maybe crash is too broad a term, but the screen will turn all white or all white
with pinstripes and not respond to any keyboard or mouse input.  Trying to
access the computer through ssh (to kill off a jammed gnome session) also
failed.  I did the export XLIP_SKIP_ARGB_VISUALS=1 and have not gotten any
crashes since.  While there probably is some other issue going on with my
system, I don't think that it can be assumed that flash wasn't the root cause,
since trying to access flash >= 8 content is the only time this happens. 
Anyway, it appears to be fixed for now.  Thanks!
Comment 29 Warren Togami 2006-09-21 18:33:47 EDT
XLIP_SKIP_ARGB_VISUALS=1 preventing your system from crashing might indicate
that you have a video driver problem.  I am guessing that you are using NVidia
or ATI proprietary drivers?  In any case the root cause of your system crash is
NOT Flash.  It is your X or kernel drivers.  Flash just might have found a
unique way of exposing a crash.
Comment 30 Otha Stubblefield 2006-09-25 15:25:43 EDT
Thanks Warren.  The XLIP...didn't just seemed to fix it.  I sifted through the
logs and found that fc5 was having trouble identifying a driver for the ATI
Express 200 onboard video system.  While I didn't have flash problems in
Windows, I did have enough other problems such that I decided to replace the
motherboard with an nVidia based one.  Things are now back to normal.  Sorry to
have troubled everyone.
Comment 33 Michael Tilburg 2006-10-23 14:03:20 EDT
This is fixed in the Flash Player 9 beta.  You can donwload it from: 

http://labs.adobe.com/downloads/flashplayer9.html
Comment 34 Warren Togami 2006-10-24 15:20:36 EDT
We aren't allowed to package Flash Player 9 beta.  I can close this bug only
after we push an updated package.
Comment 35 Warren Togami 2007-01-10 15:33:31 EST
*** Bug 202299 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.