Bug 1436386 - Ensure RGW passes all upstream Swift Tempest tests in RefStack toolset (Refstack 15.0) [NEEDINFO]
Summary: Ensure RGW passes all upstream Swift Tempest tests in RefStack toolset (Refs...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 3.2
Assignee: Marcus Watts
QA Contact: vidushi
Bara Ancincova
URL:
Whiteboard:
: 1455856 (view as bug list)
Depends On: 1250713 1455856
Blocks: 1629656 1261979 1273812 1305654 1383917 1438965
TreeView+ depends on / blocked
 
Reported: 2017-03-27 20:02 UTC by Federico Lucifredi
Modified: 2019-01-03 19:01 UTC (History)
32 users (show)

Fixed In Version: RHEL: ceph-12.2.1-16.el7cp Ubuntu: ceph_12.2.1-18redhat1
Doc Type: Bug Fix
Doc Text:
.Red Hat Ceph Storage passes the Swift Tempest test in the RefStack 15.0 toolset Various improvements have been made to the Ceph Object Gateway Swift service. As a result, when configured correctly, Red Hat Ceph Storage 3.2, which includes the `ceph-12.2.8` package, passes the Swift Tempest `tempest.api.object_storage` test suite with the exception of the `test_container_synchronization` test case. Red Hat Ceph Storage includes a different synchronization model, multisite operations, for users who require that feature.
Clone Of: 1252600
Environment:
Last Closed: 2019-01-03 19:01:20 UTC
david_paterson: needinfo?


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:01:49 UTC
Ceph Project Bug Tracker 16602 None None None 2017-03-27 20:02:51 UTC
Red Hat Bugzilla 1252600 None CLOSED Ensure RGW passes all upstream Swift Tempest tests in RefStack toolset 2019-07-17 09:44:50 UTC

Internal Links: 1252600

Comment 17 John Poelstra 2017-05-31 15:24:09 UTC
*** Bug 1455856 has been marked as a duplicate of this bug. ***

Comment 18 Harish NV Rao 2017-05-31 15:26:57 UTC
based on https://bugzilla.redhat.com/show_bug.cgi?id=1455856#c24 moving this to assigned state

Comment 91 Federico Lucifredi 2017-09-28 19:47:18 UTC
@matt - yes, I was commenting for the Doc team :)

Comment 97 Federico Lucifredi 2017-10-13 20:30:10 UTC
Is my understanding correct that this has been completed successfully now?

Comment 154 David Paterson 2018-12-07 16:48:28 UTC
I have insured that
rgw_print_prohibited_content_length = true
rgw_content_length_compat = true is set in ceph.conf and restarted the RGW service on all three controllers and I am still seeing the following failure for all object store tests.


Captured traceback:
~~~~~~~~~~~~~~~~~~~
    Traceback (most recent call last):
      File "/home/osp_admin/refstack-client/.tempest/tempest/api/object_storage/test_account_services.py", line 248, in test_list_containers_with_prefix
        self.assertHeaders(resp, 'Account', 'GET')
      File "/home/osp_admin/refstack-client/.tempest/tempest/api/object_storage/base.py", line 145, in assertHeaders
        target, method, self.policies))
      File "/home/osp_admin/refstack-client/.tempest/.venv/lib/python2.7/site-packages/testtools/testcase.py", line 498, in assertThat
        raise mismatch_error
    testtools.matchers._impl.MismatchError: accept-ranges header does not exist


Ceph version is: 12.2.5-59.el7cp (d4b9f17b56b3348566926849313084dd6efc2ca2) luminous (stable)

Comment 161 errata-xmlrpc 2019-01-03 19:01:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.