Bug 1250713 - config_tempest.py breaks if Rados Gateway is configured for object-store
Summary: config_tempest.py breaks if Rados Gateway is configured for object-store
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation
Version: 1.2.3
Hardware: All
OS: All
unspecified
high
Target Milestone: rc
: 2.2
Assignee: Bara Ancincova
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: 1172300 1251237 1252600 1273812 1436386
TreeView+ depends on / blocked
 
Reported: 2015-08-05 19:35 UTC by David Paterson
Modified: 2017-03-27 20:02 UTC (History)
36 users (show)

Fixed In Version: RHEL: ceph-10.2.5-31.el7cp Ubuntu: ceph_10.2.5-23redhat1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1251237 (view as bug list)
Environment:
Last Closed: 2017-03-14 15:42:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0514 normal SHIPPED_LIVE Red Hat Ceph Storage 2.2 bug fix and enhancement update 2017-03-21 07:24:26 UTC
Ceph Project Bug Tracker 8945 None None None 2016-09-15 07:08:05 UTC
Red Hat Bugzilla 1252600 None CLOSED Ensure RGW passes all upstream Swift Tempest tests in RefStack toolset 2019-07-17 13:24:19 UTC

Internal Links: 1252600

Description David Paterson 2015-08-05 19:35:56 UTC
Description of problem: If the Rados Gateway is configured as object-store instead of swift the tools/config_tempest.py script will break


Version-Release number of selected component (if applicable):
OSP7 RC2

How reproducible:
Every time

Steps to Reproduce:
1. Install tempest
2. run config_tempest script with appropriate arguments.

Actual results:
Fails with exception: 
CRITICAL tempest [-] ServiceError: Request on service 'object-store' with url 'http://192.168.190.246:8087/info' failed with code 404
TRACE tempest Traceback (most recent call last):
TRACE tempest   File "tools/config_tempest.py", line 726, in <module>
TRACE tempest     main()
TRACE tempest   File "tools/config_tempest.py", line 140, in main
TRACE tempest     clients.identity_region)
TRACE tempest   File "/root/tempest/tempest/common/api_discovery.py", line 154, in discover
TRACE tempest     services[name]['extensions'] = service.get_extensions()
TRACE tempest   File "/root/tempest/tempest/common/api_discovery.py", line 111, in get_extensions
TRACE tempest     top_level_path="info")
TRACE tempest   File "/root/tempest/tempest/common/api_discovery.py", line 53, in do_get
TRACE tempest     " with code %d" % (self.name, url, r.status))
TRACE tempest ServiceError: Request on service 'object-store' with url 'http://192.168.190.246:8087/info' failed with code 404


Expected results:
Script generates ./etc/tempest.conf

Additional info:
The reason this is happening is because RadowGW does not implement the /info api call.

Comment 6 arkady kanevsky 2015-08-05 21:48:23 UTC
Mike O,
need you help to have this BZ targeted for 7.0.

We need to handle it differently for short term and long term.
For long term Ceph RGW need to respond correctly so both config_tempest.py and for tempest swift tests. That will be Ceph bug. Neil, you decide which Ceph release it will land.

For short term, we need to fix config_tempest.py to "ignore" ceph swift responses. We should try to get it into CDN OSP7 bits ASAP. once we have a fix for config_tempest.py we can "apply" it in scripts for Tempest deployment on tempest VM.

Comment 7 Neil Levine 2015-08-11 21:11:59 UTC
*** Bug 1252600 has been marked as a duplicate of this bug. ***

Comment 8 Neil Levine 2015-08-11 21:25:05 UTC
There is barely any documentation about the /info API call:

http://docs.openstack.org/developer/swift/api/discoverability.html

Assigning this to one of our Swift devs as it's hard to know what to implement in lieu of proper documentation.

Comment 24 Ian Colle 2016-09-15 07:08:06 UTC
Merged upstream https://github.com/ceph/ceph/pull/10280

Comment 25 Ken Dreyer (Red Hat) 2016-09-15 17:25:02 UTC
Matt will you be backporting this to jewel?

If so, http://tracker.ceph.com/issues/8945 should be marked "Backport: jewel".

If not, this BZ should be re-targeted to RHCS 3.

Comment 43 errata-xmlrpc 2017-03-14 15:42:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0514.html


Note You need to log in before you can comment on or make changes to this bug.