Bug 143701 - Could handle missing splash image better
Could handle missing splash image better
Status: CLOSED DUPLICATE of bug 112330
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-24 08:23 EST by Nigel Horne
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 11:13:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2004-12-24 08:23:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
If splashimage points to a missing file, it would be better if
grub defaulted to a text mode, however the screen is blank and
you're left wondering what to do. Not even a warning message
that the splash image can't be found appears.

Version-Release number of selected component (if applicable):
grub-0.95-3

How reproducible:
Always

Steps to Reproduce:
1. Edit /etc/grub.conf so that splash image points to a non existant
hard drive partition, e.g. splashimage=(hd0,9)/grub/splash.xpm.gz
2. reboot
3.
    

Actual Results:  You probably get a blank screen, at best you get a
garbled display

Expected Results:  A text mode default and an error message that
splashimage can't be found.

Additional info:
Comment 1 Robert Scheck 2004-12-30 13:52:05 EST
I totally agree with you, it's a worse problem. 

Maybe the bootsplash image should be checked for availability *and* readability,
because with bug #143879 I currently run into the same result.
Comment 2 Bill Nottingham 2005-01-04 14:22:56 EST

*** This bug has been marked as a duplicate of 112330 ***
Comment 3 Peter Jones 2005-01-04 14:52:15 EST
It's not *really* a dup, just very closely related.  I want to leave
it open for now.
Comment 4 Peter Jones 2005-01-05 11:13:32 EST
Nevermind, it is a dup, I was looking at the wrong bug.

*** This bug has been marked as a duplicate of 112330 ***

Note You need to log in before you can comment on or make changes to this bug.