Bug 143704 - DHclient -r doesn't release IP address as it should
DHclient -r doesn't release IP address as it should
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks: 170780
  Show dependency treegraph
 
Reported: 2004-12-24 10:08 EST by Gael
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.0.1-16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 04:31:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gael 2004-12-24 10:08:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
DHCLIENT from Fedora core 3

the command dhclient -r doesn't release the ip address

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.dhclient -r
2.
3.
    

Expected Results:  ip adress should be released from DHCP server

Additional info:
Comment 1 Jason Vas Dias 2005-01-03 17:40:45 EST
The dhclient '-r' release lease option seems to work only
if the dhclient process that got the lease being released
is not running, or is run outside of the /sbin/ifup network
scripts - ie. doing:
  # ifdown eth0
  # ifconfig eth0 up 
  # dhclient eth0
  # dhclient -r eth0
works fine for me.
But if you do:
  # ifup eth0
  # dhclient -r eth0
This will not work; the dhclient process started by 'ifup' is
still around because the 'dhclient -r' process cannot find its
pid file, which is /var/run/dhclient-eth0.pid, and will 
reacquire the lease when it expires. 
You can get around this by doing:
  # dhclient -pf /var/run/dhclient-eth0.pid -r
but this is a pain.
I've now made a dhcp-3.0.1-16 rpm where in release mode, dhclient
will look for the pid file for each requested interface and kill
the dhclient process for that interface if found.
I will get it issued via FC3 updates; meanwhile, you can download it
from:

  http://people.redhat.com/~jvdias/dhcp/FC3/

with dhcp-3.0.1-16, doing a 'dhclient -r eth0' will have the same
effect as 'ifdown eth0' in killing the dhclient instance for eth0.




Note You need to log in before you can comment on or make changes to this bug.