Bug 170780 - DHclient -r doesn't release IP address as it should
DHclient -r doesn't release IP address as it should
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: dhcp (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Popelka
:
Depends On: 143704
Blocks: 190430
  Show dependency treegraph
 
Reported: 2005-10-14 11:15 EDT by Jason Vas Dias
Modified: 2010-04-06 08:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-06 08:50:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Vas Dias 2005-10-14 11:15:38 EDT
+++ This bug was initially created as a clone of Bug #143704 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
DHCLIENT from Fedora core 3

the command dhclient -r doesn't release the ip address

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.dhclient -r
2.
3.
    

Expected Results:  ip adress should be released from DHCP server

Additional info:

-- Additional comment from jvdias@redhat.com on 2005-01-03 17:40 EST --
The dhclient '-r' release lease option seems to work only
if the dhclient process that got the lease being released
is not running, or is run outside of the /sbin/ifup network
scripts - ie. doing:
  # ifdown eth0
  # ifconfig eth0 up 
  # dhclient eth0
  # dhclient -r eth0
works fine for me.
But if you do:
  # ifup eth0
  # dhclient -r eth0
This will not work; the dhclient process started by 'ifup' is
still around because the 'dhclient -r' process cannot find its
pid file, which is /var/run/dhclient-eth0.pid, and will 
reacquire the lease when it expires. 
You can get around this by doing:
  # dhclient -pf /var/run/dhclient-eth0.pid -r
but this is a pain.
I've now made a dhcp-3.0.1-16 rpm where in release mode, dhclient
will look for the pid file for each requested interface and kill
the dhclient process for that interface if found.
I will get it issued via FC3 updates; meanwhile, you can download it
from:

  http://people.redhat.com/~jvdias/dhcp/FC3/

with dhcp-3.0.1-16, doing a 'dhclient -r eth0' will have the same
effect as 'ifdown eth0' in killing the dhclient instance for eth0.
Comment 1 Jason Vas Dias 2005-10-14 11:16:37 EDT
fixed with dhcp-3.0.1-40_EL3+
Comment 7 Jiri Popelka 2010-04-06 08:50:38 EDT
Closing as WONTFIX. dhcp-3.0.1-10_EL3 is the latest version shipped for RHEL-3.

Note You need to log in before you can comment on or make changes to this bug.