Bug 143767 - ia32el doesn't use the values of kernel parameters about core file.
ia32el doesn't use the values of kernel parameters about core file.
Status: CLOSED DUPLICATE of bug 143769
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ia32el (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-27 06:38 EST by L3support
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-27 07:00:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L3support 2004-12-27 06:38:28 EST
Description of problem:
ia32el doesn't use kernel parameters related to core file when ia32el
creates a elf32 core file.

Version-Release number of selected component (if applicable):
ia32el-1.1-13.ia64.rpm 

How reproducible:
always

Steps to Reproduce:
1. set kernel parameters

   # echo /tmp/mycore-%e-%p-%t > /proc/sys/kernel/core_pattern
   # echo 0 > /proc/sys/kernel/core_uses_pid 
   #
   # cat /proc/sys/kernel/core_pattern
   /tmp/mycore-%e-%p-%t
   # cat /proc/sys/kernel/core_uses_pid
   0

2. compile test program

   <elf64>
   compile on ia64 machine
   # cat test.c
   main()
   {
       int *p, *q;
       p=0;
       *q=*p;
   }
   # cc -o test_ia64 test.c
   
   <elf32>
   compile on i32 machine
   # cc -o test_ia32 test.c

3. run test program

   # pwd
   /var/tmp/work
   # ./test_ia64
   Segmentation fault (core dumped)
   # ./test_ia32
   Segmentation fault (core dumped)
   
   # ls /tmp
   mycore-test_ia64-17731-1104145866
   # ls /var/tmp/work
   core.17732
  
Actual results:
   # ls /var/tmp/work
   core.17732

Expected results:
   # ls /tmp
   mycore-test_ia32-17732-xxxxxxxxxxx

Additional info:
Comment 1 Jakub Jelinek 2004-12-27 07:00:51 EST

*** This bug has been marked as a duplicate of 143769 ***

Note You need to log in before you can comment on or make changes to this bug.