Bug 143769 - ia32el doesn't use the values of kernel parameters about core file.
Summary: ia32el doesn't use the values of kernel parameters about core file.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ia32el   
(Show other bugs)
Version: 4.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
: 143767 (view as bug list)
Depends On:
Blocks: 168429 169570 170718
TreeView+ depends on / blocked
 
Reported: 2004-12-27 11:53 UTC by L3support
Modified: 2007-11-30 22:07 UTC (History)
10 users (show)

Fixed In Version: RHBA-2006-0131
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 18:16:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0131 qe-ready SHIPPED_LIVE ia32el bug fix update 2006-03-06 05:00:00 UTC

Description L3support 2004-12-27 11:53:12 UTC
Description of problem:
ia32el doesn't use kernel parameters related to core file when ia32el
creates a elf32 core file.

Version-Release number of selected component (if applicable):
ia32el-1.1-13.ia64.rpm 

How reproducible:
always

Steps to Reproduce:
1. set kernel parameters

   # echo /tmp/mycore-%e-%p-%t > /proc/sys/kernel/core_pattern
   # echo 0 > /proc/sys/kernel/core_uses_pid 
   #
   # cat /proc/sys/kernel/core_pattern
   /tmp/mycore-%e-%p-%t
   # cat /proc/sys/kernel/core_uses_pid
   0

2. compile test program

   <elf64>
   compile on ia64 machine
   # cat test.c
   main()
   {
       int *p, *q;
       p=0;
       *q=*p;
   }
   # cc -o test_ia64 test.c
   
   <elf32>
   compile on i32 machine
   # cc -o test_ia32 test.c

3. run test program

   # pwd
   /var/tmp/work
   # ./test_ia64
   Segmentation fault (core dumped)
   # ./test_ia32
   Segmentation fault (core dumped)
   
   # ls /tmp
   mycore-test_ia64-17731-1104145866
   # ls /var/tmp/work
   core.17732
  
Actual results:
   # ls /var/tmp/work
   core.17732

Expected results:
   # ls /tmp
   mycore-test_ia32-17732-xxxxxxxxxxx

Additional info:

Comment 1 Jakub Jelinek 2004-12-27 12:00:58 UTC
*** Bug 143767 has been marked as a duplicate of this bug. ***

Comment 2 Yoav Zach 2004-12-27 12:09:30 UTC
The severity and priority of this entry are both set to normal. Is this 
correct ?

Thanks,
Yoav.

Comment 3 Jakub Jelinek 2004-12-27 12:14:26 UTC
Maybe low is more appropriate, not sure.

Comment 4 Yoav Zach 2004-12-27 18:02:55 UTC
we already have a fix for this problem internaly, but it obviously won't make 
it into RHEL4 at this point. i suggest we resolve this entry with 'closed 
deffered'. any objections to that ?

thanks,
yoav.

Comment 5 L3support 2004-12-28 01:05:00 UTC
It doesn't matter to me. But could you tell me when the fixed version
is released? Is it included in RHEL4 RC or GM?

Thanks,

Comment 6 Yoav Zach 2004-12-28 06:14:58 UTC
it missed the train for RHEL4. it will probably be distributed in one 
of the updates.
thanks,
yoav.

Comment 7 Jakub Jelinek 2004-12-28 09:34:56 UTC
I guess it is a RHEL4 U1 candidate.  For that we should keep the bug open though
and as soon as bugzilla has RHEL4 as Product/Version pair this bug should be
moved there.

Comment 8 RHEL4-L3support 2005-01-19 02:17:37 UTC
Add RHEL4-L3support team in Japan

Comment 9 L3support 2005-02-09 05:02:38 UTC
Has the fixed version been registered as RHEL4 U1 candidate?

Thanks,

Comment 11 Jakub Jelinek 2005-02-09 20:16:23 UTC
ia32el-1.2-2 has the changes in.

Comment 12 Jay Turner 2005-02-10 12:14:07 UTC
Changing this to MODIFIED so that we can test.  The package is built into
4E-lacd-U1.

Comment 13 Jakub Jelinek 2005-03-30 17:04:25 UTC
Unfortunately what is in ia32el-1.2-3 doesn't match kernel's core_pattern
handling.  ia32el handles core_pattern as a string and if
/proc/sys/kernel/core_uses_pid is not 0, appends .%p expanded to it.
But kernel expands %h in /proc/sys/kernel/core_pattern into hostname, %p into
pid, %u into uid, etc., and if /proc/sys/kernel/core_uses_pid is not 0
or the process has multiple threads, appends pid if core_pattern did not contain
%p.
I think for U1 we need to keep this as is, but would be good to fix it for
U2.

Comment 14 Jay Turner 2005-04-18 08:44:37 UTC
Moving this to the U2 tracker list.

Comment 28 Yoav Zach 2005-11-08 12:23:02 UTC
I believe this issue is fixed in U2. Fujitsu - can you please verify and 
close ? Jay - I could not find the corresponding tracker. Do you know what it 
is ?
Thanks,
Yoav.

Comment 29 Jakub Jelinek 2005-11-08 12:29:17 UTC
It is definitely not fixed in U2, nor in 5.3.102.39.23.
There were some changes in U1, but not sufficient, see comment #13.
I haven't looked into newer sources yet to see if it got fixed there.

Comment 30 Yoav Zach 2005-11-08 13:12:52 UTC
Your'e right - the fix was in 5.3.104.39.24. Sorry for the confusion. Do you 
know what's the issue-tracker # for this ?
Thanks,
Yoav.

Comment 31 Jay Turner 2005-11-08 15:42:43 UTC
IT#66088

Comment 33 Jakub Jelinek 2005-11-16 11:56:17 UTC
ia32el-1.3-2 built into 4E-lacd-qu-candidate.

Comment 38 Red Hat Bugzilla 2006-03-07 18:16:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0131.html



Note You need to log in before you can comment on or make changes to this bug.