Bug 1438139 - The Subscription Details table in All Available Subscriptions Tab is too small to show the details
Summary: The Subscription Details table in All Available Subscriptions Tab is too smal...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
Depends On: 1437761 1438561
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-01 06:20 UTC by Wei Liu
Modified: 2017-08-01 19:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:22:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
Subscription_Detail.png (193.98 KB, image/png)
2017-04-01 06:21 UTC, Wei Liu
no flags Details
All_availablesubscription (415.00 KB, image/png)
2017-04-20 11:14 UTC, Rehana
no flags Details


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1585 None None None 2017-04-12 20:12:51 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Wei Liu 2017-04-01 06:20:03 UTC
Description of problem:
The Subscription Details table in All Available Subscriptions Tab is too small to show the content.Just a little details of subscription is shown.

Version-Release number of selected component (if applicable):
[root@ibm-x3250m4-16 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7

How reproducible:
always

Steps to Reproduce:
1.Install build RHEL-7.4-20170330.1
2.Open subscription-manager gui,register the system and auto-attach one subscription
3.Go to All Available Subscriptions Tab and click "Update" button,then select one available subscription and see the details in the below table

Actual results:
The Subscription Details table is too small and can just show little details.As shown in the attachment Subscription_Detail.png.

Expected results:
Adjust the size of Subscription Details table to show more details clearly

Additional info:

Comment 2 Wei Liu 2017-04-01 06:21:13 UTC
Created attachment 1268034 [details]
Subscription_Detail.png

Comment 4 Chris Snyder 2017-04-10 18:30:10 UTC
This is currently blocked by a fix for https://bugzilla.redhat.com/show_bug.cgi?id=1437761 .

Unable to reproduce as subscription-manager-gui seg faults before I am able to see the screen in question populated.

Comment 6 Rehana 2017-04-20 11:13:06 UTC
Retested with ;

subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.8-1.el7
python-rhsm: 1.19.5-1.el7


Observed that now "subscription Details" section is wide enough  to show the details.

Marking as Verified !!

Comment 7 Rehana 2017-04-20 11:14:17 UTC
Created attachment 1272918 [details]
All_availablesubscription

Comment 8 errata-xmlrpc 2017-08-01 19:22:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.