Bug 1438561 - DBusException: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
Summary: DBusException: org.freedesktop.DBus.Error.NoReply: Message did not receive a ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
: 1437761 (view as bug list)
Depends On:
Blocks: 1438139
TreeView+ depends on / blocked
 
Reported: 2017-04-03 18:45 UTC by John Sefler
Modified: 2017-08-01 19:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:22:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1573 'None' closed 1438561: Do not use D-Bus for facts collection 2020-08-13 17:34:00 UTC
Red Hat Bugzilla 1437761 'high' 'CLOSED' 'Failed to register a system and auto attach subscription from GUI' 2019-11-25 03:05:15 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Internal Links: 1437761

Description John Sefler 2017-04-03 18:45:48 UTC
Description of problem:
I do not have a predictably reproducible scenario; however, automated testing has encountered this exception several times.


Version-Release number of selected component (if applicable):
subscription-manager-1.19.4-1.el7
python-rhsm-1.19.2-1.el7

How reproducible:


Steps to Reproduce:
Taken from an automated test log that was testing in the stage environment....

ssh root@ibm-x3550m3-07.lab.eng.brq.redhat.com subscription-manager list --available
Stdout:
Stderr: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
ExitCode: 70

Last request from /var/log/rhsm/rhsm.log:
2017-03-30 21:32:16,929 [DEBUG] subscription-manager:12742:MainThread @connection.py:473 - Making request: GET /subscription/owners/7964055/pools?consumer=0d8975a8-8400-4e6a-a009-3f425f0ca843
2017-03-30 21:32:18,436 [INFO] subscription-manager:12742:MainThread @connection.py:509 - Response: status=200, requestUuid=268b7e91-fed9-4f55-ac59-e200be523559, request="GET /subscription/owners/7964055/pools?consumer=0d8975a8-8400-4e6a-a009-3f425f0ca843"
2017-03-30 21:32:18,441 [DEBUG] subscription-manager:12742:MainThread @managerlib.py:550 - Filtering 0 total pools
2017-03-30 21:32:18,441 [DEBUG] subscription-manager:12742:MainThread @managerlib.py:556 - Removed 0 incompatible pools
2017-03-30 21:32:18,441 [DEBUG] subscription-manager:12742:MainThread @managerlib.py:589 - 13 pools to display, -13 filtered out
2017-03-30 21:32:21,558 [DEBUG] subscription-manager:12802:MainThread @https.py:54 - Using standard libs to provide httplib and ssl
2017-03-30 21:32:21,659 [DEBUG] subscription-manager:12802:MainThread @dbus_interface.py:35 - self.has_main_loop=False
2017-03-30 21:32:21,721 [DEBUG] subscription-manager:12802:MainThread @ga_loader.py:89 - ga_loader GaImporterGtk3
2017-03-30 21:32:21,729 [DEBUG] subscription-manager:12802:MainThread @plugins.py:569 - loaded plugin modules: [<module 'container_content' from '/usr/share/rhsm-plugins/container_content.pyc'>, <module 'ostree_content' from '/usr/share/rhsm-plugins/ostree_content.pyc'>]
2017-03-30 21:32:21,729 [DEBUG] subscription-manager:12802:MainThread @plugins.py:570 - loaded plugins: {'container_content.ContainerContentPlugin': <container_content.ContainerContentPlugin object at 0x1221590>, 'ostree_content.OstreeContentPlugin': <ostree_content.OstreeContentPlugin object at 0x1221b50>}
2017-03-30 21:32:21,729 [DEBUG] subscription-manager:12802:MainThread @identity.py:132 - Loading consumer info from identity certificates.
2017-03-30 21:32:21,732 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: 4ec9f295c2574dc886c39f257ec1b2d3
2017-03-30 21:32:21,735 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: df37c3bee99a46bfb9381f811c618952
2017-03-30 21:32:21,736 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: ba5f0fb1aa254078aed093beeff20e3d
2017-03-30 21:32:21,744 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: 622ace7400e04be489bf2d48548b8620
2017-03-30 21:32:21,747 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: b3ff4922d3cf426696f2dbf2b65a0d47
2017-03-30 21:32:21,749 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: b9c61af2f62f41cc8bd682fbfea3021f
2017-03-30 21:32:21,751 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: b4e53509ccaa4486ab0d79c1bd4ac60c
2017-03-30 21:32:21,753 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: 02b2d368c6bf4a0d8e11665246e7fd44
2017-03-30 21:32:21,755 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: 8e269961f3c34c4686a5383a5c7a62ed
2017-03-30 21:32:21,758 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: fdb58925dab84e789c8efc2c15e70999
2017-03-30 21:32:21,759 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: a308f3cb0f81441fb5d291c2f21a205a
2017-03-30 21:32:21,761 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: 49fb05375c594178b032822529e69f5c
2017-03-30 21:32:21,762 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: 6f00f3d0241b4274a6be906699969f06
2017-03-30 21:32:21,765 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: d17bed845319445ab2c239cce252dbff
2017-03-30 21:32:21,767 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: 79c452e434764c5793fc05d1276b6066
2017-03-30 21:32:21,769 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: 51fb7afda1a74488b6267ac05d4e5784
2017-03-30 21:32:21,771 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: d078f46514bc4d3d8e0bbee48d90eb41
2017-03-30 21:32:21,773 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: 9cd7b6fb1e234c39adb5feb9443e57cf
2017-03-30 21:32:21,775 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: 6cdba655efe440c788a2ebdf515a7547
2017-03-30 21:32:21,778 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: 291d6ab78c6f4541b14e8fec83fa98a3
2017-03-30 21:32:21,780 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: f8ddf9d26bb742a9ab9a2b16bd5962ec
2017-03-30 21:32:21,782 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: e75cfdbf15444a2aacf79f7b85fad2e5
2017-03-30 21:32:21,785 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: 4b0084e3f52b46a1877848cd2b2a051b
2017-03-30 21:32:21,787 [INFO] subscription-manager:12802:MainThread @managercli.py:316 - X-Correlation-ID: 47a6ded7ad2b4611935850319cf8d19b
2017-03-30 21:32:21,788 [INFO] subscription-manager:12802:MainThread @managercli.py:394 - Client Versions: {'python-rhsm': '1.19.2-1.el7', 'subscription-manager': '1.19.4-1.el7'}
2017-03-30 21:32:21,789 [INFO] subscription-manager:12802:MainThread @connection.py:763 - Connection built: host=subscription.rhsm.stage.redhat.com port=443 handler=/subscription auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
2017-03-30 21:32:21,789 [INFO] subscription-manager:12802:MainThread @connection.py:763 - Connection built: host=subscription.rhsm.stage.redhat.com port=443 handler=/subscription auth=none
2017-03-30 21:32:21,790 [INFO] subscription-manager:12802:MainThread @managercli.py:369 - Consumer Identity name=ibm-x3550m3-07.lab.eng.brq.redhat.com uuid=0d8975a8-8400-4e6a-a009-3f425f0ca843
2017-03-30 21:32:21,790 [DEBUG] subscription-manager:12802:MainThread @cache.py:157 - Checking current system info against cache: /var/lib/rhsm/facts/facts.json
2017-03-30 21:32:21,915 [ERROR] subscription-manager:12802:MainThread @managercli.py:179 - exception caught in subscription-manager
2017-03-30 21:32:21,915 [ERROR] subscription-manager:12802:MainThread @managercli.py:180 - org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
Traceback (most recent call last):
File "/usr/sbin/subscription-manager", line 89, in <module>
sys.exit(abs(main() or 0))
File "/usr/sbin/subscription-manager", line 80, in main
return managercli.ManagerCLI().main()
File "/usr/lib/python2.7/site-packages/subscription_manager/managercli.py", line 2792, in main
return CLI.main(self)
File "/usr/lib/python2.7/site-packages/subscription_manager/cli.py", line 160, in main
return cmd.main()
File "/usr/lib/python2.7/site-packages/subscription_manager/managercli.py", line 544, in main
return_code = self._do_command()
File "/usr/lib/python2.7/site-packages/subscription_manager/managercli.py", line 2372, in _do_command
filter_string=self.options.filter_string)
File "/usr/lib/python2.7/site-packages/subscription_manager/managerlib.py", line 325, in get_available_entitlements
overlapping, uninstalled, text, filter_string)
File "/usr/lib/python2.7/site-packages/subscription_manager/managerlib.py", line 529, in get_filtered_pools_list
self.identity.uuid, active_on=active_on, filter_string=filter_string):
File "/usr/lib/python2.7/site-packages/subscription_manager/managerlib.py", line 283, in list_pools
require(FACTS).update_check(uep, consumer_uuid)
File "/usr/lib/python2.7/site-packages/subscription_manager/cache.py", line 158, in update_check
if self.has_changed() or force:
File "/usr/lib/python2.7/site-packages/subscription_manager/facts.py", line 69, in has_changed
self.facts = self.get_facts(True)
File "/usr/lib/python2.7/site-packages/subscription_manager/facts.py", line 79, in get_facts
facts = facts_dbus_client.GetFacts()
File "/usr/lib/python2.7/site-packages/rhsmlib/dbus/facts/client.py", line 57, in GetFacts
return self.interface.GetFacts(*args, **kwargs)
File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
return self._proxy_method(*args, **keywords)
File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
**keywords)
File "/usr/lib64/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

Comment 2 Kevin Howell 2017-04-05 13:57:26 UTC
I suspect that bug 1437761 is a duplicate of this bug, I'll leave both open until we know for sure.

Comment 3 Kevin Howell 2017-04-17 17:45:57 UTC
*** Bug 1437761 has been marked as a duplicate of this bug. ***

Comment 5 John Sefler 2017-04-25 16:33:32 UTC
This issue was resolved in automated testruns for all arches of RHEL-7.4-Alpha-1.0 compose RHEL-7.4-20170421.1 with packages...
subscription-manager-1.19.9-1.el7
python-rhsm-1.19.5-1.el7

Moving to VERIFIED

Comment 6 errata-xmlrpc 2017-08-01 19:22:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.