Bug 143844 - FC1-> FC3, anaconda has unhandled exception
FC1-> FC3, anaconda has unhandled exception
Status: CLOSED DUPLICATE of bug 138485
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-29 17:10 EST by Steve Ettorre
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-29 17:15:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Ettorre 2004-12-29 17:10:28 EST
*** This bug has been split off bug 139313 ***

------- Original comment by John Gregg on 2004.11.14 23:24 -------

Description of problem:

I currently run Fedora Core 2, with grub as my boot loader.
I downloaded and burned to CD all 4 iso images for FC3. When
I boot from FC3 disc 1 to install FC3 on my machine, however,
I run into a problem. Right after I accept the default option
with regard to my boot loader (i.e. update my existing one),
I get a box informing me of an unhandled exception. The box
told me to file this bug. Here is just the top screen's worth
of the backtrace:

Traceback (most recent call last):
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py",
line 789,
in nextClicked
    self.dispatch.gotoNext()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py", line
171, in gotoNext
    self.moveStep()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py", line
239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/upgrade.py",
line 396, in upgradeFindPackages
    instPath)
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/findpackageset.py",
line 149, in findpackageset
    val =
rpm.labelCompare(oevr,(epoch,h[rpm.RPMTAG_VERSION],h[rpm.RPMTAG_RELEASE]))
TypeError: argument 1, item 0 must be string or None, not long
                                                                     
          


Version-Release number of selected component (if applicable):

Fedora Core 3

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Paul Nasrat 2004-12-29 17:15:42 EST
Update image available

http://people.redhat.com/pnasrat/updates-138485.img



*** This bug has been marked as a duplicate of 138485 ***

Note You need to log in before you can comment on or make changes to this bug.