Bug 143904 - libusbscanner fuctions incorrectly at times
Summary: libusbscanner fuctions incorrectly at times
Status: CLOSED DUPLICATE of bug 142727
Alias: None
Product: Fedora
Classification: Fedora
Component: sane-backends   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-01 01:06 UTC by Arthur Pemberton
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-04 09:22:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arthur Pemberton 2005-01-01 01:06:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
/etc/hotplug/usb/libusbscanner is not the orginal script that's
included with the gphoto2 source. The changed libusbscanner included
in FC3 assumes that the scanner gets 'plugged' in after the user has
logged in, this apperently does not take into consideration scanners
which are 'plugged' in before/during boot, at which point root is
still the console owner.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Have a scanner (supported by sane) plugged in before booting up
2. Attempt `scanimage -L` as unprivilged user
3. Attempt `scanimage -L` as root
    

Actual Results:  Step 2: provided no scanners in list of detected scanners
Step 3: provided one (1) scanner in list of detected scanners

Expected Results:  Step 2 and Step 3 should yield identical results
(unless explicitly configured not to)

Additional info:

An `ls -l` of the appropriate device files under /proc/bus/usb reveals
permissions on file(s) don't allow access by unpriviled user.

Replacing /etc/hotplug/usb/libusbscanner with the libusbscanner script
provided by sane as part of its hotplug tools, and following the steps
given, solves this problem.

Comment 1 Sitsofe Wheeler 2005-01-01 11:46:38 UTC
This sounds like it could be related to bug #121511

Comment 2 Arthur Pemberton 2005-01-01 23:50:21 UTC
bug #121511 seems to be as a result of the same problem, however I can't be sure
as the person did not provide more details.

Comment 3 Tim Waugh 2005-01-04 09:22:52 UTC
Please try the current updates-testing packages and report back:

  https://bugzilla.redhat.com/beta/show_bug.cgi?id=142727
  https://www.redhat.com/archives/fedora-test-list/2004-December/msg00311.html


*** This bug has been marked as a duplicate of 142727 ***


Note You need to log in before you can comment on or make changes to this bug.