Bug 143924 - hid-core.c: input irq status -84 received
hid-core.c: input irq status -84 received
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-01 09:47 EST by Richard Hill
Modified: 2015-01-04 17:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-26 13:01:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hill 2005-01-01 09:47:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
Some point after booting, the mouse stops working.

syslog is full of
"hid-core.c: input irq status -84 received"

Re-plugging the mouse reactivates it until it fails again.

Mouse is a Microsoft Intellimouse Explorer 3.0 USB  

This is unlikely to be a hardware problem, as no problems occur when 
XP is running.

Motherboard is a MSI K8T Neo2.

Problem occurs whichever port the mouse is plugged into. 
Problem occurs under X86_64 and X86_32.








Version-Release number of selected component (if applicable):
FC2, FC3

How reproducible:
Always

Steps to Reproduce:
1. Any use of the mouse
2.
3.
    

Additional info:
Comment 1 Ed Swierk 2005-01-07 14:34:00 EST
I'm seeing the problem with FC3 (i686) running on a ThinkPad T21 with
a Logitech USB mouse.

This seems to be a regression in kernel-2.6.9-1.724_FC3; everything
was fine with the previous version (2.6.9-1.681_FC3).
Comment 2 Richard Hill 2005-01-12 08:23:30 EST
Mouse appears to work normally under XP, but now I notice that now 
and then the LED in the mouse blinks.  Could this be when XP is 
resetting the USB driver ?  

Mouse fails anywhere within a few seconds to a few minutes under 
Linux.
Comment 3 Adam Bowns 2005-02-16 19:21:51 EST
I'm currently running kernel-2.6.10-1.766_FC3 and I've also been getting the
error message: -

kernel: drivers/usb/input/hid-core.c: input irq status -84 received

popping up in my logs an insane amount of times. My mouse is a Logitech MX
Laser, and it appears to be working fine (I'm not having to plug and unplug or
anything like that). My keyboard is a “Logitech Internet Navigator keyboard” and
is working fine apart from every now and then, when I put my cursor into a new
window and type, the first character I hit is omitted. I don't experience this
problem all the time, it is ONLY the first character I type into a window.

Another message I am getting repeatedly in my logs, which could have something
to do with this bug is: -

kernel: keyboard.c: can't emulate rawmode for keycode 240

and is described in more detail in bug 134443 if anyone wants more info.
Comment 4 Dave Jones 2005-07-15 13:39:25 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 5 Adam Bowns 2005-07-16 14:11:33 EDT
I never experienced any problems with my mouse, so I can’t comment on if that's
been fixed or not. But I can confirm that the error message: -

kernel: drivers/usb/input/hid-core.c: input irq status -84 received

No longer appears on either my FC3 or FC4 systems (Both are fully up to date).
Comment 6 Richard Hill 2005-07-21 02:28:09 EDT
This is still occuring in FC4 (32), but much, much less frequently.  A quick
unplug, replug gets the mouse working again.

Unable to test FC4 (64-bit) as system either hangs or does a reset shortly 
after booting.
Comment 7 Dave Jones 2005-09-30 02:08:21 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 8 Dave Jones 2005-11-10 14:05:53 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 9 Adam Bowns 2005-11-26 09:23:31 EST
kernel-2.6.14-1.1637_FC4 seems to have fixed the problem for me.

Note You need to log in before you can comment on or make changes to this bug.