Bug 143941 - ttmkfdir misses several encodings in TTF files
Summary: ttmkfdir misses several encodings in TTF files
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ttmkfdir   
(Show other bugs)
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Liang Zhang
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 156322 165195
TreeView+ depends on / blocked
 
Reported: 2005-01-02 01:44 UTC by Granville Xiong
Modified: 2015-04-07 03:06 UTC (History)
5 users (show)

Fixed In Version: RHBA-2005-718
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 17:21:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:718 qe-ready SHIPPED_LIVE ttmkfdir bug fix update 2005-10-05 04:00:00 UTC

Description Granville Xiong 2005-01-02 01:44:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Several encodings contained in TTF files are missed in the output file
"fonts.scale" generated by ttmkfdir on Fedora Core 3.

I found this problem accidentally by trying to select a font to make
xmms be able to display English and Chinese at the same time. I ended
up with the "fonts.scale" in /usr/share/fonts/zh_CN/TrueType/:

4
gkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM
GB-medium-r-normal--0-0-0-0-c-0-ascii-0
gkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM
GB-medium-r-normal--0-0-0-0-c-0-iso10646-1
gbsn00lp.ttf -Arphic Technology Co.-AR PL SungtiL
GB-medium-r-normal--0-0-0-0-c-0-ascii-0
gbsn00lp.ttf -Arphic Technology Co.-AR PL SungtiL
GB-medium-r-normal--0-0-0-0-c-0-iso10646-1

I compared this file with the same one on Redhat Enterprise Linux 3.0 ES:

11
gbsn00lp.ttf -Arphic Technology Co.-AR PL SungtiL
GB-medium-r-normal--0-0-0-0-c-0-ascii-0
gbsn00lp.ttf -Arphic Technology Co.-AR PL SungtiL
GB-medium-r-normal--0-0-0-0-c-0-gb2312.1980-0
gbsn00lp.ttf -Arphic Technology Co.-AR PL SungtiL
GB-medium-r-normal--0-0-0-0-c-0-iso10646-1
gkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM
GB-medium-r-normal--0-0-0-0-c-0-ascii-0
gkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM
GB-medium-r-normal--0-0-0-0-c-0-gb2312.1980-0
gkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM
GB-medium-r-normal--0-0-0-0-c-0-iso10646-1
zysong.ttf -misc-ZYSong18030-medium-r-normal--0-0-0-0-c-0-ascii-0
zysong.ttf -misc-ZYSong18030-medium-r-normal--0-0-0-0-c-0-gb18030.2000-1
zysong.ttf -misc-ZYSong18030-medium-r-normal--0-0-0-0-c-0-gb2312.1980-0
zysong.ttf -misc-ZYSong18030-medium-r-normal--0-0-0-0-c-0-gbk-0
zysong.ttf -misc-ZYSong18030-medium-r-normal--0-0-0-0-c-0-iso10646-1

As you can see here, only two encodings are generated for gbsn00lp.ttf
and gkai00mp.ttf on FC3, while each of them has three encodings. More
interestingly the ttmkfdir on FC3 also only generate two encodings for
zysong.ttf:

zysong.ttf -misc-ZYSong18030-medium-r-normal--0-0-0-0-c-0-ascii-0
zysong.ttf -misc-ZYSong18030-medium-r-normal--0-0-0-0-c-0-iso10646-1

But zysong.ttf actually contains FIVE encodings!!!

Then I tried to use the RHEL3-version binary ttmkfdir to generate
fonts.scale on FC3 but I got a "segmentation fault" error. And the
compilation of ttmkfdir-3.0.9-6.src.rpm (from RHEL3) on FC3 failed!

Version-Release number of selected component (if applicable):
ttmkfdir-3.0.9-14

How reproducible:
Always

Steps to Reproduce:
1. On FC3, run the command: ttmkfdir -d
/usr/share/fonts/zh_CN/TrueType/ -o fonts.scale
2. The generated fonts.scale misses all actual chinese encodings!
3.
    

Actual Results:  4
gkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM
GB-medium-r-normal--0-0-0-0-c-0-ascii-0
gkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM
GB-medium-r-normal--0-0-0-0-c-0-iso10646-1
gbsn00lp.ttf -Arphic Technology Co.-AR PL SungtiL
GB-medium-r-normal--0-0-0-0-c-0-ascii-0
gbsn00lp.ttf -Arphic Technology Co.-AR PL SungtiL
GB-medium-r-normal--0-0-0-0-c-0-iso10646-1


Expected Results:  6
gbsn00lp.ttf -Arphic Technology Co.-AR PL SungtiL
GB-medium-r-normal--0-0-0-0-c-0-ascii-0
gbsn00lp.ttf -Arphic Technology Co.-AR PL SungtiL
GB-medium-r-normal--0-0-0-0-c-0-gb2312.1980-0
gbsn00lp.ttf -Arphic Technology Co.-AR PL SungtiL
GB-medium-r-normal--0-0-0-0-c-0-iso10646-1
gkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM
GB-medium-r-normal--0-0-0-0-c-0-ascii-0
gkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM
GB-medium-r-normal--0-0-0-0-c-0-gb2312.1980-0
gkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM
GB-medium-r-normal--0-0-0-0-c-0-iso10646-1


Additional info:

Comment 1 Granville Xiong 2005-03-31 20:08:59 UTC
This bug also exists in all versions of RHEL4. With this bug presented, many
programs that use X font cannot render Asian fonts correctly becuase of the lack
of corresponding entries generated X Font Server. For temporary solution, I
copied the fonts.scale and fonts.dir files for Chinese, Japanese and Korean from
RHEL3 to RHEL4 in order to use these Asian fonts. Please fix it! Thanks a lot!

Comment 3 Jens Petersen 2005-06-03 09:08:10 UTC
Apparently this is caused by ttmkfdir-3.0.9-defautl_enc_size.patch
and ttmkfdir-3.0.9-crashplus.patch.


Comment 4 Granville Xiong 2005-06-07 16:41:16 UTC
So will this bug be fixed soon?

Comment 11 Jens Petersen 2005-06-17 01:48:17 UTC
Sorry, that should end "or not?"

Comment 13 Jens Petersen 2005-06-17 04:32:04 UTC
Any comment from the X team on ttmkfdir vs mkfontscale?

Comment 18 Jens Petersen 2005-08-03 14:02:46 UTC
Should be fixed in FC devel in 3.0.9-17 with a patch by Tagoh.


Comment 20 Jens Petersen 2005-08-03 14:46:43 UTC
Updates for FC3 and FC4 will be forthcoming.

Comment 21 Jens Petersen 2005-08-16 07:07:10 UTC
Updates for FC3 and FC4 went into updates.

Comment 22 Red Hat Bugzilla 2005-10-05 17:21:34 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-718.html



Note You need to log in before you can comment on or make changes to this bug.