Bug 143961 - rhpl should have wireless ext, v17
rhpl should have wireless ext, v17
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 144661 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-02 13:15 EST by Sammy
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-02 11:40:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Make ethtools.c use libiw.so (in rhpl-0.148.1-2) (6.17 KB, patch)
2005-04-15 05:21 EDT, Emre Telatar
no flags Details | Diff
Make ethtools.c use libiw.so (in rhpl-0.158.1) (6.16 KB, patch)
2005-04-15 05:22 EDT, Emre Telatar
no flags Details | Diff

  None (edit)
Description Sammy 2005-01-02 13:15:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; en_US) KHTML/3.3.2 (like Gecko)

Description of problem:
New kernel in FC4 is updated to wireless extension v17 thus the drivers
use that. When one does system-config-network you get warnings about
this. Before rebuilding glibckernheaders and wireless-tools should be
updated (bugs filed saperately.)

Version-Release number of selected component (if applicable):
rhpl-0.151

How reproducible:
Always

Steps to Reproduce:
1.update to FC4 with 2.6.10
2.use a wireless adapter
3.system-config-network
    

Additional info:
Comment 1 Harald Hoyer 2005-01-10 09:12:35 EST
*** Bug 144661 has been marked as a duplicate of this bug. ***
Comment 2 Emre Telatar 2005-04-15 05:19:34 EDT
My Fedora FC3 laptop was reporting:

Warning : Device eth1 has been compiled with version 17
of Wireless Extension, while we are using version 16.
Some things may be broken...

whenever system-config-network was used, while iwconfig -v reported:

iwconfig  Wireless-Tools version 27
          Compatible with Wireless Extension v11 to v17.

Kernel    Currently compiled with Wireless Extension v17.

eth1      Recommend Wireless Extension v16 or later,
          Currently compiled with Wireless Extension v17.

After some digging around, I realized that the warning was coming from the rhpl
package which carries its own private copy of the wireless-tools library in the
form of iwlib.c rather than linking with libiw.so provided by wireless-tools. 
The iwlib.c in rhpl is indeed old.  I patched the ethtools in rhpl source rpm to
link with libiw.so (requires minor changes to the code as some structures and
API has changed) and the warnings disappeared.  I attach two patches, one
against rhpl-0.148.1-2 (I believe the current FC3), the other against
rhpl-0.158.1 (appears to be latest).  Hope it helps.
Comment 3 Emre Telatar 2005-04-15 05:21:31 EDT
Created attachment 113214 [details]
Make ethtools.c use libiw.so (in rhpl-0.148.1-2)
Comment 4 Emre Telatar 2005-04-15 05:22:32 EDT
Created attachment 113215 [details]
Make ethtools.c use libiw.so (in rhpl-0.158.1)
Comment 5 Harald Hoyer 2005-04-15 08:33:29 EDT
cool! many thx! was on my todo list

Note You need to log in before you can comment on or make changes to this bug.