Bug 1439898 - Auth token information missing from requests with no args Edit
Summary: Auth token information missing from requests with no args Edit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron-lbaas
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Brent Eagles
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks: 1378993 1542065
TreeView+ depends on / blocked
 
Reported: 2017-04-06 19:25 UTC by Brent Eagles
Modified: 2019-09-10 14:07 UTC (History)
10 users (show)

Fixed In Version: openstack-neutron-lbaas-10.0.0-8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1542065 (view as bug list)
Environment:
Last Closed: 2017-05-17 20:18:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 455765 None None None 2017-04-12 13:31:43 UTC
Launchpad 1680575 None None None 2017-04-09 11:18:36 UTC

Description Brent Eagles 2017-04-06 19:25:07 UTC
Copied from u/s launchpad https://bugs.launchpad.net/octavia/+bug/1680575

 
The fix for https://bugs.launchpad.net/neutron/+bug/1531640 nested the code for adding authentication token to the request headers in such a way that it would not get added if there were no args to the request. This caused GET and DELETE requests to fail when keystone authentication is configured, manifesting in a range of problems such as the inability to delete load balancers and for creation to never complete.

Comment 4 Alexander Stafeyev 2017-05-10 04:52:35 UTC
Hi Brent, 
What are the reproduction steps pls ? 

tnx

Comment 5 Nir Magnezi 2017-05-13 21:00:54 UTC
(In reply to Alexander Stafeyev from comment #4)
> Hi Brent, 
> What are the reproduction steps pls ? 
> 
> tnx

@Alex,

Verification here could ba a successful creation and deletion of a loadbalancer in Octavia.

Without Brent's fix, Octavia would not be able to properly use Keystone authentication.

Comment 6 Alexander Stafeyev 2017-05-14 05:55:36 UTC
https://review.openstack.org/#/c/264382/ - Merged
+
I created LB successfully.

Comment 7 Assaf Muller 2017-05-17 17:00:13 UTC
Reported and fixed on internal builds without an external release, marking doctext as not necessary.

Comment 8 errata-xmlrpc 2017-05-17 20:18:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.