Bug 1439917 - Swift bucket X-Timestamp not set by Rados Gateway
Summary: Swift bucket X-Timestamp not set by Rados Gateway
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: 2.3
Assignee: Marcus Watts
QA Contact: Tejas
Erin Donnelly
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks: 1437916
TreeView+ depends on / blocked
 
Reported: 2017-04-06 20:26 UTC by Vikhyat Umrao
Modified: 2017-09-05 23:14 UTC (History)
10 users (show)

(edit)
.The Ceph Object Gateway provides valid time stamps for newly created objects

Previously, the Ceph Object Gateway was storing 0 in the `x-timestamp` fields for all objects. This bug has been fixed, and newly created objects have the correct time stamps. Note that old objects will still retain the 0 time stamps.
Clone Of:
(edit)
Last Closed: 2017-06-19 13:31:50 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC
Ceph Project Bug Tracker 16597 None None None 2017-04-11 21:28 UTC
Red Hat Knowledge Base (Solution) 3000581 None None None 2017-04-12 19:41 UTC

Description Vikhyat Umrao 2017-04-06 20:26:25 UTC
Description of problem:
Swift bucket X-Timestamp not set by Rados Gateway version jewel (Red Hat Ceph Storage 2.2 - 10.2.5-37.el7cp)

# swift post test-c5-osp8
# swift stat test-c5-osp8
                      Account: v1
                    Container: test-c5-osp8
                      Objects: 0
                        Bytes: 0
                     Read ACL:
                    Write ACL:
                      Sync To:
                     Sync Key:
                Accept-Ranges: bytes
             X-Storage-Policy: default-placement
X-Container-Bytes-Used-Actual: 0
                  X-Timestamp: 0.00000
                   X-Trans-Id: tx0000000000000000000e0-0058e69bb8-75623bc-default
                 Content-Type: text/plain; charset=utf-8



This is a regression because it is working perfectly fine with version hammer(Red Hat Ceph Storage 1.3.z - 0.94.5-9.el7cp).

The feature was added here: http://tracker.ceph.com/issues/10938

Version-Release number of selected component (if applicable):
Red Hat Ceph Storage 2.2 - 10.2.5-37.el7cp

How reproducible:
100%

Steps to Reproduce:
1. Create the container 
2. Run the stat

Comment 1 Vikhyat Umrao 2017-04-06 20:28:51 UTC
I have tested below combinations:

OSP 8 and OSP 10 with RHCS 2.2 - 10.2.5-37.el7cp
==================================================

OSP 8 - # swift --version
python-swiftclient 2.6.0
--------------------------------

# swift post test-c5-osp8
# swift stat test-c5-osp8
                      Account: v1
                    Container: test-c5-osp8
                      Objects: 0
                        Bytes: 0
                     Read ACL:
                    Write ACL:
                      Sync To:
                     Sync Key:
                Accept-Ranges: bytes
             X-Storage-Policy: default-placement
X-Container-Bytes-Used-Actual: 0
                  X-Timestamp: 0.00000
                   X-Trans-Id: tx0000000000000000000e0-0058e69bb8-75623bc-default
                 Content-Type: text/plain; charset=utf-8

OSP 10 - # swift --version
python-swiftclient 3.1.0
-----------------------------------

# swift post test-c5-osp-10
# swift stat test-c5-osp-10
                      Account: v1
                    Container: test-c5-osp-10
                      Objects: 0
                        Bytes: 0
                     Read ACL:
                    Write ACL:
                      Sync To:
                     Sync Key:
                Accept-Ranges: bytes
             X-Storage-Policy: default-placement
X-Container-Bytes-Used-Actual: 0
                  X-Timestamp: 0.00000
                   X-Trans-Id: tx000000000000000000013-0058e69ea6-77bd34e-default
                 Content-Type: text/plain; charset=utf-8

Plain SWIFT client without keystone:
----------------------------------------
[root@kilo1 ~]# swift -A http://kilo1.example.com/auth/1.0 -U testuser2:swift -K 'a7BmMdckQc3dyqbKapcbCw1mzD3EgTsc341L7OYF' post test-c5
[root@kilo1 ~]# swift -A http://kilo1.example.com/auth/1.0 -U testuser2:swift -K 'a7BmMdckQc3dyqbKapcbCw1mzD3EgTsc341L7OYF' stat test-c5
                      Account: v1
                    Container: test-c5
                      Objects: 0
                        Bytes: 0
                     Read ACL:
                    Write ACL:
                      Sync To:
                     Sync Key:
                Accept-Ranges: bytes
             X-Storage-Policy: default-placement
X-Container-Bytes-Used-Actual: 0
                  X-Timestamp: 0.00000
                   X-Trans-Id: tx0000000000000000000e5-0058e69f25-75623bc-default
                 Content-Type: text/plain; charset=utf-8


OSP 8 with RHCS 1.3.z - 0.94.5-9.el7cp
=================================

# swift post test-c1-osp8-rhcs-1.3.z
# swift stat test-c1-osp8-rhcs-1.3.z
                      Account: v1
                    Container: test-c1-osp8-rhcs-1.3.z
                      Objects: 0
                        Bytes: 0
                     Read ACL:
                    Write ACL:
                      Sync To:
                     Sync Key:
                Accept-Ranges: bytes
             X-Storage-Policy: default-placement
X-Container-Bytes-Used-Actual: 0
                  X-Timestamp: 1491509197.00000 <=================
                   X-Trans-Id: tx00000000000000000001b-0058e69fd4-1dc3a29-default
                 Content-Type: text/plain; charset=utf-8
[root@dell-per630-5 ~(keystone_admin)]# 

============

Comment 17 errata-xmlrpc 2017-06-19 13:31:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.