Bug 144021 - gdb broke after kernel update to 2.6.9-1.724_FC3
gdb broke after kernel update to 2.6.9-1.724_FC3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
: 144233 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-03 15:13 EST by Satish Balay
Modified: 2015-01-04 17:14 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 23:14:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish Balay 2005-01-03 15:13:56 EST
Description of problem:

gdb does not work after upgrading to kernel 2.6.9-1.724_FC3

Version-Release number of selected component (if applicable):
gdb-6.1post-1.20040607.43
kernel-2.6.9-1.724_FC3

How reproducible:
Always

Steps to Reproduce:
1. Install FC3 & updates (including kernel-2.6.9-1.724_FC3)
2. compile a piece of 'c' code using: gcc -g foo.c
3. try debugging using: gdb a.out
  
Actual results:

asterix:/home/balay/junk>uname -a
Linux asterix 2.6.9-1.724_FC3 #1 Sun Jan 2 15:43:49 EST 2005 i686 i686 i386
GNU/Linux
asterix:/home/balay/junk>gcc -g sizeof.c
asterix:/home/balay/junk>gdb a.out
GNU gdb Red Hat Linux (6.1post-1.20040607.43rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db
library "/lib/tls/libthread_db.so.1".

(gdb) b main
Breakpoint 1 at 0x80483ac: file sizeof.c, line 7.
(gdb) r
Starting program: /home/balay/junk/a.out
warning: Child process unexpectedly missing: No child processes

Program terminated with signal ?, Unknown signal.
The program no longer exists.
You can't do that without a process to debug.
(gdb) r
Starting program: /home/balay/junk/a.out
warning: Child process unexpectedly missing: No child processes

Program terminated with signal ?, Unknown signal.
The program no longer exists.
You can't do that without a process to debug.
(gdb)


Expected results:

No errors from gdb

Additional info:

Works fine with kernel-2.6.9-1.681_FC3

Same broken behavior with kernel-2.6.9-1.1049_FC4 in rawhide

filing in bugzilla - so that it doesn't get lost in malining-lists
https://www.redhat.com/archives/fedora-test-list/2005-January/msg00025.html
Comment 1 Satish Balay 2005-01-04 10:33:48 EST
2.6.9-1.715_FC3 appears to work - so the breakage happened between 715 & 722
Comment 2 Satish Balay 2005-01-04 11:14:37 EST
2.6.10-1.1063_FC4 (in rawhide) doesn't show this problem - so its fixed between
1049 & 1063?

Comment 3 Anduin Withers 2005-01-04 15:09:41 EST
It appears to be in linux-2.6.9-exit-race-fix.patch and linux-
2.6.10rc2-wait-mt-zombie-race-fix.patch (because it depends on the 
first patch)

This bug is neither priority normal nor severity normal, an update 
was posted to mirrors, it hasn't been withdrawn. You cannot ptrace 
with this kernel, a basic smoke check should have failed.
Comment 5 Barry K. Nathan 2005-01-05 08:36:14 EST
This bug appears to be fixed in 2.6.10-1.727_FC3, at least in my
testing. In case anyone missed the mailing list announcement, it's
available for testing here:
http://people.redhat.com/davej/kernels/Fedora/FC3/

(At the time of this writing there does not seem to be a 2.6.10-based
kernel for FC2 there.)
Comment 6 Claus Olesen 2005-01-05 20:11:53 EST
*** Bug 144233 has been marked as a duplicate of this bug. ***
Comment 7 Sam Varshavchik 2005-01-08 15:21:27 EST
I can reproduce also this bug in the most recent FC2 kernel, kernel-2.6.9-1.11_FC2

kernel-2.6.9-1.6_FC2 gdb works.

kernel-2.6.9-1.11_FC2 breaks gdb.

Comment 8 Satish Balay 2005-01-09 10:18:05 EST
kernel-2.6.10-1.735_FC3 also works fine. (however I'm still stuck with
#144415)

Note You need to log in before you can comment on or make changes to this bug.