Bug 144025 - linuxwacom sig11's xorg on x86_64 with no further messages
linuxwacom sig11's xorg on x86_64 with no further messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: linuxwacom (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
:
: 140184 (view as bug list)
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-01-03 16:17 EST by taj
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-23 18:20:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log (47.71 KB, text/plain)
2005-03-11 17:54 EST, taj
no flags Details
strace of server startup (24.83 KB, text/plain)
2005-03-11 17:55 EST, taj
no flags Details
configuration file (4.45 KB, text/plain)
2005-03-11 17:56 EST, taj
no flags Details
working SRPM for x86_64 (463.52 KB, application/octet-stream)
2005-03-11 19:28 EST, taj
no flags Details

  None (edit)
Description taj 2005-01-03 16:17:48 EST
linuxwacom-0.6.4-6.x86_64.rpm 

Linux Wacom sig11's xorg on opteron systems.  There is a fix upstream
thats not encorperated yet.

There is a new version upstream without this fix too.

A potential fix:

http://sourceforge.net/mailarchive/message.php?msg_id=10418264

New upstream version:

http://prdownloads.sourceforge.net/linuxwacom/linuxwacom-0.6.6.tar.bz2?download


Please update to linuxwacom-0.6.6 and encorperate x86_64 fixes.
Comment 1 Kristian Høgsberg 2005-03-09 13:26:20 EST
There's a new linuxwacom-0.6.6-1 in rawhide which should fix the
problem.  Please try it out and see if it fixes the problem.

Thanks,
Kristian
Comment 2 Kristian Høgsberg 2005-03-09 13:28:11 EST
*** Bug 140184 has been marked as a duplicate of this bug. ***
Comment 3 taj 2005-03-10 01:05:16 EST

I have tested the build and done a remote install.  So far so good. 
The build works with 2.4 kernels too.  I'll report further when I get
user feedback with the device connected.

Comment 4 taj 2005-03-11 17:50:44 EST

X11 is performing a Sig11 on startup with the provided binary.
I'll attach an strace and the config file.  The wacom device appears
to be detected and functioning with "wacdump /dev/ttyS1."


rpm -qa xorg\* linuxwacom\* kernel\* glibc\* --qf
'%{name}-%{version}-%{release}(%{arch})\n'|sort
glibc-2.3.4-3(i686)
glibc-2.3.4-3(x86_64)
glibc-common-2.3.4-3(x86_64)
glibc-devel-2.3.4-3(i386)
glibc-devel-2.3.4-3(x86_64)
glibc-headers-2.3.4-3(x86_64)
glibc-kernheaders-2.4-9.1.87(x86_64)
glibc-profile-2.3.4-3(x86_64)
glibc-utils-2.3.4-3(x86_64)
kernel-2.6.10-1.1056_FC4(x86_64)
kernel-2.6.5-1.358(x86_64)
kernel-2.6.9-1.1047_FC4(x86_64)
kernel-2.6.9-1.1048_FC4(x86_64)
kernel-2.6.9-1.1049_FC4(x86_64)
kernel-doc-2.6.10-1.1056_FC4(noarch)
kernel-utils-2.4-13.1.49(x86_64)
linuxwacom-0.6.6-1(x86_64)
linuxwacom-devel-0.6.6-1(x86_64)
xorg-x11-6.8.1.901-1(x86_64)
xorg-x11-deprecated-libs-6.8.1.901-1(i386)
xorg-x11-deprecated-libs-6.8.1.901-1(x86_64)
xorg-x11-deprecated-libs-devel-6.8.1.901-1(x86_64)
xorg-x11-devel-6.8.1.901-1(i386)
xorg-x11-devel-6.8.1.901-1(x86_64)
xorg-x11-doc-6.8.1.901-1(x86_64)
xorg-x11-font-utils-6.8.1.901-1(x86_64)
xorg-x11-libs-6.8.1.901-1(i386)
xorg-x11-libs-6.8.1.901-1(x86_64)
xorg-x11-Mesa-libGL-6.8.1.901-1(i386)
xorg-x11-Mesa-libGL-6.8.1.901-1(x86_64)
xorg-x11-Mesa-libGLU-6.8.1.901-1(i386)
xorg-x11-Mesa-libGLU-6.8.1.901-1(x86_64)
xorg-x11-sdk-6.8.1.901-1(x86_64)
xorg-x11-tools-6.8.1.901-1(x86_64)
xorg-x11-twm-6.8.1.901-1(x86_64)
xorg-x11-xauth-6.8.1.901-1(x86_64)
xorg-x11-xdm-6.8.1.901-1(x86_64)
xorg-x11-Xdmx-6.8.1.901-1(x86_64)
xorg-x11-xfs-6.8.1.901-1(x86_64)
xorg-x11-Xnest-6.8.1.901-1(x86_64)
xorg-x11-Xvfb-6.8.1.901-1(x86_64)
Comment 5 taj 2005-03-11 17:54:37 EST
Created attachment 111906 [details]
Xorg.log

Sig 11 normal log file
Comment 6 taj 2005-03-11 17:55:57 EST
Created attachment 111907 [details]
strace of server startup

strace of server startup
Comment 7 taj 2005-03-11 17:56:56 EST
Created attachment 111908 [details]
configuration file


xorg.conf configuration file.
Comment 8 taj 2005-03-11 18:16:41 EST
It looks like this wont work yet without the above patch which is not
integrated into 0.6.6.  Maybe we just need to wait for linuxwacom to
make a formal release from their CVS repo.

src/Makefile.in

$(XF86OBJS): xf86Wacom.c Makefile
        gcc $(CFLAGS) $(DEPFLAGS) -pipe -ansi \
                -pedantic -Wall -Wpointer-arith $(NO_MERGE_CONSTANTS) \
                -I. $(DRIVER_INCLUDES) \
                -Dlinux >>>>>>>>>>>>-D__i386__<<<<<<<<<<<<<<
-D_POSIX_C_SOURCE=199309L -D_POSIX_SOURCE \
                -D_XOPEN_SOURCE -D_BSD_SOURCE -D_SVID_SOURCE 
-D_GNU_SOURCE \
                -DSHAPE -DXINPUT -DXKB -DLBX -DXAPPGROUP -DXCSECURITY \
                -DTOGCUP -DXF86BIGFONT -DDPMSExtension -DPIXPRIV
-DPANORAMIX \
                -DRENDER -DGCCUSESGAS -DAVOID_GLYPHBLT -DPIXPRIV \
                -DSINGLEDEPTH -DXFreeXDGA -DXvExtension -DXFree86LOADER \
                -DXFree86Server -DXF86VIDMODE -DXvMCExtension \
                -DSMART_SCHEDULE -DBUILDDEBUG -DXResExtension \
                -DX_BYTE_ORDER=X_LITTLE_ENDIAN -DNDEBUG -DFUNCPROTO=15 \
                -DNARROWPROTO -DIN_MODULE -DXFree86Module $(LINUX_INPUT) \
                -o $@ -c $(subst .o,.c,$@)

Comment 9 taj 2005-03-11 19:28:21 EST
Created attachment 111914 [details]
working SRPM for x86_64


After some phone calls and testing, this works for x86_64.  Maybe you could
check it on other platforms or just stuff it into rawhide after review.
Comment 10 Mike A. Harris 2005-04-11 19:25:01 EDT
This bug seems to still exist Kristian...  the bug got caught in MODIFIED
state tho, so looks like it's been overlooked.

Setting back to ASSIGNED.
Comment 11 Kristian Høgsberg 2005-04-13 15:25:01 EDT
OK, I've put a new build in rawhide:

  linuxwacom-0.6.6-5

which should fix the problems on 64 bit systems.
Comment 12 taj 2005-04-15 02:57:42 EDT

I'll give this a test Sunday.  I need to have someone on the other end of a
phone to know if it works.
Comment 13 taj 2005-04-19 02:03:53 EDT
The lamest additional comment ever.

Sigh.  I did install the 6.6-5, I presume X11 is starting fine so the bug is
most likely resolved.  They lost the stylus on the other end so I'm not sure
when I'll close this bug.  The machine is remote.

I'll close it when they confirm restarting X11 and testing the stylus.

Maybe someone else could confirm this bug is closed before the stylus is found here.

Comment 14 taj 2005-04-23 18:20:46 EDT
Following up on comment 13

They found the stylus and I recieved email that 6.6-5.1 is working on x86_64.


I'll close this bug as rawhide as the packages there no longer have problems
specific to this bug.

Note You need to log in before you can comment on or make changes to this bug.