Bug 1440502 - hp 8610 Filter failed when trying to print on fedora 26
Summary: hp 8610 Filter failed when trying to print on fedora 26
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 26
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
: 1443148 1444651 (view as bug list)
Depends On:
Blocks: F26BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2017-04-09 13:21 UTC by Pablo Estigarribia
Modified: 2018-12-20 05:03 UTC (History)
12 users (show)

Fixed In Version: hplip-3.17.4-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-01 18:16:18 UTC


Attachments (Terms of Use)
journal_print_log_since_print_sent (1.03 MB, text/plain)
2017-04-09 13:21 UTC, Pablo Estigarribia
no flags Details
select-from-db (74.58 KB, image/jpeg)
2017-04-25 10:25 UTC, Pablo Estigarribia
no flags Details
journal-2017-04-25 (3.44 MB, text/plain)
2017-04-25 10:30 UTC, Pablo Estigarribia
no flags Details

Description Pablo Estigarribia 2017-04-09 13:21:39 UTC
Created attachment 1270218 [details]
journal_print_log_since_print_sent

Description of problem:
After upgrade on Sunday 09, hp printer 8610 stopped working with message "filter failed"

Version-Release number of selected component (if applicable): 
# hp-info 
warning: hp-info should not be run as root/superuser.

HP Linux Imaging and Printing System (ver. 3.16.11)
Device Information Utility ver. 5.2

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Traceback (most recent call last):
  File "/usr/bin/hp-info", line 175, in <module>
    ui = import_module(ui_package + ".infodialog")
  File "/usr/lib64/python3.6/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 978, in _gcd_import
  File "<frozen importlib._bootstrap>", line 961, in _find_and_load
  File "<frozen importlib._bootstrap>", line 936, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 205, in _call_with_frames_removed
  File "<frozen importlib._bootstrap>", line 978, in _gcd_import
  File "<frozen importlib._bootstrap>", line 961, in _find_and_load
  File "<frozen importlib._bootstrap>", line 948, in _find_and_load_unlocked
ModuleNotFoundError: No module named 'ui5'


How reproducible:

Install any hp print I think, as it is affecting hplip. 


Steps to Reproduce:
1. Install hp printer
2. Try to print.

Option 2:
1. Install hpplip package
2. Try to run hp-info and other of the tools


Actual results:
When printing it doesn't works, error message: "filter failed" 
Also attached journalctl

Expected results:
Print normal without errors

Additional info:
Attached journalctl.

Comment 1 Pablo Estigarribia 2017-04-09 16:11:24 UTC
hp-info command works after installing: `sudo dnf install hplip-gui` 

But it doesn't solves the problem yet, so it's still valid. 

I think it could be high or critical priority because there is no workaround to print on hplip printers yet.

Comment 2 Pablo Estigarribia 2017-04-09 16:14:42 UTC
Now I did new change and found a workaround: 

Change drive from hplip cups, to hpij on manual selection of driver. 

The bug could be still valid because gnome selects automatically hpcups driver, but priority is not high.

Comment 3 Michele Baldessari 2017-04-20 18:45:14 UTC
I am hitting this one as well since I upgraded to F26:
Apr 20 20:26:22 palahniuk.int.rhx cupsd[1103]: cupsdSetBusyState: newbusy="Printing jobs and dirty files", busy="Printing jobs and dirty files"
Apr 20 20:26:22 palahniuk.int.rhx cupsd[1103]: Set job-printer-state-message to "Processing page 1...", current level=INFO
Apr 20 20:26:22 palahniuk.int.rhx cupsd[1103]: Discarding unused job-progress event...
Apr 20 20:26:22 palahniuk.int.rhx cupsd[1103]: Discarding unused printer-state-changed event...
Apr 20 20:26:22 palahniuk.int.rhx hpcups[853]: prnt/hpcups/HPCupsFilter.cpp 487: m_Job initialization failed with error = 4 
Apr 20 20:26:22 palahniuk.int.rhx cupsd[1103]: prnt/hpcups/HPCupsFilter.cpp 487: m_Job initialization failed with error = 4 
Apr 20 20:26:22 palahniuk.int.rhx cupsd[1103]: prnt/backend/hp.c 913: ERROR: null print job total=0
Apr 20 20:26:22 palahniuk.int.rhx hp[854]: prnt/backend/hp.c 913: ERROR: null print job total=0
Apr 20 20:26:22 palahniuk.int.rhx cupsd[1103]: PID 853 (/usr/lib/cups/filter/hpcups) stopped with status 1.
Apr 20 20:26:22 palahniuk.int.rhx cupsd[1103]: PID 854 (/usr/lib/cups/backend/hp) exited with no errors.

Comment 4 John Ellson 2017-04-21 14:20:29 UTC
This maybe a dup of 1443148

Comment 5 Zdenek Dohnal 2017-04-24 13:11:57 UTC
Hi,

would you mind re-installing your printer with (you need to have installed hplip-gui):

1) $ hp-setup -r
2) $ hp-setup
3) hp-plugin

if it helps?

Comment 6 John Ellson 2017-04-24 15:38:01 UTC
No luck.  Same error. (See #1443148)

I see Comment #2 claims that hpij works.  How to I load that?

Comment 7 Pablo Estigarribia 2017-04-25 10:25:28 UTC
Created attachment 1273867 [details]
select-from-db

This images shows howto select hpijs to workaround this bug.

Comment 8 Pablo Estigarribia 2017-04-25 10:30:12 UTC
I have added attachment that shows howto choose the hpijs driver, you must go to print settings, unlock button, print details and then select from database. 

I have tried also steps with hp-setup and hp-plugin but still not working with that. 

Kind regards,
Pablo.

Comment 9 Pablo Estigarribia 2017-04-25 10:30:57 UTC
Created attachment 1273868 [details]
journal-2017-04-25

Comment 10 Zdenek Dohnal 2017-04-25 12:26:42 UTC
*** Bug 1443148 has been marked as a duplicate of this bug. ***

Comment 11 Zdenek Dohnal 2017-04-25 12:27:52 UTC
*** Bug 1444651 has been marked as a duplicate of this bug. ***

Comment 12 Zdenek Dohnal 2017-04-25 12:33:26 UTC
I have HP LaserJet m1536dnf MFP and printing works for me. Probably only some models of HP are affected with this issue.

Comment 13 Zdenek Dohnal 2017-04-25 12:34:26 UTC
There is new version of hplip in bodhi, so you can try this new version, if it helps.

Comment 14 John Ellson 2017-04-25 20:37:31 UTC
Nope.   Same problem with hplib-3.17.4-1:

Apr 25 16:33:59 ontap hp[25242]: prnt/backend/hp.c 913: ERROR: null print job total=0

Comment 15 John Ellson 2017-04-26 14:15:10 UTC
I finally managed to switch to hpijs driver. ( In system-config-printer, you have to select "Change" for the "Make and Model" to get to the drivers, even though there is no change wanted to the "Make and Model". )

hpijs-3.17.4 works.  So the problem is specific to the hpcups-3.17.4 driver.

Comment 16 Zdenek Dohnal 2017-04-26 15:03:08 UTC
I have suspicion that my solution of this issue https://bugzilla.redhat.com/show_bug.cgi?id=1364711 caused this bug. Would you mind trying this scratch build https://koji.fedoraproject.org/koji/taskinfo?taskID=19217114 ?

Comment 17 John Ellson 2017-04-26 17:54:43 UTC
Yes.  Thats better.  I'm now using hplip-3.17.4-2 from koji with hpcups drver enabled.

Comment 18 Zdenek Dohnal 2017-04-26 18:42:45 UTC
Ok, I will build it now. I am deeply sorry for inconvenience.

Comment 19 Pablo Estigarribia 2017-04-27 02:00:25 UTC
Trying to update to hplip-3.17.4-2 with dnf didn't work in my case: 

sudo dnf install hplip --enablerepo=updates-testing
Última comprobación de caducidad de metadatos hecha hace 2:05:44, el Wed Apr 26 20:45:43 2017 -03.
El paquete hplip-3.17.4-1.fc26.x86_64 ya se encuentra instalado, omitiendo.
Dependencias resueltas.
Nada por hacer.
¡Listo!


---

Also tried distrosync

--- 

I see the update in : https://bodhi.fedoraproject.org/updates/FEDORA-2017-b3c2b6d28d 

But don't know howto obtain from koji with dnf. 

----

Should I download each rpm from https://koji.fedoraproject.org/koji/buildinfo?buildID=883678 ? 

I think there is something that I haven't read about testing it.

Comment 20 Zdenek Dohnal 2017-04-27 07:30:49 UTC
Pablo,

you can install these rpms from scratch build by:

$ sudo dnf install <1.rpm_download_link_from_scratch_build>...<N.rpm_download_link_from_scratch_build>

As you can see from the bodhi update, the update is in pending state with request for testing. That means it isn't even in updates-testing repository yet. I think I cannot do much more for speeding up the process.

Comment 21 Pablo Estigarribia 2017-04-27 10:18:17 UTC
Thanks!

I Did: 

```
sudo dnf install https://kojipkgs.fedoraproject.org//packages/hplip/3.17.4/2.fc26/x86_64/hplip-3.17.4-2.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/hplip/3.17.4/2.fc26/x86_64/hplip-common-3.17.4-2.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/hplip/3.17.4/2.fc26/x86_64/hplip-gui-3.17.4-2.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/hplip/3.17.4/2.fc26/x86_64/hplip-libs-3.17.4-2.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/hplip/3.17.4/2.fc26/x86_64/libsane-hpaio-3.17.4-2.fc26.x86_64.rpm
Última comprobación de caducidad de metadatos hecha hace 0:03:13, el Thu Apr 27 07:08:02 2017 -03.
Dependencias resueltas.
===================================================================================================
 Package                  Arquitectura      Versión                  Repositorio             Tamaño
===================================================================================================
Actualizando:
 hplip                    x86_64            3.17.4-2.fc26            @commandline             13 M
 hplip-common             x86_64            3.17.4-2.fc26            @commandline            102 k
 hplip-gui                x86_64            3.17.4-2.fc26            @commandline            1.3 M
 hplip-libs               x86_64            3.17.4-2.fc26            @commandline            191 k
 libsane-hpaio            x86_64            3.17.4-2.fc26            @commandline            121 k

Resumen de la transacción
===================================================================================================
Actualizar  5 Paquetes
```

And tested the printer with both drivers hpijs and hpcups. 
Also removed the printer and added again, working without changes!

working with both drivers!

Thanks a lot.

Comment 22 Fedora Update System 2017-04-28 00:22:47 UTC
hplip-3.17.4-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b3c2b6d28d

Comment 23 Pablo Estigarribia 2017-04-28 01:30:57 UTC
seems that automatic system put it on queue for testing. 

I have tested, also done sudo dnf update again and everything is working fine, same as tested before.

Comment 24 Fedora Update System 2017-05-01 18:16:18 UTC
hplip-3.17.4-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Geoffrey Marr 2017-05-01 18:28:08 UTC
Discussed during the 2017-05-01 blocker review meeting: [1]

The decision to classify this bug as a RejectedBlocker was made as it doesn't violate any blocker criteria and seems to be fixed now.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-05-01/f26-blocker-review.2017-05-01-16.02.txt

Comment 26 FrankS 2017-08-26 15:02:44 UTC
I had same issue with hplip-3.17.6-1.fc26:

hp[5717]: prnt/backend/hp.c 913: ERROR: null print job total=0

Tried a work-around which I found on FreeBSD forum and it worked fine; I replaced the cupsFilter in the ppd-file:

before:
*cupsFilter: "application/vnd.cups-postscript 100 foomatic-rip"
*cupsFilter: "application/vnd.cups-pdf 0 foomatic-rip"

after:
*cupsFilter: "*/* 0 -"

So to my opinion either the filter or the PPD generation is wrong.

Comment 27 maria121 2018-12-20 05:03:50 UTC
My printer suffered a paper jam. After releasing the paper, I found that the printer was unwilling to print anything. The specific error was filter failed.
I am using Lenovo pc, When I face any issue with my pc I solve my problem with this site http://lenovotechsupport.com


Note You need to log in before you can comment on or make changes to this bug.