Bug 144093 - RFE: ATI Mobility Radeon 9700 and 1280x800 mode for laptops
RFE: ATI Mobility Radeon 9700 and 1280x800 mode for laptops
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: system-config-display (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2005-01-04 10:06 EST by Andrew Gormanly
Modified: 2014-06-18 05:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-07 20:53:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
XFree86 config file (3.15 KB, text/plain)
2005-01-04 12:32 EST, Andrew Gormanly
no flags Details
extramodes file (662 bytes, text/plain)
2005-01-04 12:45 EST, Andrew Gormanly
no flags Details
new XF86Config (1.74 KB, text/plain)
2005-01-28 07:28 EST, Andrew Gormanly
no flags Details
X log (53.66 KB, text/plain)
2005-01-28 07:29 EST, Andrew Gormanly
no flags Details

  None (edit)
Description Andrew Gormanly 2005-01-04 10:06:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)

Description of problem:
I've a new Sony Vaio S2XP, on which I've installed RHEL 3WS.  Neither
the video card (Mobility Radeon 9700; 64MB) nor the screen are supported.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Try and select video card or resolution for this machine

Actual Results:  Neither is available.

Expected Results:  It'd be nice to see more on the screen.

Additional info:

# lspci | grep ATI
01:00.0 VGA compatible controller: ATI Technologies Inc RV350
[Mobility Radeon 9600 M10]

# ddcprobe

Videocard DDC probe results
Description:  ATI Technologies Inc. P11
Memory (MB):  64

Monitor DDC probe results
Monitor DDC Probe failed.

redhat-config-xfree86 selects VESA driver (generic) as "ddcprobe
returned bogus values".  Trying to manually specify ATI Radeon
(generic), ATI Radeon 9600, ATI Radeon 9700, or ATI Radeon Mobility M9
all lock the system, requiring hard reset.

I've tried calculating some 1280x800 modelines and putting them into
/usr/share/rhpl/extramodes, but these are not picked up (because I'm
using VESA driver?) with X output:

(II) VESA(0): Not using mode "1280x800" (no mode of this name)

It seems this problem has already come up in Fedora Core
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=122739#c2), but
I need to stick with RHEL, as my laptop is where I build all our
add-on rpms for our systems here.
Comment 1 Suzanne Hillman 2005-01-04 10:54:54 EST
Internal RFE bug #144102 entered; will be considered for future releases.
Comment 2 Paul Nasrat 2005-01-04 11:44:18 EST
Andrew can you attach the modelines you added in extramodes and your xorg.conf
Comment 3 Andrew Gormanly 2005-01-04 12:32:22 EST
Created attachment 109338 [details]
XFree86 config file

RHEL, so XFree86 rather than X.org config file
Comment 4 Andrew Gormanly 2005-01-04 12:45:07 EST
Created attachment 109340 [details]
extramodes file

Generated with the online XFree86 modeline generator at

I've also tried Robert Shearman's modeline for a similar issue in Fedora (bug
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=105973&action=view) but
neither work.
Comment 5 Andrew Gormanly 2005-01-04 12:50:43 EST
I noticed from bug #122739 that Bastien Nocera at Red Hat has a very similar
laptop to mine (Vaio S1XP vs S2XP, we have one of each here but the older one is
a M$ box), which seems to be working with Fedora, but he's not posted his known
good modeline.
Comment 6 Søren Sandmann Pedersen 2005-01-26 14:24:56 EST
Could you try this one:

   Modeline "1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841

which Flo in #122739 reports to work.
Comment 7 Andrew Gormanly 2005-01-28 07:28:24 EST
Created attachment 110349 [details]
new XF86Config

(deadlock is the name of the machine)

Tried with the suggested modes and it still doesn't work.

(I changed the HorizSync and VertRefresh from the default for my current
XF86Config so I can get to 1024x768)

I also made the changes in extramodes, but this mode still dowsn't show up in
redhat-config-xfree86 either.
Comment 8 Andrew Gormanly 2005-01-28 07:29:46 EST
Created attachment 110350 [details]
X log

Here's the X log for the new set-up.
Comment 9 Søren Sandmann Pedersen 2005-03-01 18:10:57 EST
Could you try manually changing the "Device" section to use the radeon
driver, like this:

Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
        VendorName  "Videocard vendor"
        BoardName   "Mobility Radeon 9600 M10"

and see if this still causes lockups? 
Comment 10 Andrew Gormanly 2005-03-02 04:52:57 EST
'fraid so.

I'm considering RHEL 4 WS: do you have any idea if that would be
better, given that it's X.org rather than XFree86?
Comment 11 Søren Sandmann Pedersen 2005-03-02 13:51:28 EST
Yes, I would expect RHEL 4 to work better. At least one person reports
successfully running Xorg on a Sony Vaio S2XP in 1200x800.
Comment 13 Andrew Gormanly 2005-12-02 12:11:59 EST
Xorg in RHEL 4 does work fine with this system.

Note You need to log in before you can comment on or make changes to this bug.