Bug 1440942 - Dell EMC Cinder back ends to not deploy in OSP-11
Summary: Dell EMC Cinder back ends to not deploy in OSP-11
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Alan Bishop
QA Contact: Aharon Canan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-10 19:14 UTC by Alan Bishop
Modified: 2017-06-04 07:52 UTC (History)
16 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-7.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-05-17 20:20:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 456382 None None None 2017-04-12 20:24:30 UTC
Launchpad 1681497 None None None 2017-04-10 19:14:15 UTC

Description Alan Bishop 2017-04-10 19:14:16 UTC
Description of problem:

Cinder back ends for Dell EMC PS, SC and ScaleIO do not deploy. Each of the three was converted to a service that can be used with composable roles, but the services are missing from the resource registry, and are also missing from the list of Controller services in roles_data.yaml.

I discovered this while working on bug #1439895, and a fix has already been posted upstream.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Alan Bishop 2017-04-10 19:19:51 UTC
whoops, not ON_DEV just yet (fix is posted to just master)

Comment 2 arkady kanevsky 2017-04-11 13:25:58 UTC
Thanks Alan.

Comment 3 Rajini Karthik 2017-04-11 14:35:33 UTC
Alan, I hope you can backport the upstream fixes to Ocata and newton if possible

Comment 4 arkady kanevsky 2017-04-11 19:36:11 UTC
Paul,
RH QE can do testing themselves as they test OSP11 on FV2 stamp.
Do not want OSP11 dependent on my QA folks as they all working on JS-10.0

Comment 5 Paul Grist 2017-04-11 20:03:13 UTC
Thanks Arkady, I will follow up. In general we mark partner backends as otherQA to track, but will verify we can cover this.  It will be next week after the Israel holidays.

Comment 6 Paul Grist 2017-04-11 20:25:58 UTC
Thanks Arkady, I will follow up. In general we mark partner backends as otherQA to track, but will verify we can cover this.  It will be next week after the Israel holidays.

Comment 7 Christian Schwede (cschwede) 2017-04-12 20:13:23 UTC
Proposed patch merged on master: https://review.openstack.org/#/c/455402/

Comment 8 Alan Bishop 2017-04-13 16:14:05 UTC
Backport to stable/ocata is stuck due to upstream bug that is blocking CI (https://bugs.launchpad.net/tripleo/+bug/1682001)

Comment 9 Christian Schwede (cschwede) 2017-04-21 07:30:32 UTC
Backport merged upstream - changing to POST

Comment 11 Alan Bishop 2017-04-24 18:47:42 UTC
Note to QE:

Please be sure to focus on the OSP-10 to OSP-11 upgrade path. See my note to
the Doc team for details.

Note to Doc team:

Section 3.4.2 of the upgrade document [1] covers situations where the customer
is deploying modified overcloud templates, and section 3 of the
Back End Guides [2],[3] directs the operator to do just that.

In order to successfully upgrade OSP-10 to OSP-11 with a Dell EMC SC or PS
back end, the customer will need to sync their modified version of
environment file(s) with the new version in OSP-11.

When deploying a Storage Center back end, in
environments/cinder-dellsc-config.yaml they need to _replace_ this line (applicable in OSP-10):

  OS::TripleO::ControllerExtraConfigPre: ../puppet/extraconfig/pre_deploy/controller/cinder-dellsc.yaml

With this (applicable in OSP-11):

  OS::TripleO::Services::CinderBackendDellSc: ../puppet/services/cinder-backend-dellsc.yaml

When deploying an EqualLogic back end, they need to transfer their
customizations from environments/cinder-eqlx.yaml (applicable in OSP-10) to
environments/cinder-dellps.yaml (applicable in OSP-11). This results in a
modified version of the environment file used to deploy an EqualLogic back
end. The name of this file changed from environments/cinder-eqlx.yaml (OSP-10)
to environments/cinder-dellps.yaml (OSP-11).

The guides [2],[3] explains the path to the .yaml file needs to be updated from a
relative path ("../puppet") to an absolute path.

[1] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html/upgrading_red_hat_openstack_platform/
[2] https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/paged/dell-storage-center-back-end-guide/
[3] https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/paged/dell-equallogic-back-end-guide/

Comment 12 Alan Bishop 2017-05-16 14:08:44 UTC
The doc notes I outline in comment #11 are being incorporated into the overall upgrade documentation.

Comment 13 errata-xmlrpc 2017-05-17 20:20:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.