Bug 1441218 - Regression: kube-apiserver.service fails to start: first path segment in URL cannot contain colon
Summary: Regression: kube-apiserver.service fails to start: first path segment in URL ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kubernetes
Version: 26
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jan Chaloupka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1472929 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-11 12:46 UTC by Martin Pitt
Modified: 2017-07-19 15:50 UTC (History)
13 users (show)

Fixed In Version: kubernetes-1.6.1-1.fc26 kubernetes-1.6.7-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-16 20:20:45 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github 6294 0 None None None 2020-08-24 12:36:55 UTC

Description Martin Pitt 2017-04-11 12:46:53 UTC
Description of problem:

kube-apiserver.service does not start any more in Fedora 26 (still works fine in 25, CentOS 7, etc.):

E0411 12:36:28.827991     486 server.go:254] Failed to create clientset: parse 127.0.0.1:8080: first path segment in URL cannot contain 
colon

This was apparently reported as https://github.com/kubernetes/kubernetes/issues/38380 and fixed later on, but it seems the fix is still missing in Fedora 26.


Version-Release number of selected component (if applicable):

kubernetes-master-1.5.4-2.fc26.x86_64

How reproducible: Always


Steps to Reproduce:

I noticed that when investigating the Cockpit test regressions on Fedora 26 [1].
 I reproduced the steps in a clean system. I used a privileged LXC container:

 sudo lxc-create -n f26 -t fedora -- --release 26
 echo 'lxc.cap.drop =' | sudo tee -a /var/lib/lxc/f26/config
 sudo lxc-start -n f26
 sudo lxc-attach -n f26

but this isn't specific to containers (the cockpit tests run in full QEMU VMs).

But I do use cockpit's kubernetes setup script to configure the kube master. This needed an initial fix to work with kube-apiserver.service now running as user, thus I need to use the script from the Pull Request:

  dnf install -y etcd openssl kubernetes kubernetes-master

  curl https://raw.githubusercontent.com/mvollmer/cockpit/fedora-26/test/images/scripts/lib/kubernetes.setup | sh -ex

  systemctl start etcd kube-apiserver kube-controller-manager kube-scheduler kube-proxy kubelet

After that, kube-apiserver.service fails with the above error. These steps work fine in previous Fedoras.

[1] https://github.com/cockpit-project/cockpit/pull/6294

Comment 1 Stef Walter 2017-04-25 07:13:08 UTC
This regression was discovered by the Cockpit integration tests. Failures are being  tracked here:

https://github.com/cockpit-project/cockpit/issues/6327

Comment 2 Jan Chaloupka 2017-04-25 14:25:30 UTC
Martin,

can you point me to the fix? Looking at the referenced PRs, no luck so far.

Comment 3 Jan Chaloupka 2017-04-25 14:40:05 UTC
Taking the question back.

Testing with kubernetes-1.5.6-1.fc27.x86_64, the issue is still there.
Testing with kubernetes-1.6.1-1.fc27.x86_64, the issue is done.

The fix is most likely this [1].

[1] https://github.com/kubernetes/kubernetes/pull/38519

Comment 4 Fedora Update System 2017-04-26 21:52:50 UTC
kubernetes-1.6.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-aac9d07ff3

Comment 5 Fedora Update System 2017-07-08 22:26:15 UTC
kubernetes-1.6.7-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-48014f1cad

Comment 6 Fedora Update System 2017-07-12 08:35:40 UTC
kubernetes-1.6.7-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-48014f1cad

Comment 7 Fedora Update System 2017-07-16 20:20:45 UTC
kubernetes-1.6.7-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Jason Brooks 2017-07-19 15:50:09 UTC
*** Bug 1472929 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.