Bug 1472929 - Kube-apiserver fails to start in f26
Kube-apiserver fails to start in f26
Status: CLOSED DUPLICATE of bug 1441218
Product: Fedora
Classification: Fedora
Component: kubernetes (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Chaloupka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 11:46 EDT by Spyros Trigazis
Modified: 2017-07-19 11:50 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-19 11:50:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Spyros Trigazis 2017-07-19 11:46:56 EDT
Description of problem:
When I try to start the kube-apiserver with the following configuration it fails to start with:




Version-Release number of selected component (if applicable):
kubernetes-master-1.5.3-1.fc26.x86_64


How reproducible: 100%


Steps to Reproduce:
1.

boot a FA26 host, I used : https://download.fedoraproject.org/pub/alt/atomic/stable/Fedora-Atomic-26-20170707.1/CloudImages/x86_64/images/Fedora-Atomic-26-20170707.1.x86_64.qcow2

2.

sudo su
. /etc/kubernetes/config
. /etc/kubernetes/apiserver
kube-apiserver \
            $KUBE_LOGTOSTDERR \
            $KUBE_LOG_LEVEL \
            $KUBE_ETCD_SERVERS \
            $KUBE_API_ADDRESS \
            $KUBE_API_PORT \
            $KUBELET_PORT \
            $KUBE_ALLOW_PRIV \
            $KUBE_SERVICE_ADDRESSES \
            $KUBE_ADMISSION_CONTROL \
            $KUBE_API_ARGS

Actual results:
I0719 13:56:00.604299    3496 config.go:527] Will report 137.138.120.12 as public IP address.
E0719 13:56:00.606254    3496 server.go:254] Failed to create clientset: parse 127.0.0.1:8080: first path segment in URL cannot contain colon
panic: parse 127.0.0.1:8080: first path segment in URL cannot contain colon

goroutine 1 [running]:
k8s.io/kubernetes/pkg/client/clientset_generated/internalclientset/typed/core/internalversion.NewForConfigOrDie(0xc42071e1a0, 0xc4206c6d90)
	/builddir/build/BUILD/kubernetes-029c3a408176b55c30846f0faedf56aae5992e9b/src/k8s.io/kubernetes/_output/local/go/src/k8s.io/kubernetes/pkg/client/clientset_generated/internalclientset/typed/core/internalversion/core_client.go:132 +0x62
k8s.io/kubernetes/pkg/master.(*Config).Complete(0xc4206c7d18, 0x0)
	/builddir/build/BUILD/kubernetes-029c3a408176b55c30846f0faedf56aae5992e9b/src/k8s.io/kubernetes/_output/local/go/src/k8s.io/kubernetes/pkg/master/master.go:180 +0x40a
k8s.io/kubernetes/cmd/kube-apiserver/app.Run(0xc42015bb80, 0x2bc9f48, 0x5f5a5a0)
	/builddir/build/BUILD/kubernetes-029c3a408176b55c30846f0faedf56aae5992e9b/src/k8s.io/kubernetes/_output/local/go/src/k8s.io/kubernetes/cmd/kube-apiserver/app/server.go:347 +0x1e8d
main.main()
	/builddir/build/BUILD/kubernetes-029c3a408176b55c30846f0faedf56aae5992e9b/src/k8s.io/kubernetes/_output/local/go/src/k8s.io/kubernetes/cmd/kube-apiserver/apiserver.go:50 +0xd8
Comment 1 Spyros Trigazis 2017-07-19 11:49:25 EDT
Since 1.6.7 will be released next week, I'm not sure if this is still important
Comment 2 Jason Brooks 2017-07-19 11:50:09 EDT

*** This bug has been marked as a duplicate of bug 1441218 ***

Note You need to log in before you can comment on or make changes to this bug.