Bug 14419 - Signal 11 in wu-ftpd 2.5.0 through 2.6.1
Signal 11 in wu-ftpd 2.5.0 through 2.6.1
Status: CLOSED DUPLICATE of bug 21900
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd (Show other bugs)
5.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-21 14:55 EDT by Giuseppe Ragusa
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 17:06:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giuseppe Ragusa 2000-07-21 14:55:38 EDT
Since upgrading my RedHat 5.1 wu-ftpd to version 2.5.0 I occasionally
received through syslog a message like this:

Apr 19 12:52:25 alpha ftpd[5104]: exiting on signal 11

subsequent upgrades to wu-ftpd 2.6.0 did not resolve my problems.
I always used RedHat precompiled versions (which also "featured" the long
known ftpwho error message on RH5.x, already featured in Bugzilla but never
solved).
Now I have downloaded and rebuilt 2.6.1-1.src.rpm and the message is:

Jul 21 19:59:14 alpha ftpd[7296]: exiting on signal 11: Segmentation fault

the ftpwho error is gone now (maybe autoconf'd build process figured out
the right ps syntax) but the sigsegv seems more frequent too. I'm running a
low traffic web/ftp site and the access rate is actually slowing down much
now (summer time): so the sigsegv rate is raising!
I'm running a pure RH 5.1 system with all the upgrades (now released
officially only for 5.2...) and kernel 2.0.38 with Solar Designer security
patches.
Wu-ftpd runs from inetd with the line:

ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  in.ftpd -l -a

and a somewhat tweaked ftpd configuration (but no virtual hosts).
Judging from the access logs, real and guest users seems to have been
unaffected by the problem and the anonymous ones who get caught by sigsegv
are in vast majority using IE4 (but some GetRight report too).  There seem
to be no other pattern.

Hope you can catch the bug (or help those kind souls finishing up the
latest proftpd release... ;> )
Comment 1 Bernhard Rosenkraenzer 2000-08-03 12:29:12 EDT
Can't reproduce it using Linux and *BSD clients (don't have anything else).

Does the number of segfaults reduce if you recompile using the old ("./build
lnx") method?
Comment 2 Dale Lovelace 2000-08-04 14:33:41 EDT
This is not a problem in Red Hat Linux 6.2
Comment 3 Andrey J. Melnikoff 2000-12-20 14:07:38 EST
Yeah! It really bug of wu-ftpd..
reproduced on RedHat 6.2 witch wu-ftpd-2.6.1-6 package.
other technical info sent to: bero@redhat.com
wait for patch :)
Comment 4 WU-FTPD Development Group 2001-03-12 17:06:55 EST
Close this to 21900.  Patch is in 21900.
Comment 5 Bernhard Rosenkraenzer 2001-03-16 07:09:02 EST

*** This bug has been marked as a duplicate of 21900 ***

Note You need to log in before you can comment on or make changes to this bug.