This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 144250 - dhcp fails to hand out leases and complains with errors on boot
dhcp fails to hand out leases and complains with errors on boot
Status: CLOSED DUPLICATE of bug 144358
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jason Vas Dias
:
: 144481 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-05 07:18 EST by Reuben Farrelly
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2005-01-05 07:18:25 EST
Description of problem:  After updating to last nights new DHCP (-16), I'm now
seeing these messages logged on boot:

Jan  6 00:58:33 tornado dhcpd: Lease with bogus binding state: 257
Jan  6 00:58:33 tornado last message repeated 4 times

and while running:

Jan  6 00:58:50 tornado dhcpd: DHCPREQUEST for 192.168.0.13 from
00:90:27:23:ee:12 via eth0: unknown lease 192.168.0.13.
Jan  6 01:01:53 tornado last message repeated 3 times
Jan  6 01:02:04 tornado last message repeated 2 times
Jan  6 01:02:23 tornado dhcpd: DHCPDISCOVER from 00:06:5b:d7:03:d7 via eth0:
network 192.168.0.0/24: no free leases
Jan  6 01:03:28 tornado last message repeated 4 times

This is an error.  There are plenty of free leases...

Version-Release number of selected component (if applicable):  3.0.1-16

How reproducible: very.  The problem persists over removing the dhcp.leases file
and restarting.

I downgraded to 3.0.1-11 and everything worked OK again.
Comment 1 Jason Vas Dias 2005-01-05 09:34:03 EST
 Did you install the binary FC4/rawhide dhcp-3.0.1-16 package on an 
 FC3 system ?
 If so, this is not likely to work, as the gcc and glibc version
 dhcp was built with on FC4 are not in FC3 - doing a :
  # rpmbuild --rebuild dhcp-3.0.1-16.src.rpm 
 and then installing the packages produced in 
 /usr/src/redhat/RPMS/$arch
 should work, but you have to change the compiler to gcc33 -
 (see bug #139299) 
 gcc or gcc4 on FC3 won't work, as the 'binding_state_t' variables
 are not made into byte values as in FC4 / gcc33 - it sounds like 
 you already built with gcc/gcc4 and the binding_state_t variables
 get an invalid byte value of 257 .
 You can download dhcp-3.0.1-16 built for i386/FC3 (and the 
 dhcp-3.0.1-16.src.rpm that uses gcc33) from:
   http://people.redhat.com/~jvdias/dhcp/FC3 
 Please try this version and let me know if you still have a problem.
 I've tested it on i386/FC3 with no problems.
 I'll be pushing this into FC3 updates, but this takes some time.
 By the way, the server lease database is:
    /var/lib/dhcp/dhcpd.leases
                      ^
    not           dhcp.leases
 did you try removing the real leases file and restarting ?
Comment 2 Reuben Farrelly 2005-01-05 15:53:01 EST
Yes, this is on a system running latest devel/rawhide.  I made a typo
with dhcpd.leases, I deleted both files after stopping dhcpd.

I only reverted to -11 from FC3 as this was the only one I could get
my hands on other than the latest version ;-)

Comment 3 Jason Vas Dias 2005-01-05 16:10:29 EST
What architecture is this system ? not i386 ?

There could be a problem with the GCC on our build servers.
The message : 
Jan  6 00:58:33 tornado dhcpd: Lease with bogus binding state: 257
indicates that the binding_state_t variables have a size > 1 
(a known gcc issue).
Comment 4 Reuben Farrelly 2005-01-05 16:16:12 EST
It's a P4/i386...
Comment 5 Jason Vas Dias 2005-01-06 10:05:43 EST
This problem is caused by gcc bug #144358 .

Until the default 'gcc' compiler is fixed, DHCP must be compiled
with gcc33 from the compat-gcc-8-3.3.4.2 package.

I've submitted dhcp-3.0.1-17 to FC4/rawhide that is compiled with
gcc33, which should be available in the next rawhide release.


*** This bug has been marked as a duplicate of 144358 ***
Comment 6 Jason Vas Dias 2005-01-07 11:33:37 EST
*** Bug 144481 has been marked as a duplicate of this bug. ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:07:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.