Bug 144339 - kernel-2.6.9-1.724_FC3 changes config of pci modem
kernel-2.6.9-1.724_FC3 changes config of pci modem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 145149 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-05 23:56 EST by Dmitri A. Sergatskov
Modified: 2015-01-04 17:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 19:02:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci -vvv with 2.6.9-1.681_FC3 kernel (1.61 KB, application/x-gzip)
2005-01-05 23:59 EST, Dmitri A. Sergatskov
no flags Details

  None (edit)
Description Dmitri A. Sergatskov 2005-01-05 23:56:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After updating to kernel-2.6.9-1.724_FC3, pci modem configured to
ttyS14 instead of ttyS4. That seems to confuse kudzu. 
/dev/modem is not being configure at boot, which in turn breaks
all dial-up configurations...



Version-Release number of selected component (if applicable):
kernel-2.6.9-1.724_FC3

How reproducible:
Always

Steps to Reproduce:
1.boot to kernel-2.6.9-1.724_FC3
2.check for /dev/modem
3.
    

Actual Results:  is not there. Actual modem configure to /dev/ttyS14
instead of
/dev/ttyS4 


Expected Results:  Modem at /dev/ttyS4. Kudzu (?) sets /dev/modem ->
/dev/ttyS4

Additional info:

Athlon XP, Asus A7V333 m/b, USR 56k Internal Voice Modem (Model 2976)
(output of "lspci -vvv" is attached)
Comment 1 Dmitri A. Sergatskov 2005-01-05 23:59:50 EST
Created attachment 109412 [details]
output of lspci -vvv with 2.6.9-1.681_FC3 kernel
Comment 2 Dmitri A. Sergatskov 2005-01-06 00:21:32 EST
OK. I did cold reboot (power cycle) and let kudzu unconfigure and
then reconfigure modem. That created /dev/modem. Then I  discovered that
"neat" uses /dev/ttySX device instead fo /dev/modem (kudzu buglet?).
After manually changing that, everything seems to be working again.
I still not sure this (change ttyS4 -> ttyS14) is a desired behavior,
so will live it open but at lower priority.
Comment 3 Jason 2005-01-15 19:39:27 EST
My modem is also now /dev/ttyS14.  I have an actiontec call waiting
modem (internal pci).  Kernel 2.6.10-1.741_FC3 still has this
behavior.  My modem has been /dev/ttyS14 since 2.6.10-1.737_FC3 and
2.6.9-1.724_FC3.
Comment 4 Jason 2005-01-15 19:40:39 EST
*** Bug 145149 has been marked as a duplicate of this bug. ***
Comment 5 Dave Jones 2005-07-15 15:36:31 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 Dmitri A. Sergatskov 2005-07-15 17:28:19 EDT
It looks OK in FC4

Note You need to log in before you can comment on or make changes to this bug.