Bug 1444125 - panic in github.com/openshift/origin/pkg/proxy/hybrid
Summary: panic in github.com/openshift/origin/pkg/proxy/hybrid
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Dan Williams
QA Contact: Meng Bo
URL:
Whiteboard:
: 1551777 (view as bug list)
Depends On:
Blocks: 1445510
TreeView+ depends on / blocked
 
Reported: 2017-04-20 15:39 UTC by Eric Paris
Modified: 2018-04-16 21:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: the hybrid proxy was not correctly protecting access to internal data. Consequence: when the hybrid proxy was enabled, it could terminate the openshift-node process with a runtime panic due to concurrent data accesses. Fix: ensure internal data is correctly protected against concurrent access. Result: openshift-node should no longer panic with concurrent data access failures when the hybrid proxy is enabled.
Clone Of:
: 1445510 (view as bug list)
Environment:
Last Closed: 2017-08-10 05:21:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
logs of the panic (64.70 KB, text/plain)
2017-04-20 15:39 UTC, Eric Paris
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Origin (Github) 13847 0 None None None 2017-04-24 14:59:06 UTC
Red Hat Knowledge Base (Solution) 3414231 0 None None None 2018-04-16 21:23:08 UTC
Red Hat Product Errata RHEA-2017:1716 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.6 RPM Release Advisory 2017-08-10 09:02:50 UTC

Description Eric Paris 2017-04-20 15:39:39 UTC
Created attachment 1273022 [details]
logs of the panic

v3.5.5.7

panic is in the attachment

Comment 1 Eric Paris 2017-05-01 19:45:43 UTC
https://github.com/openshift/origin/pull/13847

Comment 3 Meng Bo 2017-06-02 10:15:45 UTC
Tested idle/unidle related features on 3.6.92, no such pance found, and no regression issue found.

Verify the bug.

Comment 5 errata-xmlrpc 2017-08-10 05:21:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Comment 6 Steven Walter 2018-04-16 21:22:39 UTC
*** Bug 1551777 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.