Bug 1445510 - [3.5] panic in github.com/openshift/origin/pkg/proxy/hybrid
Summary: [3.5] panic in github.com/openshift/origin/pkg/proxy/hybrid
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.z
Assignee: Ben Bennett
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On: 1444125
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-25 20:20 UTC by Ben Bennett
Modified: 2017-05-18 09:28 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Panic due to concurrent access shows in the logs Consequence: Scary log messages (the thread is restarted, so there is no functional problem other than a small cost to rebuild the thread state) Fix: Add the appropriate locking. Result: Clean logs, no panics.
Clone Of: 1444125
Environment:
Last Closed: 2017-05-18 09:28:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ose pull 724 0 None None None 2017-04-25 20:23:02 UTC
Red Hat Product Errata RHBA-2017:1235 0 normal SHIPPED_LIVE OpenShift Container Platform 3.5, 3.4, 3.3, and 3.1 bug fix update 2017-05-18 13:15:52 UTC

Description Ben Bennett 2017-04-25 20:20:20 UTC
+++ This bug was initially created as a clone of Bug #1444125 +++

v3.5.5.7

panic is in the attachment

Comment 2 zhaozhanqi 2017-04-28 03:10:38 UTC
@Ben Bennett

Could you give me some help to verify this bug since I have no idea how to reproduce this bug?

Comment 3 Ben Bennett 2017-04-28 12:46:57 UTC
@zhaozhanqi: Sadly, I can't tell you how to verify this fix.  It happens rarely, and was only seen in the logs on a busy, long-running system.  It would be a tricky race-condition to manage to trigger.  The best we can do is test that it doesn't break anything else, and that the code review caught all of the places the lock was needed.

Definitely run the idling and unidling test cases since that will be where the code is exercised.

Comment 4 Meng Bo 2017-05-03 07:43:16 UTC
Do regression testing on 3.5.5.12 include parallel idling/unidling operations.

No regression issue found and no panic error found in the logs.

Move the bug to verified.

Comment 6 errata-xmlrpc 2017-05-18 09:28:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1235


Note You need to log in before you can comment on or make changes to this bug.