Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1444369

Summary: [RFE] Support for attach/detach of SR-IOV interfaces
Product: Red Hat OpenStack Reporter: Harald Jensås <hjensas>
Component: openstack-novaAssignee: smooney
Status: CLOSED CURRENTRELEASE QA Contact: James Parker <jparker>
Severity: low Docs Contact:
Priority: low    
Version: 10.0 (Newton)CC: alifshit, cswanson, dasmith, dhill, egallen, eglynn, gkadam, hakhande, igallagh, jniu, jparker, jraju, kchamart, lyarwood, mariel, marjones, mwitt, mzheng, nlevinki, oblaut, pablo.iranzo, pkovacs, psahoo, rlondhe, sbauza, sgordon, smooney, spower, srevivo, stephenfin, supadhya, vcojot, vkhitrin, vromanso, weiyongjun
Target Milestone: betaKeywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-nova-23.2.2-0.20220720130412.7074ac0.el9ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1905336 (view as bug list) Environment:
Last Closed: 2022-09-22 10:39:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version: Victoria
Embargoed:
Bug Depends On:    
Bug Blocks: 1170451, 1419948, 1422243, 1476902, 1500557, 1905336    

Description Harald Jensås 2017-04-21 08:59:10 UTC
Need ability to attach, hotplug, second SRIOV VF to instance. 

Version-Release number of selected component (if applicable):
RHEL OSP 10

How reproducible:
Everytime. 

Steps to Reproduce:
1. Spawn an instance using SRIOV Port
2. Tried to attach second SRIOV port to an instance. 
3. It's getting failed with following message: 

~~~
$ nova interface-attach --port-id 4c87802f-0f31-4087-9376-d639801be588 225b9842-aa1b-4a28-b997-537e645953b8
ERROR (ClientException): Unexpected API Error. Please report this at http://bugs.launchpad.net/nova/ and attach the Nova API log if possible.
<class 'PortBindingFailed_Remote'> (HTTP 500) (Request-ID: req-51dd3020-bbd6-4db0-bfea-3fa4e6b8ddff)
~~~

Actual results:
Not able to attach second SRIOV port to an  instance. 

Expected results:
Need ability to hotplug SRIOV port to instance.

There is an abandonen blueprint[1] for this functionality.

[1] https://review.openstack.org/#/c/139910/

Comment 1 Assaf Muller 2017-04-24 12:29:56 UTC
*** Bug 1443092 has been marked as a duplicate of this bug. ***

Comment 2 Stephen Gordon 2017-04-24 15:53:25 UTC
This will be re-assessed in planning for the Queens (13) release. Please note that given differences in the code bases between Newton and Queens as well as the areas a solution to this problem will touch it is currently considered unlikely that this will be backportable.

Comment 4 Stephen Finucane 2018-08-22 14:48:23 UTC
*** Bug 1595046 has been marked as a duplicate of this bug. ***

Comment 14 Stephen Finucane 2020-09-08 15:55:05 UTC
*** Bug 1656523 has been marked as a duplicate of this bug. ***

Comment 15 Stephen Finucane 2020-09-16 14:48:26 UTC
This has landed upstream.

Comment 19 spower 2022-05-31 12:17:53 UTC
This FutureFeature for OSP 17.0 is not marked as an MVP for OSP 17.0 GA so will be targeted for review to be included in OSP 17.1. If Tech Preview is required for OSP 17.0 please clone the BZ and follow Tech Preview procedure.

Comment 23 Artom Lifshitz 2022-08-05 14:19:45 UTC
As this has been VERIFIED already, and James has bandwidth to QA the docs (that have already been written), we can move this back to 17.0.

Comment 25 OSP Team 2022-09-22 10:39:50 UTC
According to our records, this should be resolved by openstack-nova-23.2.2-0.20220720130412.7074ac0.el9ost.  This build is available now.