Bug 1444714 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
Summary: Error reading system DMI information: coercing to Unicode: need string or buf...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
: 1444742 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-24 05:25 UTC by Wei Liu
Modified: 2017-08-01 19:23 UTC (History)
6 users (show)

Fixed In Version: subscription-manager-1.19.10-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:23:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
the rhsm log (13.20 KB, text/plain)
2017-04-24 05:26 UTC, Wei Liu
no flags Details
the rhsmcertd log (1.35 KB, text/plain)
2017-04-24 05:26 UTC, Wei Liu
no flags Details
Attaching the rhsm-debug system report (47.50 KB, application/x-gzip)
2017-04-25 18:18 UTC, John Sefler
no flags Details


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1607 None closed 1444714: Error reading system DMI information 2020-08-13 20:52:17 UTC
Red Hat Bugzilla 1447722 None CLOSED rhsmcertd-worker: Error reading networking information: [Errno 13] Permission denied 2019-10-23 13:40:47 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Internal Links: 1447722

Description Wei Liu 2017-04-24 05:25:43 UTC
Description of problem:
Error message append to rhsm.log when register a system with no installed products and restart the rhsmcertd service.

Version-Release number of selected component (if applicable):
subscription-manager version:
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.9-1.el7
python-rhsm: 1.19.5-1.el7

How reproducible:
always

Steps to Reproduce:
1.Install build RHEL-7.4-20170421.1
2.remove the system's product cert.
#mv /etc/pki/product-default/*.pem /root/tmp
3.register the system
#subscription-manager register
4.restart the rhsmcertd
#serverice rhsmcertd restart
5.check rhsm.log in /var/log/rhsm/
[root@dhcp-129-210 rhsm]# cat rhsm.log | grep Error
2017-04-24 13:13:05,485 [WARNING] subscription-manager:19995:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-04-24 13:16:00,903 [WARNING] rhsmcertd-worker:20237:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied
2017-04-24 13:16:00,917 [WARNING] rhsmcertd-worker:20237:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-04-24 13:16:00,948 [WARNING] rhsmcertd-worker:20237:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied
2017-04-24 13:16:00,958 [WARNING] rhsmcertd-worker:20237:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied
2017-04-24 13:16:00,959 [WARNING] rhsmcertd-worker:20237:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-04-24 13:16:01,216 [WARNING] rhsmcertd-worker:20237:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied

Actual results:
As step5.

Expected results:
NO error message

Additional info:
rhsm.log and rhsmcertd.log refer to the attachment

Comment 2 Wei Liu 2017-04-24 05:26:17 UTC
Created attachment 1273508 [details]
the rhsm log

Comment 3 Wei Liu 2017-04-24 05:26:38 UTC
Created attachment 1273509 [details]
the rhsmcertd log

Comment 4 John Sefler 2017-04-25 18:15:54 UTC
I also see this WARNING to the rhsm.log by querying the system facts...

[root@jsefler-rhel7 ~]# subscription-manager version 
server type: This system is currently not registered.
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.9-1.el7
python-rhsm: 1.19.5-1.el7


[root@jsefler-rhel7 ~]# subscription-manager facts
cpu.core(s)_per_socket: 1
cpu.cpu(s): 2
cpu.cpu_socket(s): 2
cpu.thread(s)_per_core: 1
cpu.topology_source: kernel /sys cpu sibling lists
distribution.id: Maipo
distribution.name: Red Hat Enterprise Linux Server
distribution.version: 7.4
distribution.version.modifier: beta
lscpu.architecture: x86_64
lscpu.bogomips: 4799.99
lscpu.byte_order: Little Endian
lscpu.core(s)_per_socket: 1
lscpu.cpu(s): 2
lscpu.cpu_family: 6
lscpu.cpu_mhz: 2399.998
lscpu.cpu_op-mode(s): 32-bit, 64-bit
lscpu.flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx rdtscp lm constant_tsc rep_good nopl eagerfpu pni pclmulqdq ssse3 cx16 sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx hypervisor lahf_lm xsaveopt
lscpu.hypervisor_vendor: KVM
lscpu.l1d_cache: 32K
lscpu.l1i_cache: 32K
lscpu.l2_cache: 4096K
lscpu.model: 42
lscpu.model_name: Intel Xeon E312xx (Sandy Bridge)
lscpu.numa_node(s): 1
lscpu.numa_node0_cpu(s): 0,1
lscpu.on-line_cpu(s)_list: 0,1
lscpu.socket(s): 2
lscpu.stepping: 1
lscpu.thread(s)_per_core: 1
lscpu.vendor_id: GenuineIntel
lscpu.virtualization_type: full
memory.memtotal: 1016200
memory.swaptotal: 1048572
net.interface.eth0.ipv4_address: 10.16.7.94
net.interface.eth0.ipv4_address_list: 10.16.7.94
net.interface.eth0.ipv4_broadcast: 10.16.7.255
net.interface.eth0.ipv4_broadcast_list: 10.16.7.255
net.interface.eth0.ipv4_netmask: 22
net.interface.eth0.ipv4_netmask_list: 22
net.interface.eth0.ipv6_address.global: 2620:52:0:1007:5054:ff:feed:8b50
net.interface.eth0.ipv6_address.global_list: 2620:52:0:1007:5054:ff:feed:8b50
net.interface.eth0.ipv6_address.link: fe80::5054:ff:feed:8b50
net.interface.eth0.ipv6_address.link_list: fe80::5054:ff:feed:8b50
net.interface.eth0.ipv6_netmask.global: 64
net.interface.eth0.ipv6_netmask.global_list: 64
net.interface.eth0.ipv6_netmask.link: 64
net.interface.eth0.ipv6_netmask.link_list: 64
net.interface.eth0.mac_address: 52:54:00:ED:8B:50
net.interface.lo.ipv4_address: 127.0.0.1
net.interface.lo.ipv4_address_list: 127.0.0.1
net.interface.lo.ipv4_broadcast: Unknown
net.interface.lo.ipv4_broadcast_list: Unknown
net.interface.lo.ipv4_netmask: 8
net.interface.lo.ipv4_netmask_list: 8
net.interface.lo.ipv6_address.host: ::1
net.interface.lo.ipv6_address.host_list: ::1
net.interface.lo.ipv6_netmask.host: 128
net.interface.lo.ipv6_netmask.host_list: 128
network.fqdn: jsefler-rhel7.usersys.redhat.com
network.hostname: jsefler-rhel7.usersys.redhat.com
network.ipv4_address: 10.16.7.94
network.ipv6_address: fe80::5054:ff:feed:8b50, 2620:52:0:1007:5054:ff:feed:8b50
proc_cpuinfo.common.address_sizes: 40 bits physical, 48 bits virtual
proc_cpuinfo.common.bogomips: 4799.99
proc_cpuinfo.common.cache_alignment: 64
proc_cpuinfo.common.cache_size: 4096 KB
proc_cpuinfo.common.clflush_size: 64
proc_cpuinfo.common.core_id: 0
proc_cpuinfo.common.cpu_cores: 1
proc_cpuinfo.common.cpu_family: 6
proc_cpuinfo.common.cpu_mhz: 2399.998
proc_cpuinfo.common.cpuid_level: 13
proc_cpuinfo.common.flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx rdtscp lm constant_tsc rep_good nopl eagerfpu pni pclmulqdq ssse3 cx16 sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx hypervisor lahf_lm xsaveopt
proc_cpuinfo.common.fpu: yes
proc_cpuinfo.common.fpu_exception: yes
proc_cpuinfo.common.microcode: 0x1
proc_cpuinfo.common.model: 42
proc_cpuinfo.common.model_name: Intel Xeon E312xx (Sandy Bridge)
proc_cpuinfo.common.power_management: Unknown
proc_cpuinfo.common.siblings: 1
proc_cpuinfo.common.stepping: 1
proc_cpuinfo.common.vendor_id: GenuineIntel
proc_cpuinfo.common.wp: yes
system.certificate_version: 3.2
system.default_locale: en_US.UTF-8
uname.machine: x86_64
uname.nodename: jsefler-rhel7.usersys.redhat.com
uname.release: 3.10.0-632.el7.x86_64
uname.sysname: Linux
uname.version: #1 SMP Mon Mar 27 22:53:17 EDT 2017
virt.host_type: kvm
virt.is_guest: True


[root@jsefler-rhel7 ~]# tail -f /var/log/rhsm/rhsm.log | grep Error
2017-04-25 14:08:59,490 [WARNING] subscription-manager:22559:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found

Comment 5 John Sefler 2017-04-25 18:18:42 UTC
Created attachment 1274002 [details]
Attaching the rhsm-debug system report

[root@jsefler-rhel7 ~]# rhsm-debug system
Wrote: /tmp/rhsm-debug-system-20170425-248713.tar.gz

Comment 6 Jiri Hnidek 2017-04-26 09:07:46 UTC
I can confirm this bug in master branch.

Comment 7 Jiri Hnidek 2017-04-26 14:44:14 UTC
Note: removing /etc/pki/default-product/69.pem is not good idea, because this cert file is shipped with system and it tell us about type of system (RHEL 7 x86_64, RHEL 6 i386, etc.). You cannot get this certificate from yum repositories as another certs in /etc/pki/products/.

Comment 11 Chris Snyder 2017-04-27 20:39:10 UTC
*** Bug 1444742 has been marked as a duplicate of this bug. ***

Comment 12 Rehana 2017-05-03 11:59:44 UTC
Reproducing the failure : 
subscription-manager: 1.19.8-1.el7
python-rhsm: 1.19.5-1.el7


# mv /etc/pki/product-default/*.pem /root/tmp
# subscription-manager list --installed

No installed products to list

# subscription-manager register
Registering to: subscription.rhsm.stage.redhat.com:443/subscription
Username: stage_test_rhel74
Password: 
The system has been registered with ID: cf944d02-1214-4dee-8b90-56428ac6851e 

[root@bkr-hv01-guest24 ~]# service rhsmcertd restart
Redirecting to /bin/systemctl restart rhsmcertd.service

# cat rhsm.log | grep Error
2017-05-03 07:33:16,631 [WARNING] rhsmcertd-worker:6885:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied
2017-05-03 07:33:16,643 [WARNING] rhsmcertd-worker:6885:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-03 07:33:16,680 [WARNING] rhsmcertd-worker:6885:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied
2017-05-03 07:33:16,689 [WARNING] rhsmcertd-worker:6885:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied
2017-05-03 07:33:16,690 [WARNING] rhsmcertd-worker:6885:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-03 07:33:16,724 [WARNING] rhsmcertd-worker:6885:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied

# subscription-manager facts
# tail -f /var/log/rhsm/rhsm.log | grep Error
2017-05-03 07:36:22,729 [WARNING] rhsmcertd-worker:6973:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied
2017-05-03 07:36:43,428 [WARNING] subscription-manager:7020:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found

Retesting with latest subscription-manager 
============================================


# subscription-manager  version
server type: This system is currently not registered.
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.10-1.el7
python-rhsm: 1.19.5-1.el7


Observed that now list facts doesn't print any error messages on rhsm.log (issue mentioned in comment 4) , but the issue in the bug description is still observed. 

# mv /etc/pki/product-default/*.pem /root/tmp
# subscription-manager list --installed

No installed products to list

# subscription-manager register
Registering to: subscription.rhsm.stage.redhat.com:443/subscription
Username: stage_test_rhel74
Password: 
The system has been registered with ID: cf944d02-1214-4dee-8b90-56428ac6851e 

[root@bkr-hv01-guest24 ~]# service rhsmcertd restart
Redirecting to /bin/systemctl restart rhsmcertd.service

2017-05-03 07:50:16,019 [WARNING] rhsmcertd-worker:616:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied
2017-05-03 07:50:16,069 [WARNING] rhsmcertd-worker:616:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied
2017-05-03 07:53:20,835 [WARNING] rhsmcertd-worker:690:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied
2017-05-03 07:53:20,889 [WARNING] rhsmcertd-worker:690:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied

Moving this back to "New" in order to get the above issue fixed.

Comment 13 Kevin Howell 2017-05-03 14:43:44 UTC
Rehana, please retest with subscription-manager-1.19.10-1 (as noted in Fixed In Version).

Comment 14 Kevin Howell 2017-05-03 14:44:26 UTC
Rehana, or a version above 1.19.10-1.

Comment 15 Kevin Howell 2017-05-03 14:45:17 UTC
Rehana, my apologies, misread comment 12...

Comment 16 Kevin Howell 2017-05-03 14:52:07 UTC
Rehana, let's handle the networking information issue to a separate bug. I'll open a new one and link it here.

Specifically, I'm opening a new bug for:
2017-05-03 07:53:20,889 [WARNING] rhsmcertd-worker:690:MainThread @hwprobe.py:600 - Error reading networking information: [Errno 13] Permission denied

Comment 17 John Sefler 2017-05-04 21:17:20 UTC
Flipping back to ON_QA, but let's wait on the fix for Bug 1447722 before attempting to verify this bug again.

Comment 18 Wei Liu 2017-05-05 03:36:38 UTC
I try again on the latest build and find new error message:

2017-05-04 12:47:34,328 [WARNING] subscription-manager:59512:MainThread @dmiinfo.py:90 - Error reading system DMI information: list assignment index out of range

subscription-manager version:
subscription-manager-gui-1.19.12-1.el7.x86_64
python-rhsm-certificates-1.19.6-1.el7.x86_64
subscription-manager-initial-setup-addon-1.19.12-1.el7.x86_64
python-rhsm-1.19.6-1.el7.x86_64
subscription-manager-1.19.12-1.el7.x86_64

Steps to Reproduce:
1.Install build RHEL-7.4-20170504.0
2.remove the system's product cert.
#mv /etc/pki/product-default/*.pem /root/tmp
3.register the system
#subscription-manager register
4.restart the rhsmcertd
#serverice rhsmcertd restart
5.check rhsm.log in /var/log/rhsm/
[root@dhcp-129-210 rhsm]# cat rhsm.log | grep Error
2017-05-04 12:47:34,328 [WARNING] subscription-manager:59512:MainThread @dmiinfo.py:90 - Error reading system DMI information: list assignment index out of range

Comment 19 Jiri Hnidek 2017-05-05 18:50:44 UTC
I'm not able to reproduce your last bug report at RHEL-7.4. Please, can you send me more content from /var/log/rhsm/rhsm.log.

Comment 20 Wei Liu 2017-05-08 02:39:36 UTC
Today I tried again on build RHEL-7.4-Beta-1.0(RHEL-7.4-20170504.0),but also failed to reproduce this issue.The rhsm.log is correct now and no error message.So if find this issue later,will open one new bug to track it and attach the rhsm log.

Comment 21 Shwetha Kallesh 2017-05-08 07:41:40 UTC
Reproducer:

[root@bkr-hv01-guest09 ~]# subscription-manager  version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.9-1.el7
python-rhsm: 1.19.5-1.el7


[root@bkr-hv01-guest09 ~]# subscription-manager  register
Registering to: subscription.rhsm.stage.redhat.com:443/subscription
Username: shwetha_tier1_test
Password: 
The system has been registered with ID: 9667365b-00f7-4c13-aca8-3f5a1bb7e5a6 
[root@bkr-hv01-guest09 ~]# service rhsmcertd restart
Redirecting to /bin/systemctl restart rhsmcertd.service


[root@bkr-hv01-guest09 ~]# cd /var/log/rhsm/
[root@bkr-hv01-guest09 rhsm]# cat rhsm.log | grep Error
2017-05-08 03:10:33,890 [WARNING] subscription-manager:12653:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-08 03:29:04,910 [WARNING] subscription-manager:12816:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-08 03:29:44,087 [WARNING] subscription-manager:12873:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-08 03:30:20,799 [WARNING] subscription-manager:12928:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-08 03:30:50,632 [WARNING] subscription-manager:12988:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-08 03:31:55,405 [WARNING] subscription-manager:13057:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found


Facts:

[root@bkr-hv01-guest09 ~]# subscription-manager  facts 

[root@bkr-hv01-guest09 rhsm]# cat rhsm.log | grep Error
2017-05-08 03:10:33,890 [WARNING] subscription-manager:12653:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-08 03:29:04,910 [WARNING] subscription-manager:12816:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-08 03:29:44,087 [WARNING] subscription-manager:12873:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-08 03:30:20,799 [WARNING] subscription-manager:12928:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-08 03:30:50,632 [WARNING] subscription-manager:12988:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-08 03:31:55,405 [WARNING] subscription-manager:13057:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found
2017-05-08 03:39:03,082 [WARNING] subscription-manager:13161:MainThread @dmiinfo.py:86 - Error reading system DMI information: coercing to Unicode: need string or buffer, NoneType found

Comment 22 Shwetha Kallesh 2017-05-08 08:03:32 UTC
[root@bkr-hv01-guest09 rhsm]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.12-1.el7
python-rhsm: 1.19.6-1.el7

Verification for register and facts as rhsmcertd part is moved to separate bug

[root@bkr-hv01-guest09 ~]# subscription-manager  register
Registering to: subscription.rhsm.stage.redhat.com:443/subscription
Username: shwetha_tier1_test
Password: 
The system has been registered with ID: 9667365b-00f7-4c13-aca8-3f5a1bb7e5a6 

[root@bkr-hv01-guest09 rhsm]# date
Mon May  8 03:59:28 EDT 2017


[root@bkr-hv01-guest09 rhsm]# tail -f rhsm.log | grep Error

[root@bkr-hv01-guest09 rhsm]# date
Mon May  8 04:00:58 EDT 2017


[root@bkr-hv01-guest09 ~]# subscription-manager facts

[root@bkr-hv01-guest09 rhsm]# tail -f rhsm.log | grep Error

Comment 23 Shwetha Kallesh 2017-05-08 08:21:23 UTC
Flipping back it on_qa for reasons mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1444714#c17

Comment 24 Rehana 2017-05-16 10:34:11 UTC
Verifying this bug with latest subscription-manager build : 
==========================================================
# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.1.0-1
subscription management rules: 5.23
subscription-manager: 1.19.13-1.el7
python-rhsm: 1.19.6-1.el7


[root@inferno home]# subscription-manager facts --list
cpu.core(s)_per_socket: 1
cpu.cpu(s): 1
cpu.cpu_socket(s): 1
cpu.thread(s)_per_core: 1
cpu.topology_source: kernel /sys cpu sibling lists
distribution.id: Maipo
distribution.name: Red Hat Enterprise Linux Server
distribution.version: 7.4
distribution.version.modifier: beta
dmi.bios.address: 0xe8000
dmi.bios.bios_revision: 1.0
dmi.bios.release_date: 01/01/2007
dmi.bios.rom_size: 64 KB
dmi.bios.runtime_size: 96 KB
dmi.bios.vendor: Seabios
dmi.bios.version: 0.5.1
dmi.chassis.asset_tag: Unknown
dmi.chassis.boot-up_state: Safe
dmi.chassis.lock: Not Present
dmi.chassis.manufacturer: Red Hat
dmi.chassis.power_supply_state: Safe
dmi.chassis.security_status: Unknown
dmi.chassis.serial_number: Unknown
dmi.chassis.thermal_state: Safe
dmi.chassis.type: Other
dmi.chassis.version: Unknown
dmi.memory.array_handle: 0x1000
dmi.memory.bank_locator: Unknown
dmi.memory.data_width: 64 bit
dmi.memory.error_correction_type: Multi-bit ECC
dmi.memory.error_information_handle: Not Provided
dmi.memory.form_factor: DIMM
dmi.memory.location: Other
dmi.memory.locator: DIMM 0
dmi.memory.maximum_capacity: 2 GB
dmi.memory.size: 2048 MB
dmi.memory.speed:   (ns)
dmi.memory.total_width: 64 bit
dmi.memory.type: RAM
dmi.memory.use: System Memory
dmi.meta.cpu_socket_count: 1
dmi.processor.family: Other
dmi.processor.socket_designation: CPU 1
dmi.processor.status: Populated:Enabled
dmi.processor.type: Central Processor
dmi.processor.upgrade: Other
dmi.processor.version: Unknown
dmi.processor.voltage: Unknown
dmi.system.family: Red Hat Enterprise Linux
dmi.system.manufacturer: Red Hat
dmi.system.product_name: KVM
dmi.system.serial_number: Unknown
dmi.system.sku_number: Unknown
dmi.system.status: No errors detected
dmi.system.uuid: 6a8d23cf-219c-68ab-516d-f366c19e8a9e
dmi.system.version: RHEL 6.0.0 PC
dmi.system.wake-up_type: Power Switch
lscpu.architecture: x86_64
lscpu.bogomips: 4533.49
lscpu.byte_order: Little Endian
lscpu.core(s)_per_socket: 1
lscpu.cpu(s): 1
lscpu.cpu_family: 6
lscpu.cpu_mhz: 2266.746
lscpu.cpu_op-mode(s): 32-bit, 64-bit
lscpu.flags: fpu de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pse36 clflush mmx fxsr sse sse2 syscall nx lm nopl pni cx16 hypervisor lahf_lm
lscpu.hypervisor_vendor: KVM
lscpu.l1d_cache: 32K
lscpu.l1i_cache: 32K
lscpu.l2_cache: 4096K
lscpu.model: 13
lscpu.model_name: QEMU Virtual CPU version (cpu64-rhel6)
lscpu.numa_node(s): 1
lscpu.numa_node0_cpu(s): 0
lscpu.on-line_cpu(s)_list: 0
lscpu.socket(s): 1
lscpu.stepping: 3
lscpu.thread(s)_per_core: 1
lscpu.vendor_id: GenuineIntel
lscpu.virtualization_type: full
memory.memtotal: 1883640
memory.swaptotal: 1048572
net.interface.eth0.ipv4_address: 10.65.206.77
net.interface.eth0.ipv4_address_list: 10.65.206.77
net.interface.eth0.ipv4_broadcast: 10.65.207.255
net.interface.eth0.ipv4_broadcast_list: 10.65.207.255
net.interface.eth0.ipv4_netmask: 23
net.interface.eth0.ipv4_netmask_list: 23
net.interface.eth0.ipv6_address.link: fe80::5054:ff:fe01:1733
net.interface.eth0.ipv6_address.link_list: fe80::5054:ff:fe01:1733
net.interface.eth0.ipv6_netmask.link: 64
net.interface.eth0.ipv6_netmask.link_list: 64
net.interface.eth0.mac_address: 52:54:00:01:17:33
net.interface.lo.ipv4_address: 127.0.0.1
net.interface.lo.ipv4_address_list: 127.0.0.1
net.interface.lo.ipv4_broadcast: Unknown
net.interface.lo.ipv4_broadcast_list: Unknown
net.interface.lo.ipv4_netmask: 8
net.interface.lo.ipv4_netmask_list: 8
net.interface.lo.ipv6_address.host: ::1
net.interface.lo.ipv6_address.host_list: ::1
net.interface.lo.ipv6_netmask.host: 128
net.interface.lo.ipv6_netmask.host_list: 128
network.fqdn: inferno.lab.eng.pnq.redhat.com
network.hostname: inferno.lab.eng.pnq.redhat.com
network.ipv4_address: 10.65.206.77
network.ipv6_address: fe80::5054:ff:fe01:1733
proc_cpuinfo.common.address_sizes: 40 bits physical, 48 bits virtual
proc_cpuinfo.common.apicid: 0
proc_cpuinfo.common.bogomips: 4533.49
proc_cpuinfo.common.cache_alignment: 64
proc_cpuinfo.common.cache_size: 4096 KB
proc_cpuinfo.common.clflush_size: 64
proc_cpuinfo.common.core_id: 0
proc_cpuinfo.common.cpu_cores: 1
proc_cpuinfo.common.cpu_family: 6
proc_cpuinfo.common.cpu_mhz: 2266.746
proc_cpuinfo.common.cpuid_level: 4
proc_cpuinfo.common.flags: fpu de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pse36 clflush mmx fxsr sse sse2 syscall nx lm nopl pni cx16 hypervisor lahf_lm
proc_cpuinfo.common.fpu: yes
proc_cpuinfo.common.fpu_exception: yes
proc_cpuinfo.common.initial_apicid: 0
proc_cpuinfo.common.microcode: 0x1
proc_cpuinfo.common.model: 13
proc_cpuinfo.common.model_name: QEMU Virtual CPU version (cpu64-rhel6)
proc_cpuinfo.common.physical_id: 0
proc_cpuinfo.common.power_management: Unknown
proc_cpuinfo.common.processor: 0
proc_cpuinfo.common.siblings: 1
proc_cpuinfo.common.stepping: 3
proc_cpuinfo.common.vendor_id: GenuineIntel
proc_cpuinfo.common.wp: yes
system.certificate_version: 3.2
system.default_locale: en_US.UTF-8
uname.machine: x86_64
uname.nodename: inferno.lab.eng.pnq.redhat.com
uname.release: 3.10.0-666.el7.x86_64
uname.sysname: Linux
uname.version: #1 SMP Thu May 11 11:24:52 EDT 2017
virt.host_type: kvm
virt.is_guest: True
virt.uuid: 6a8d23cf-219c-68ab-516d-f366c19e8a9e


#tail -f /var/log/rhsm/rhsm.log 

2017-05-16 15:57:29,213 [INFO] rhsmd:5429:MainThread @rhsmd:263 - rhsmd started
2017-05-16 15:57:29,352 [INFO] subscription-manager:5423:MainThread @managercli.py:522 - X-Correlation-ID: 59584fe8222445ccbeb79e312370485d
2017-05-16 15:57:29,352 [INFO] subscription-manager:5423:MainThread @managercli.py:411 - Client Versions: {'python-rhsm': '1.19.6-1.el7', 'subscription-manager': '1.19.13-1.el7'}
2017-05-16 15:57:29,353 [INFO] subscription-manager:5423:MainThread @connection.py:780 - Connection built: host=F21-candlepin.usersys.redhat.com port=8443 handler=/candlepin auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
2017-05-16 15:57:29,354 [INFO] subscription-manager:5423:MainThread @connection.py:780 - Connection built: host=F21-candlepin.usersys.redhat.com port=8443 handler=/candlepin auth=none
2017-05-16 15:57:31,007 [INFO] subscription-manager:5423:MainThread @dmiinfo.py:75 - Using dmidecode dump file: /dev/mem

# cat /var/log/rhsm/rhsm.log | grep Error
# 

With latest subscription-manager build, No warning messages are logged in rhsm.log after querying facts

Moving the bug to Verified!!

Comment 25 errata-xmlrpc 2017-08-01 19:23:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.