Bug 1444742 - Missing virt.uuid fact both in GUI and CLI
Summary: Missing virt.uuid fact both in GUI and CLI
Keywords:
Status: CLOSED DUPLICATE of bug 1444714
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Chris Snyder
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-24 07:38 UTC by Wei Liu
Modified: 2017-04-28 01:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-27 20:39:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
missing virt.uuid (172.37 KB, image/png)
2017-04-24 07:38 UTC, Wei Liu
no flags Details
rhsm.log (28.59 KB, text/plain)
2017-04-25 03:08 UTC, qianzhan
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1438085 high CLOSED fact collection behavior of 'virt.uuid' has changed for 'virt.host_type's containing {"ibm_systemz","powervm"} 2020-10-14 00:28:05 UTC

Internal Links: 1438085

Description Wei Liu 2017-04-24 07:38:53 UTC
Created attachment 1273549 [details]
missing virt.uuid

Description of problem:
Missing virt_uuid fact does not appear in GUI and also can not find with cli

Version-Release number of selected component (if applicable):
subscription-manager version:
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.9-1.el7
python-rhsm: 1.19.5-1.el7

How reproducible:
always

Steps to Reproduce:
1. Install build RHEL-7.4-20170421.1
2. open subscription-manager-gui.
3. open "System Facts" window form menu bar "System -> System Facts"
4. Find the option "virt" and unfold it.
virt.uuid not appear
5. Find virt info by CLI 
# subscription-manager facts --list | grep virt
lscpu.virtualization_type: full
proc_cpuinfo.common.address_sizes: 36 bits physical, 48 bits virtual
virt.host_type: kvm
virt.is_guest: True


Actual results:
As step4.

Expected results:
After step 4. the virt property should show like below :

virt.host_type: kvm
virt.is_guest: True
virt.uuid: e98648c3-c9de-3b11-cfc8-636baecd8632   <---

and cli can aslo work.

Additional info:
GUI refer to the attachment

Comment 2 Kevin Howell 2017-04-24 14:45:36 UTC
Can you please provide /var/log/rhsm/rhsm.log?

Comment 3 John Sefler 2017-04-24 19:02:23 UTC
Is this related to the work on Bug 1438085?

Comment 4 qianzhan 2017-04-25 03:08:22 UTC
(In reply to Kevin Howell from comment #2)
> Can you please provide /var/log/rhsm/rhsm.log?

Please check the attachment 'rhsm.log'.

Comment 5 qianzhan 2017-04-25 03:08:49 UTC
Created attachment 1273798 [details]
rhsm.log

Comment 7 Chris Snyder 2017-04-27 20:39:10 UTC
This bug will be fixed by the fix for bz 1444714.

I have verified that the root cause of this bz was the same as that one.

Closing as a duplicate of that bz.

*** This bug has been marked as a duplicate of bug 1444714 ***


Note You need to log in before you can comment on or make changes to this bug.