Bug 1444848 - Error while importing a VM from 4.0 data domain
Summary: Error while importing a VM from 4.0 data domain
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.1.1.6
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: ovirt-4.1.2
: 4.1.2.2
Assignee: jniederm
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks: 1449353
TreeView+ depends on / blocked
 
Reported: 2017-04-24 12:22 UTC by jniederm
Modified: 2017-05-12 16:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Backend error popup "Cannot import Tempalte. Memory size (X MB) cannot exceed maximum memory size (0MB)." appears when importing template from pre 4.1 environment from non-master data domain. Fix: Maximum memory handling during template import fixed. Result:
Clone Of:
Environment:
Last Closed: 2017-05-12 16:33:15 UTC
oVirt Team: Virt
rule-engine: ovirt-4.1+
rule-engine: blocker+
mtessun: planning_ack+
rule-engine: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
screenshot.png (43.68 KB, image/jpeg)
2017-04-24 12:23 UTC, jniederm
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1449641 None None None Never
oVirt gerrit 76016 master MERGED core: ImportVmTemplateFromConfiguration handles maxMemory 2017-04-27 15:14:18 UTC
oVirt gerrit 76017 ovirt-engine-4.1 MERGED core: ImportVmTemplateFromConfiguration handles maxMemory 2017-05-10 06:48:20 UTC

Internal Links: 1449641

Description jniederm 2017-04-24 12:22:31 UTC
Description of problem:
Backend error thrown while importing template, that was created in engine 4.0, from non-master data storage domain.

http://lists.ovirt.org/pipermail/users/2017-April/081367.html

Version-Release number of selected component (if applicable):
user: ovirt 4.1.1.6
peproduced on: branch ovirt-engine-4.1, commit e196e21

How reproducible:
100%

Steps to Reproduce:
1. In engine 4.0: let's have a host, storage domain and VM
2. create template from the VM
3. "update OVFs" on the storage domain (right click on the storage comain)
4. add new data storage domain
5. put old storage domain to maintenance, detach and remove it
6. remove the VM and template
7. upgrade to engine 4.1 and upgrade cluster version to 4.1
8. import the original storage domain (alongside new storage domain)
9. initiate import of the template from the original storage domain (select original storage domain, select "template import" subtab, select the template, click "Import" toolbar button)

Actual results:
Error dialog shown

Expected results:
template imported

Additional info:

Comment 1 jniederm 2017-04-24 12:23:13 UTC
Created attachment 1273602 [details]
screenshot.png

Comment 2 rhev-integ 2017-05-12 15:10:18 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Tag 'ovirt-engine-4.1.2' doesn't contain patch 'https://gerrit.ovirt.org/76017']
gitweb: https://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=shortlog;h=refs/tags/ovirt-engine-4.1.2

For more info please contact: infra@ovirt.org


Note You need to log in before you can comment on or make changes to this bug.