Bug 1449353 - Unable to import a template to RHV 4.1 from Storage domain imported of RHEV 3.5
Summary: Unable to import a template to RHV 4.1 from Storage domain imported of RHEV 3.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.1
Hardware: All
OS: Linux
high
urgent
Target Milestone: ovirt-4.2.0
: ---
Assignee: jniederm
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On: 1444848
Blocks: 1449641
TreeView+ depends on / blocked
 
Reported: 2017-05-09 18:19 UTC by Koutuk Shukla
Modified: 2019-05-16 13:18 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when importing a template into Red Hat Virtualization 4.2 from a storage domain that had previously been attached to an environment earlier than version 4.1, a maximum memory error occurred. In the current release, the maximum memory limitation has been fixed.
Clone Of:
: 1449641 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:42:49 UTC
oVirt Team: Virt


Attachments (Terms of Use)
engine.log (822.95 KB, text/plain)
2017-05-09 18:19 UTC, Koutuk Shukla
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 None None None 2018-05-15 17:44:33 UTC

Description Koutuk Shukla 2017-05-09 18:19:45 UTC
Created attachment 1277417 [details]
engine.log

Description of problem:
Unable to import a template to RHV 4.1 from Storage domain imported of RHEV 3.5. Storage domain previously attached to RHEV 3.5.

Version-Release number of selected component (if applicable):

Red Hat Virtualization Manager Version: 4.1.1.8-0.1.el7 

How reproducible:
100%

Steps to Reproduce:
1. Detach a NFS Storage domain containing a Template configured with Memory 8GB
2. Import Storage domain to RHV 4.1 
3. Try to Import the Template.

Actual results:
Template import fails with below errors.

2017-05-09 23:31:15,697+05 WARN  [org.ovirt.engine.core.bll.exportimport.ImportVmTemplateFromConfigurationCommand] (default task-19) [96ef9c83-ee83-4db4-9216-46a9b4bf2b4e] Validation of action 'ImportVmTemplateFromConfiguration' failed for user admin@internal-authz. Reasons: VAR__ACTION__IMPORT,VAR__TYPE__VM_TEMPLATE,ACTION_TYPE_FAILED_MAX_MEMORY_CANNOT_BE_SMALLER_THAN_MEMORY_SIZE,$maxMemory 0,$memory 8192


Expected results:
Template should be imported sucessfully.


Additional info:
Attaching engine.log of RHV 4.1 environment.

Details: 

Template name: test-template
CPU : 1
Memory : 8GB

Failure event from engine.log

2017-05-09 23:31:14,621+05 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetImageInfoVDSCommand] (default task-19) [96ef9c83-ee83-4db4-9216-46a9b4bf2b4e] START, GetImageInfoVDSCommand( GetImageInfoVDSCommandParameters:{runAsync='true', storagePoolId='00000001-0001-0001-0001-000000000311', ignoreFailoverLimit='false', storageDomainId='178d4880-af35-48fa-88ff-e5a2b455d0bd', imageGroupId='1f91fc2d-e326-4fa7-8470-9b2c48054220', imageId='1976d000-cf13-4c13-be5e-c9eb4eb026d3'}), log id: 5f4ea8bb
2017-05-09 23:31:14,622+05 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.GetVolumeInfoVDSCommand] (default task-19) [96ef9c83-ee83-4db4-9216-46a9b4bf2b4e] START, GetVolumeInfoVDSCommand(HostName = hosted-engine1, GetVolumeInfoVDSCommandParameters:{runAsync='true', hostId='4eb08795-9d4b-4bff-9a9d-e6a9e881a4bf', storagePoolId='00000001-0001-0001-0001-000000000311', storageDomainId='178d4880-af35-48fa-88ff-e5a2b455d0bd', imageGroupId='1f91fc2d-e326-4fa7-8470-9b2c48054220', imageId='1976d000-cf13-4c13-be5e-c9eb4eb026d3'}), log id: 1811eaa
2017-05-09 23:31:15,680+05 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.GetVolumeInfoVDSCommand] (default task-19) [96ef9c83-ee83-4db4-9216-46a9b4bf2b4e] FINISH, GetVolumeInfoVDSCommand, return: org.ovirt.engine.core.common.businessentities.storage.DiskImage@742517c2, log id: 1811eaa
2017-05-09 23:31:15,680+05 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetImageInfoVDSCommand] (default task-19) [96ef9c83-ee83-4db4-9216-46a9b4bf2b4e] FINISH, GetImageInfoVDSCommand, return: org.ovirt.engine.core.common.businessentities.storage.DiskImage@742517c2, log id: 5f4ea8bb
2017-05-09 23:31:15,697+05 WARN  [org.ovirt.engine.core.bll.exportimport.ImportVmTemplateFromConfigurationCommand] (default task-19) [96ef9c83-ee83-4db4-9216-46a9b4bf2b4e] Validation of action 'ImportVmTemplateFromConfiguration' failed for user admin@internal-authz. Reasons: VAR__ACTION__IMPORT,VAR__TYPE__VM_TEMPLATE,ACTION_TYPE_FAILED_MAX_MEMORY_CANNOT_BE_SMALLER_THAN_MEMORY_SIZE,$maxMemory 0,$memory 8192

Comment 4 Michal Skrivanek 2017-05-10 07:21:51 UTC
done on master

Comment 7 Israel Pinto 2017-11-27 13:43:15 UTC
Verify with:
Software version:4.2.0-0.5.master.el7


Steps to Reproduce:
In RHV 3.5: 
1. Create VM with 2 GB memory and create template from this VM
2. Export template to export domain
3. Detached export domain 
In RHV 4.2
1. Attached export domain
2. Import template
3. Create New VM from template

PASS

Comment 8 RHV Bugzilla Automation and Verification Bot 2017-12-06 16:16:29 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No relevant external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 9 RHV Bugzilla Automation and Verification Bot 2017-12-12 21:15:03 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No relevant external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 10 RHV Bugzilla Automation and Verification Bot 2017-12-18 17:05:28 UTC
INFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[No relevant external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 13 errata-xmlrpc 2018-05-15 17:42:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 14 Franta Kust 2019-05-16 13:06:45 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.