Bug 144487 - Vietnamese Locale does not collate correctly
Summary: Vietnamese Locale does not collate correctly
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-07 17:05 UTC by Srin Tuar
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 516467 (view as bug list)
Environment:
Last Closed: 2006-08-31 01:08:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
locale source file (8.54 KB, text/plain)
2005-01-07 17:06 UTC, Srin Tuar
no flags Details

Description Srin Tuar 2005-01-07 17:05:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
The vietnamese locale, vi_VN, as shipped with fc3, does not sort text
correctly. Pablo Saratxaga has created a modified vi_VN for mandrake,
after installing that on my fc3 things worked much better! It would be
nice if we could include it in the next fedora core- or even better if
Ulrich could get it in the next glibc release.



Version-Release number of selected component (if applicable):
glibc-2.3.3-74

How reproducible:
Always

Steps to Reproduce:
1. Create a file TOSORT.txt containting the lines
Äó
dâu
dấu
2. LC_ALL=vi_VN sort < TOSORT.txt

Actual Results:
dâu
Äó
dấu


Expected Results:
dâu
dấu
Äó


Additional info:

the sprm "locales-2.3.1.4-6mdk.src.rpm", is googleable, it
contains a copy of vi_VN which can be made to generate
a good Vietnamese locale

Comment 1 Srin Tuar 2005-01-07 17:06:58 UTC
Created attachment 109477 [details]
locale source file

locale file

Comment 2 Ulrich Drepper 2005-06-30 19:57:10 UTC
I assume you're a native speaker and can vouch for the correctness (or better
suitability)?

Comment 3 Srin Tuar 2005-07-07 02:37:46 UTC
I am not a native speaker.

Documentation in English, if you want: 
http://vietunicode.sourceforge.net/charset/v3.htm

Comment 4 Ulrich Drepper 2005-07-08 01:32:48 UTC
If you're not a native speaker, why should your information be trusted?  Unless
you can soon produce conclusive evidence from an authorative sources I'll close
the bug as NOTABUG.

Comment 5 Nguyen Thai Ngoc Duy 2005-07-08 10:02:17 UTC
There is a bug on glibc bugzilla on vi_VN
(http://sources.redhat.com/bugzilla/show_bug.cgi?id=448)
And yes, i'm a native Vietnamese speaker, Vietnamese GNOME translation
coordinator and translator of other projects so you may trust me :)
BTW, could you close glibc bug 448 please?

Comment 6 Ulrich Drepper 2005-07-08 16:20:39 UTC
I've added the new version to the upstream CVS.  The proposed changes in the
sourceware bug system is quite different.  Since that bug was older I
disregarded that version.  But somebody better verify that this is correct.

Comment 7 Nguyen Thai Ngoc Duy 2005-07-10 09:49:28 UTC
I have some comment about this on sourceware bug system because as the time i
was checking mails, redhat bugzilla was down. Please have a look.

Comment 8 Lawrence Lim 2006-08-31 01:08:34 UTC
Bug has been resolved upstream.

<http://sources.redhat.com/bugzilla/show_bug.cgi?id=448#c15>


Note You need to log in before you can comment on or make changes to this bug.