Bug 144538 - 'nfsnobody' UID causes huge /var/log/lastlog
'nfsnobody' UID causes huge /var/log/lastlog
Status: CLOSED DUPLICATE of bug 165058
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-07 17:52 EST by Steve Huston
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 07:08:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Huston 2005-01-07 17:52:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
Related to the bug mentioned here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138676

When doing an install of FC3 on an Opteron system, the
/var/log/lastlog file would fill all of /var causing the install to
fail.  While the file should be sparse, and therefore "appear" larger
than it is, I wonder if the problem is related to differences in how
ReiserFS deals with sparse files (which is the FS used in this case).
 ie, in that bug, the user said that 'ls' showed the inflated size,
while 'du' showed the "real" size.  On my machine it does the opposite.

Either way, the solution was to remove the file during the install,
and before nfs-utils installed and created the nfsnobody user.  Then
change the UID and GID for nfsnobody to 65534 and touch
/var/log/lastlog so it can be created on next login.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC3 on x86_64 with ReiserFS for /var
2. Wait for nfs-utils to be installed
3. /mnt/sysimage/var is now full, install fails as RPM complains
    

Actual Results:  Install failed with error messages that the disk was full

Expected Results:  Either the file shouldn't be that large (sparse
files in ReiserFS issue), or the UID/GID number should be 65535, which
would cure the symptom but not necessarily the problem.

Additional info:

Setting high, as this would affect anyone trying to do an install with
ReiserFS and a disk smaller than 1TB
Comment 1 Trond Eivind Glomsrød 2005-02-16 11:06:24 EST
This also happens on RHEL4 x86-64... on a fresh install, /var/log/lastlog is
1.2T causing problems for some programs
Comment 2 Ken Snider 2005-03-11 20:09:27 EST
This also occurs on RHEL3 x86_64 - I'm wondering if this is
*exclusively* a 64-bit issue?
Comment 3 Steve Dickson 2005-09-06 07:08:19 EDT

*** This bug has been marked as a duplicate of 165058 ***

Note You need to log in before you can comment on or make changes to this bug.