Bug 165058 - nfs-utils makes a nfsnobody user which on 64b platforms is 4294967294
nfs-utils makes a nfsnobody user which on 64b platforms is 4294967294
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
: 144538 (view as bug list)
Depends On:
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-08-03 18:46 EDT by Steve Dickson
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2005-727
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 13:45:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2005-08-03 18:46:39 EDT
+++ This bug was initially created as a clone of Bug #149407 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041215
Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
 nfs-utils makes a nfsnobody user which on 64b platforms is 4294967294

 106  # Define the correct unsigned uid value for 32 or 64 bit archs
  107  %ifarch %{all_32bit_archs}
  108  %define nfsnobody_uid   65534
  109  %else
  110  %define nfsnobody_uid   4294967294
  111  %endif
  112
  113  # If UID 65534 (or 4294967294 64bit archs) is unassigned, create user
"nfsnobody"
  114  cat /etc/passwd | cut -d':' -f 3 | grep --quiet %{nfsnobody_uid} 2>/dev/null
  115  if [ "$?" -eq 1 ]; then
  116          /usr/sbin/useradd -c "Anonymous NFS User" -r \
  117                  -s /sbin/nologin -u %{nfsnobody_uid} -d /var/lib/nfs
nfsnobody 2>/dev/null || :
  118  fi

From the lastlog man page they have:

CAVEATS
      Large  gaps in uid numbers will cause the lastlog program to run longer
      with no output to the screen (i.e. if mmdf=800 and last  uid=170,  pro-
      gram will appear to hang as it processes uid 171-799).

Consequently when the nfs-utils package is installed /var/log/lastlog gets
turned into a HUGE sparse file and lastlog takes a long time to run because of
the huge gap.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install the nfs-utils package


  

Actual Results:  /var/log/lastlog is turned into a really large sparse file. 
Lastlog takes a long time to run.  The customer discovered this when one of
their backup like systems died when confronted with the 1.2TB lastlog file.

Expected Results:  The lastlog should not have been so large.  

Additional info:

This bugzilla is tied to IT #64891.  It has been discussed that nfs-utils needs
to have an option in it to not add the nfsnobody user to the last database.  

Bugzilla ID 146214 mentions a new shadow-utils from CVS in which there is a new
option "-l".  This option tells useradd not to add the user to the last database. 

nfs-utils somehow needs to use this option so it does not add the nfsnobody user
to the last database.
Comment 1 Steve Dickson 2005-08-03 19:42:36 EDT
fixed in nfs-utils-1.0.6-60.EL4
Comment 5 Steve Dickson 2005-09-06 07:08:38 EDT
*** Bug 144538 has been marked as a duplicate of this bug. ***
Comment 7 Red Hat Bugzilla 2005-10-05 13:31:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-727.html
Comment 8 Red Hat Bugzilla 2005-10-05 13:45:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-727.html
Comment 9 Jamie Bohr 2007-05-31 20:02:32 EDT
1.0.6-80 still has an issue

-> rpm -q nfs-utils
nfs-utils-1.0.6-80.EL4
-> ll -hal /var/log/lastlog
-r--------  1 root root 1.2T May 31 17:43 /var/log/lastlog
->

Note You need to log in before you can comment on or make changes to this bug.