Bug 1445502 - On a single-node cluster, multicast is never correctly set up.
Summary: On a single-node cluster, multicast is never correctly set up.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.z
Assignee: Ben Bennett
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On: 1445501
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-25 19:58 UTC by Ben Bennett
Modified: 2017-05-18 09:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The code to set up multicast was not run when only one node was in the cluster. Consequence: Multicast traffic was dropped when on a single-node cluster. Fix: Change the rules so the multicast setup is performed for a single-node. Result: Multicast works for single-node clusters.
Clone Of: 1445501
Environment:
Last Closed: 2017-05-18 09:28:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ose pull 722 0 None None None 2017-04-25 19:58:32 UTC
Red Hat Product Errata RHBA-2017:1235 0 normal SHIPPED_LIVE OpenShift Container Platform 3.5, 3.4, 3.3, and 3.1 bug fix update 2017-05-18 13:15:52 UTC

Description Ben Bennett 2017-04-25 19:58:32 UTC
+++ This bug was initially created as a clone of Bug #1445501 +++

Description of problem:

On a single-node cluster, multicast packets are not delivered.


Version-Release number of selected component (if applicable):

3.5.0

How reproducible:

Always

Steps to Reproduce:
1. Create a single node cluster
2. Create a pod to receive multicast packets
3. Create a pod to send multicast packets
4. Watch for multicast delivery

Actual results:

At step 4, no packets are delivered.

Expected results:

At step 4, packets should be delivered.

Additional info:

Comment 2 Hongan Li 2017-04-28 07:33:20 UTC
verified in atomic-openshift-3.5.5.10-1.git.0.9290eec.el7.x86_64 and the bug has been fixed. Multicast works well on single node cluster.



# ovs-ofctl dump-flows br0 -O openflow13 | grep table=111
 cookie=0x0, duration=7463.021s, table=111, n_packets=78, n_bytes=7062, priority=100 actions=goto_table:120

Comment 4 errata-xmlrpc 2017-05-18 09:28:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1235


Note You need to log in before you can comment on or make changes to this bug.