Bug 144576 - gnome-terminal doesn't implement ESC [ ... S and ESC [ ... T ("indn", "rin")
Summary: gnome-terminal doesn't implement ESC [ ... S and ESC [ ... T ("indn", "rin")
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-08 18:27 UTC by Miloslav Trmač
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 21:08:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test case. (425 bytes, text/plain)
2005-01-08 18:29 UTC, Miloslav Trmač
no flags Details

Description Miloslav Trmač 2005-01-08 18:27:56 UTC
Description of problem:
This problem is one of those buried deep in bug 122815;
it might be the cause of bug 128375 and others, but I
haven't examined them.

I hope providing a minimal, easily reproducible testcase will
allow focusing on this single issue for this bug report...

TERM=xterm by default in gnome-terminal, but gnome-terminal doesn't
implement the "indn" and "rin" control sequences in xterm's
terminfo entry. This can lead to display corruption.

Version-Release number of selected component (if applicable):
ncurses-5.4-13
gnome-terminal-2.7.3-1
vte-0.11.11-6

Steps to Reproduce:
$ gcc nctest2.c -lncurses
$ ./a.out
[test string is at line 10, like it should...]
press any key
[test string is still at line 10, should be at line 20...]
press any key to exit

Similarly when compiling with -DUP, except that the role of
lines 10 and 20 is reversed.

Comment 1 Miloslav Trmač 2005-01-08 18:29:07 UTC
Created attachment 109516 [details]
Test case.

Comment 2 Miloslav Trmač 2005-01-10 21:08:01 UTC
Silly me... it is already fixed in rawhide (vte-0.11.11-15).
Sorry for the spam.

Let me just note that having that as a FC3 update would be
really nice.


Note You need to log in before you can comment on or make changes to this bug.