Bug 144634 - daemon() mishandles command argument as calling runuser
daemon() mishandles command argument as calling runuser
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 144843 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-10 00:11 EST by Kazuyuki Maejima
Modified: 2014-03-16 22:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 16:12:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kazuyuki Maejima 2005-01-10 00:11:40 EST
Description of problem:

iiim service would not start, leaving the following message:

runuser: invalid option -- r
Try `runuser --help' for more information.

Version-Release number of selected component (if applicable):

8.02-1

How reproducible:

Always

Steps to Reproduce:

Run /sbin/service iiim start (or restart when lock file remains)
  
Actual results:

IIIMF input server would not start.

Expected results:

IIIMF input server starts.

Additional info:

Tracing iiim initscript by `sh -x', I found runuser
called with oddly quoted arguments.  Apparently
-c option only took '"/usr/sbin/htt', and -retryonerr
was another runuser option, which caused the error.

+ runuser -s /bin/bash - htt -c '"/usr/sbin/htt' -retryonerror '0"'

Deleting backslashes from the runuser command line in
/etc/rc.d/init.d/functions solves this problem.

           $nice runuser -s /bin/bash - $user -c "$*"

After the above chage, arguments are quoted appropriately.

+ runuser -s /bin/bash - htt -c '/usr/sbin/htt -retryonerror 0'
Comment 1 Bill Nottingham 2005-01-10 16:12:54 EST
Thanks, will be fixed in the next build.
Comment 2 Bill Nottingham 2005-01-11 17:27:10 EST
*** Bug 144843 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.