Bug 144843 - iiim invalid option - quotes problem in daemon
iiim invalid option - quotes problem in daemon
Status: CLOSED DUPLICATE of bug 144634
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 16:53 EST by Ivan Gyurdiev
Modified: 2014-03-16 22:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-01-11 16:53:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
iiim fails on startup complaining something like:
runuser -- -r: invalid option

This fixes it for me

--- functions.old       2005-01-11 14:48:48.000000000 -0700
+++ functions   2005-01-11 14:49:01.000000000 -0700
@@ -147,7 +147,7 @@
        if [ -z "$user" ]; then
           $nice $*
        else
-          $nice runuser -s /bin/bash - $user -c \"$*\"
+          $nice runuser -s /bin/bash - $user -c "$*"
        fi
        [ "$?" -eq 0 ] && success $"$base startup" || failure $"$base
startup"
 }


Version-Release number of selected component (if applicable):
initscripts-8.02-1

How reproducible:
Always

Steps to Reproduce:
1. See summary
    

Additional info:
Comment 1 Bill Nottingham 2005-01-11 17:26:58 EST

*** This bug has been marked as a duplicate of 144634 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.