Bug 1446432 - Minimal install option install full gnome desktop
Summary: Minimal install option install full gnome desktop
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords: Triaged
Depends On:
Blocks: F26BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2017-04-28 01:11 UTC by Germán Ríos González
Modified: 2017-05-15 23:18 UTC (History)
18 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-05-14 20:19:45 UTC


Attachments (Terms of Use)

Description Germán Ríos González 2017-04-28 01:11:10 UTC
Description of problem:
When you install F26 alpha with de minimal install option anaconda install full gnome desktop

Version-Release number of selected component (if applicable):
Fedora 26 Alpha

How reproducible:


Steps to Reproduce:
1.Install Fedora 26 Alpha
2.Select the minimal install option
3.Continue and finalize the installer

Actual results:
Install full gnome desktop

Expected results:
Install the minimal package

Additional info:

Comment 1 Martin Kolman 2017-04-28 09:45:17 UTC
This is most likely an issue with the Fedora comps, so reassigning.

Comment 2 Stephen Gallagher 2017-04-28 12:13:10 UTC
Where did you get the install media? Which version was it? The Workstation Edition netinstall? The Server Edition installer?

We need more information on exactly what you did. For example, what does "Select the minimal install option" mean?

Comment 3 Germán Ríos González 2017-04-28 13:58:40 UTC
(In reply to Stephen Gallagher from comment #2)
> Where did you get the install media? Which version was it? The Workstation
> Edition netinstall? The Server Edition installer?
> 
> We need more information on exactly what you did. For example, what does
> "Select the minimal install option" mean?

Hi Mr. Gallagher, I took the media from the fedora page https://getfedora.org/workstation/prerelease/ and download the 64bit version of the workstation net install.

With minimal installation I mean when you are in the installer and selects "SOFTWARE SELECTION" then in the section "Base Environment" select the radio button "Minimal Install" or "Fedora Custom Operating System", from Fedora 15 to 25 when you select the minimal install only gets the basic stuff and you can from there install a desktop or whatever you want.

Comment 4 Stephen Gallagher 2017-04-28 17:34:59 UTC
Reassigning to Anaconda. Looks to me like what is happening is that when you select a different environment group under "SOFTWARE SELECTION", it's actually adding the packages for that environment group to the list, rather than replacing the list that's already enqueued for installation.

In my test just now, I intentionally tried installing on a VM with too little disk space to install Workstation. I set the selection to "Fedora Custom Operating System" and it told me that I needed 1.1GiB more space to install. I then switched to "Fedora Server" and it suddenly needed 1.5GiB more space. Back to "Fedora Custom" and it again needs 1.5GiB.

I tried with "Development and Creative Workstation" and it needs 5.96GiB. Back to "Fedora Custom" and it still needs 5.96GiB.

Comment 5 Fedora Blocker Bugs Application 2017-04-28 17:38:03 UTC
Proposed as a Blocker for 26-beta by Fedora user sgallagh using the blocker tracking app because:

 "When installing with the generic network install image, interactively selecting a package set other than the default must work... "Work" means that the mechanism for selecting different package sets must work: the packages in the set chosen must actually be correctly selected for installation."

Comment 6 Adam Williamson 2017-04-28 19:26:28 UTC
Can confirm this - in fact openQA hits it, just doesn't notice there's a problem:

https://openqa.fedoraproject.org/tests/88501

that's the 'minimal package set' test, run from the Server DVD (so the default selected package set was Server, but the test changes it to "Fedora Custom Operating System", i.e. minimal). It completes and boots fine so openQA thinks it's fine, but if you look at the installed packages log file:

https://openqa.fedoraproject.org/tests/88501/file/_collect_data-rpms.log

it's got lots of stuff that's clearly from Server, not minimal, like abrt and cockpit. You can compare to the list from a *real* minimal install (from the Everything netinst):

https://openqa.fedoraproject.org/tests/88462/file/_collect_data-rpms.log

I guess I'll file an issue for openQA to make the 'minimal package set' test somehow try and check it was *really* the 'minimal package set' that got installed...

+1 blocker per the criterion sgallagh cited. Thanks for catching this.

Comment 7 Geoffrey Marr 2017-05-01 18:26:00 UTC
Discussed during the 2017-05-01 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as it violates the following blocker criteria:

"When installing with the generic network install image, interactively selecting a package set other than the default must work..."

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-05-01/f26-blocker-review.2017-05-01-16.02.txt

Comment 8 Adam Williamson 2017-05-01 22:50:27 UTC
I'm wondering if the fix for https://bugzilla.redhat.com/show_bug.cgi?id=1404158 - "Fix partial kickstart software selection in GUI (#1404158)", commit 012fe32eff1d3291a1f36a24f5a906f12ba01141 on f26-devel, 59bf385a9250c883f4acb81140fefe6d4f62e82b on master - could be related here? jkonecny?

Comment 9 Jiri Konecny 2017-05-02 14:09:16 UTC
No this is not related. That code is not even present on F26 alpha.

I'm not aware of any change in Anaconda which can cause this. I'll try to dig deeply and find what is causing this.

Comment 10 Jiri Konecny 2017-05-03 16:16:29 UTC
It looks to me like a bug in the DNF API, more precisely the 'reset()' method.

When an environment is changed we are calling 'Base.reset(goal=True)' and it should remove the selected packages, if I understand it correctly. However, from pdb it looks like Base.transaction.install_set is still full of packages after this call.

I'm switching this to DNF. Could you please look on that and verify if this is really an issue of DNF 2.3.0?

Comment 11 Jaroslav Mracek 2017-05-04 18:21:59 UTC
Please can you confirm that the problem appears with dnf-2.x? According my first look, the base.transaction object is filled after resolve() and it is not empty  after Base.reset(), because it deletes goal but the goal was already transformed into transaction therefore it doesn't change already filled transaction (two in depend objects).

Comment 12 Jaroslav Mracek 2017-05-05 11:06:40 UTC
Here is the PR that should solve a problem: https://github.com/rpm-software-management/dnf/pull/803

Comment 13 Jiri Konecny 2017-05-05 11:21:02 UTC
Tested, the patch should work properly.

Nice co-operation Jaroslav, good work.

Comment 14 Fedora Update System 2017-05-11 08:59:17 UTC
dnf-2.4.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e0fa49ff81

Comment 15 Fedora Update System 2017-05-13 01:10:50 UTC
dnf-2.4.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e0fa49ff81

Comment 16 Fedora Update System 2017-05-14 20:19:45 UTC
dnf-2.4.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Adam Williamson 2017-05-15 23:18:11 UTC
Looks like we can confirm the fix for this from openQA testing: the post-install package list for the openQA 'minimal package set install' test now *does* look like the minimal package set (and not the Server package set, as it was before due to this bug).


Note You need to log in before you can comment on or make changes to this bug.