Bug 144659 - Cannot retrieve photos from digital camera as a user using gphoto2 ... Works fine with root.
Summary: Cannot retrieve photos from digital camera as a user using gphoto2 ... Works ...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
(Show other bugs)
Version: 3
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL: http://sourceforge.net/mailarchive/fo...
Whiteboard:
Keywords:
: 144761 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-10 14:06 UTC by Mat
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 09:01:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed usbcam file with old lines commented out. (1.95 KB, text/plain)
2005-01-10 22:53 UTC, Mat
no flags Details

Description Mat 2005-01-10 14:06:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Connecting a Kodak 3400 digital camera - and it seems for other
models.  A user cannot retrieve files from the camera as a user in
FC3.  It will, however, work as root.

Someone posted a fix on the gphoto2 forums for FC3.  The file
/etc/hotplug/usb/usbcam file points to the wrong location for the
console lock file in FC3.



Version-Release number of selected component (if applicable):
Gphoto2 - 2.1.4 and 2.1.5

How reproducible:
Always

Steps to Reproduce:
1. Tried 3 seperate installions across 3 machines of Fedora Core 3.
2. Tried in default install and also logged into gnome & updated to
latest updates
3. Plug camera ( Kodak 3400 ) using a usbcable in and cannot retrieve
photos as a user.  Will work fine as root.

    

Actual Results:  gthumb ( seperate problem ) gives a message "The
filesystem doesn't support getting file information" and hangs when
trying to import the photos.

console.  gphoto2 -P ( get all photos ) - gives an error message for a
user.  As root will download the images off the camera.

Expected Results:  It should work as a user.

Additional info:

After I applied the suggested workaround / fix.  I can now use gtkam
and digikam or console gphoto2 -P to download the photos.  gthumb
which is the default program for gnome is broken for the kodak 3400 it
seems and a seperate bug.

Comment 1 Tim Waugh 2005-01-10 14:29:45 UTC
Please attach the usbcam script that you now have.

Comment 2 Mat 2005-01-10 22:53:31 UTC
Created attachment 109580 [details]
fixed usbcam file with old lines commented out.

Comment 3 Tim Waugh 2005-01-11 09:01:50 UTC
This is functionally identical to the usbcam we actually ship.  Since you
mention 2.1.5 above, it seems you probably installed from source and overwrote
it using the upstream version, not our fixed version packaged in the RPM.

Comment 4 Tim Waugh 2005-01-11 18:14:15 UTC
*** Bug 144761 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.