Bug 1446665 - ERROR: bi_list(): (5) Input/output error
Summary: ERROR: bi_list(): (5) Input/output error
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: 2.3
Assignee: Matt Benjamin (redhat)
QA Contact: shilpa
Erin Donnelly
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1437916
TreeView+ depends on / blocked
 
Reported: 2017-04-28 14:30 UTC by Vikhyat Umrao
Modified: 2017-07-30 15:51 UTC (History)
11 users (show)

(edit)
.bi-list operations now perform as expected

Previously, the addition of new bucket index key ranges for multi-site replication induced an unintended bucket index entry decoding problem in the `bi-list operation`, which is now used during bucket resharding. Consequently, bucket resharding failed when multi-site replication was used.

The logic has been changed in the `bi-list` operation to resolve this bug, and `bi-list` operations can be performed as expected when multi-site replication is used.
Clone Of:
(edit)
Last Closed: 2017-06-19 13:32:35 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC
Ceph Project Bug Tracker 19876 None None None 2017-05-05 19:44 UTC

Description Vikhyat Umrao 2017-04-28 14:30:15 UTC
Description of problem:
ERROR: bi_list(): (5) Input/output error


Version-Release number of selected component (if applicable):
Red Hat Ceph Storage 2.2

How reproducible:
Always in the customer environment 

Steps to Reproduce:
# date; radosgw-admin bi list --bucket=test1 > test1.bi.list
Fri Apr 28 13:27:02 UTC 2017
2017-04-28 13:27:02.499190 7fd07e7229c0  0 error in read_id for id  : (2) No such file or directory
2017-04-28 13:27:02.500445 7fd07e7229c0  0 error in read_id for id  : (2) No such file or directory
ERROR: bi_list(): (5) Input/output error

If we check above command output the time command ran was'Apr 28 13:27:02' if we check exact command timing '2017-04-28 13:27:02.500445'.

and if we check the log last time stamp for above time.

2017-04-28 13:27:02.457201 7fc711fdf700 1 -- 192.168.124.218:0/3530236345 <== osd.153 192.168.82.87:6811/10671 12 ==== osd_op_reply(680 notify.6 [watch ping cookie 140498289426864 gen 1] v0'0 uv1 ondisk = 0) v7 ==== 128+0+0 (2694835397 0 0) 0x7fc798000f90 con 0x7fc81807cb40

This above log is just before the command 'bi list' run and after this, we have kind of pause for 4 seconds and we do not have any log for 4 seconds and then we have the first log as 'RGWDataChangesLog::ChangesRenewThread: start'.

2017-04-28 13:27:06.528321 7fc7b17fa700 2 RGWDataChangesLog::ChangesRenewThread: start

Comment 37 shilpa 2017-05-24 06:32:18 UTC
Verified on ceph-radosgw-10.2.7-16

Comment 41 errata-xmlrpc 2017-06-19 13:32:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.