Bug 144724 - firefox doesn't like IPv6
Summary: firefox doesn't like IPv6
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: rawhide
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-10 22:50 UTC by G.Wolfe Woodbury
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 19:13:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description G.Wolfe Woodbury 2005-01-10 22:50:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Fresh install of rawhide 2005.01.09 on AMD k6-2@400MHz (320MB RAM
other standard hardware)

Running firefox with IPv6 enabled causes firefox to consume large
amounts of CPU without opening a window in 10+ minutes of running.

Disabling ipv6 (net-pf-10 off) allows firefox to run quite well.

Version-Release number of selected component (if applicable):
firefox-1.0-8

How reproducible:
Always

Steps to Reproduce:
1. fresh install of rawhide (2005.01.09)
2. default setup
3. try to run firefox
    

Actual Results:  firefox "hangs" consuming CPU time and not timeing out

Expected Results:  firefox should open a window and proceed normally

Additional info:

Comment 1 Warren Togami 2005-02-24 00:36:40 UTC
David can you reproduce this?  I know you use ipv6.


Comment 2 David Woodhouse 2005-02-24 00:51:19 UTC
Firefox is running fine here on rawhide here with IPv6 support present. Both
when I have a global IPv6 address and without. Suggest you use strace or GDB to
see what it's doing.

I haven't tried rawhide on anything but ppc, but I see no reason why i386 should
be different in this respect.

Comment 3 Matthew Miller 2005-02-24 01:18:09 UTC
David -- did you have firefox running *before* 1.0-8 on this system? (See bug
#145806)

Comment 4 David Woodhouse 2005-02-24 01:33:26 UTC
Yes. I've had firefox on this system since 0.10.1-1.0PR1.21 when the PPC build
was fixed (bug #135225)


Note You need to log in before you can comment on or make changes to this bug.