Bug 145806 - Firefox is not starting in rawhide.
Firefox is not starting in rawhide.
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Christopher Aillon
: 146604 149504 (view as bug list)
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
Reported: 2005-01-21 14:58 EST by Daniel Walsh
Modified: 2007-11-30 17:10 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-28 10:27:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2005-01-21 14:58:27 EST
Description of problem:
Firefox does not work in rawhide.

Version-Release number of selected component (if applicable):

How reproducible:
Two separate machines show the same problem

Steps to Reproduce:
1.  Run firefox
Actual results:

Doesn't start
Expected results:

Additional info:
Comment 1 Florian La Roche 2005-01-26 17:30:39 EST
Also happening for me with a reinstall from FC devel from today.
mozilla is ok. no plugins.
Comment 2 Florian La Roche 2005-01-27 06:16:22 EST
Downgrading to the previous version without the language packs in
fc4 works for me.
Comment 3 Christopher Aillon 2005-01-30 09:56:49 EST
*** Bug 146604 has been marked as a duplicate of this bug. ***
Comment 4 Ralf Ertzinger 2005-02-05 07:48:49 EST
JFI, firefox-1.0-8 works fine on my rawhide system (rawhide as of
today, as far as the broken deps allow it)
Comment 5 Alexandre Oliva 2005-02-08 03:12:14 EST
FWIW, I ran into this problem shortly after I installed rawhide, about
two weeks ago, so I went back to FC3's firefox.  Today I figured I'd
try to debug it a bit, so I upgraded to rawhide's firefox, along with
the rest of 20050207 rawhide, started it and, voila, no problem. 
Could it be that it was already fixed elsewhere?  Or is it some form
of race condition and I'd better should keep the old firefox handy?
Comment 6 Brian Gerst 2005-02-08 08:35:11 EST
Still doesn't work on x86_64.
Comment 7 Daniel Walsh 2005-02-08 11:20:26 EST
No the bug is on fresh installs.  If you upgrade from a previous
version of Firefox, it works.  On a first time install it freezes.
Comment 8 Alexandre Oliva 2005-02-08 21:47:25 EST
How do you qualify first-time install?  I did an x86_64 everything
install of rawhide about two weeks ago.  It didn't work.  I removed
firefox.x86_64 and installed firefox.i386.  It didn't work.  I went
back to FC3's firefox.i386.  It works.  Yesterday, I updated to
rawhide's firefox.i386, and it works.  If it fails only for first-time
installs, how come when I installed firefox.i386 it failed?  Are you
saying that, if I rpm -e firefox and up2date -i firefox again, it will
fail again, even though it's not right after a full install?  I'll try
that later.
Comment 9 Daniel Walsh 2005-02-09 09:23:49 EST
Yes I believe if you install the new firefox with out a previous
working firefox on the machine it will not work.  If you install the
FC3 firefox and update to the latest, then it works.

Comment 10 Brian Gerst 2005-02-09 10:36:26 EST
I did this:
rpm -e firefox
rpm -ihv firefox-0.10.1-1.0PR1.20.x86_64.rpm
rpm -Uhv firefox-1.0-8.x86_64.rpm

... and it still doesn't start.  If I use the i386 rpms it does the
same thing.  But, the i386 rpm does work ok on a 32-bit kernel.  Could
it be an x86-64 specific kernel bug (threading, IPC) we're hitting?  I
am using a vanilla 2.6.11-rc2 kernel.

strace shows it stuck in a loop:
write(7, "8", 1)                        = 1
futex(0x604820, FUTEX_WAKE, 1)          = 1
futex(0x2aaaaff0204c, FUTEX_WAKE, 1)    = 1
futex(0x2aaaaff02048, FUTEX_WAKE, 1)    = 1
read(4, "\372", 1)                      = 1
ioctl(3, FIONREAD, [0])                 = 0
poll([{fd=3, events=POLLIN}, {fd=8, events=POLLIN}, {fd=12,
events=POLLIN|POLLPRI}, {fd=14, events=POLLIN|POLLPRI}, {fd=15,
events=POLLIN|POLLPRI}, {fd=16, events=POLLIN|POLLPRI}, {fd=17,
events=POLLIN}, {fd=4, events=POLLIN, revents=POLLIN}], 8, -1) = 1
Comment 11 Alexandre Oliva 2005-02-09 11:31:15 EST
Same here (except that I was playing with the i386 builds of firefox,
and I was using the latest update as the FC3 package).

However, after running commands similar to yours, I ran:

rpm -U --oldpackage firefox*FC3*.i386.rpm
rpm -U firefox-1.0-8.i386.rpm

and then it worked.

However, comparing the files listed in rpm -ql firefox before and
after this pair of upgrades, no change is there (I tarred them up).

So it must be something in the %post/%pre(un)?install scripts that is
getting it wrong.
Comment 12 Warren Togami 2005-02-22 02:42:39 EST
Isn't the issue that firefox FC4 is failing if you do not have a previous
firefox profile?
Comment 14 Matthew Miller 2005-02-22 11:34:56 EST
No, it seems to be something systemwide. Having a previous profile copied from a
working system doesn't help.
Comment 15 Warren Togami 2005-02-23 12:55:35 EST
*** Bug 149504 has been marked as a duplicate of this bug. ***
Comment 16 Matthew Miller 2005-02-24 15:35:55 EST
FWIW, I rebuilt the rpm with the new langpack-installing part commented out of
the specfile, and after installing the resulting rpm, it runs fine.
Comment 17 Christopher Aillon 2005-02-27 22:50:57 EST
I commented out the langpack fu for now in rawhide  1.0.1-1 should have this
fix.  Does it work again?
Comment 18 Brian Gerst 2005-02-28 00:59:44 EST
1.0.1-1 works for me (x86-64)
Comment 19 shrek-m 2005-02-28 04:06:41 EST
1.0.1-1 ppc is ok after a new login

# grep firefox /var/log/yum.log
Feb 28 08:49:37 Updated: firefox.ppc 1.0.1-1
Feb 28 08:49:43 Updated: firefox.ppc 1.0.1-1
Comment 20 Christopher Aillon 2005-02-28 10:27:52 EST
Ok.  Marking RAWHIDE.  Now to figure out why the langpack stuff isn't working =(
Comment 21 Jens Petersen 2005-03-18 03:39:54 EST
The langpacks work in RHEL 4, so why not in FC3 or devel? 
Comment 22 Christopher Aillon 2005-03-18 11:56:25 EST
Not sure.  File a bug to re-add them though.

Note You need to log in before you can comment on or make changes to this bug.