Bug 1447458 - Timer unit can't be properly activated
Summary: Timer unit can't be properly activated
Keywords:
Status: CLOSED DUPLICATE of bug 1439957
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: certbot
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: James Hogarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-02 21:08 UTC by Anatole Denis
Modified: 2017-05-02 21:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-02 21:19:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Anatole Denis 2017-05-02 21:08:59 UTC
Description of problem:

There is a typo in certbot-renew.timer, the line

WantedBy=timer.target

refers to a nonexisting target. It should be

WantedBy=timers.target

As a consequence enabling the timer unit doesn't ensure it is started appropriately on boot

Version-Release number of selected component (if applicable): 0.13.0-2.el7

How reproducible: always


Steps to Reproduce:
1. Enable the certbot-renew.timer unit
2. Restart timers.target or the machine

Actual results:

The timer unit is not started (systemctl status certbot-renew.timer or systemctl list-timers)

Expected results:

The timer unit is started and appears in systemctl list-timers

Comment 1 Anatole Denis 2017-05-02 21:19:15 UTC
Sorry I completely forgot to check whether it was fixed in updates-testing (and it is)

All my apologies for the spam

*** This bug has been marked as a duplicate of bug 1439957 ***


Note You need to log in before you can comment on or make changes to this bug.