Bug 14475 - option dialogs of option dialogs can't be brought to front
Summary: option dialogs of option dialogs can't be brought to front
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard: Winston gold
Keywords:
: 14569 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-22 21:39 UTC by Trond Eivind Glomsrxd
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-31 18:20:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Trond Eivind Glomsrxd 2000-07-22 21:39:38 UTC
Sawfish, with "keep transient windows stacked above parents" selected.
First, select a gnome terminals option window with the right button. The
select the font chooser - this window can't be on top of the original
options window, making it hard to see what font you're choosing

Comment 1 Glen Foster 2000-07-30 19:24:48 UTC
This defect is considered MUST-FIX for Winston Gold-release

Comment 2 Havoc Pennington 2000-07-31 18:20:10 UTC
*** Bug 14569 has been marked as a duplicate of this bug. ***

Comment 3 Havoc Pennington 2000-07-31 21:00:49 UTC
Should be all fixed. Sawfish now allows windows TRANSIENT_FOR the root window to
go below their group, and also gnome-terminal now sets the settings dialog 
TRANSIENT_FOR the terminal instead of the root window. The font dialog is mildly
broken (should be transient for the settings dialog), but that is a separate
issue and is a known gnome-libs bug that requires binary compat breakage.

Comment 4 David Balažic 2000-08-09 14:48:17 UTC
Don't know if this is the same bug but :
In pinstripe GNOME desktop if I open gnorpm and gnome-terminal and
click on INSTALL in gnorpm , by that opening another window titled
"Install" which loads the contents of the inserted pinstripe CD 1,
and try to install a package that will have unresolved dependencies,
an error dialog will pop up. Now I put the gnome-terminal window on
top, but so that the title bars of the others are visible. I click
( left mouse button ) on the title bar of the "Install" window. It
should be brought to front , but it isn't !
If I right click on it , then it goes to background. If again right
click it ( or left , same effect ) the it comes up, but not all the
way. The order starting from the lowest is :
 - gnorpm main window
 - gnorpm Install window , the one I clicked
 - gnorpm "Dependency problems" dialog
 - GNOME-Terminal , still on the top !
I would expect the "Install" window on top or the error dialog,
but not gnome-terminal !

Please check this.


Comment 5 David Balažic 2001-02-07 15:23:20 UTC
My problem is fixed in Guiness ( RH 7.0 )


Note You need to log in before you can comment on or make changes to this bug.